Re: [PATCH v5 4/4] sparc64: Add support for ADI (Application Data Integrity)

2017-01-25 Thread Khalid Aziz
On 01/25/2017 03:50 PM, Rob Gardner wrote: On 01/25/2017 03:20 PM, Khalid Aziz wrote: On 01/25/2017 03:00 PM, Rob Gardner wrote: On 01/25/2017 12:57 PM, Khalid Aziz wrote: @@ -157,6 +158,24 @@ int __get_user_pages_fast(unsigned long start, int nr_pages, int write, pgd_t *pgdp; int

Re: [PATCH v5 4/4] sparc64: Add support for ADI (Application Data Integrity)

2017-01-25 Thread Rob Gardner
On 01/25/2017 03:20 PM, Khalid Aziz wrote: On 01/25/2017 03:00 PM, Rob Gardner wrote: On 01/25/2017 12:57 PM, Khalid Aziz wrote: @@ -157,6 +158,24 @@ int __get_user_pages_fast(unsigned long start, int nr_pages, int write, pgd_t *pgdp; int nr = 0; +#ifdef CONFIG_SPARC64 +if (a

[PATCH] watchdog: Introduce watchdog_stop_on_unregister helper

2017-01-25 Thread Guenter Roeck
Many watchdog drivers explicitly stop the watchdog when unregistering it. While it is unclear if this is actually needed (the whatdog should not be running at that time if it can be stopped), introduce a helper to explicitly stop the watchdog in the watchdog core when unregistering it. This helps r

Re: [PATCH v5 4/4] sparc64: Add support for ADI (Application Data Integrity)

2017-01-25 Thread Khalid Aziz
On 01/25/2017 03:00 PM, Rob Gardner wrote: On 01/25/2017 12:57 PM, Khalid Aziz wrote: @@ -157,6 +158,24 @@ int __get_user_pages_fast(unsigned long start, int nr_pages, int write, pgd_t *pgdp; int nr = 0; +#ifdef CONFIG_SPARC64 +if (adi_capable()) { +long addr = start;

Re: [PATCH v5 4/4] sparc64: Add support for ADI (Application Data Integrity)

2017-01-25 Thread David Miller
From: Rob Gardner Date: Wed, 25 Jan 2017 15:00:42 -0700 > Same comment here, and the various other places that employ this same > code construct. Please do not quote an entire huge patch just to comment on a small part of it. Quote only the minimum necessary context in order to provide your fee

Re: [PATCH v5 4/4] sparc64: Add support for ADI (Application Data Integrity)

2017-01-25 Thread Rob Gardner
On 01/25/2017 12:57 PM, Khalid Aziz wrote: ADI is a new feature supported on SPARC M7 and newer processors to allow hardware to catch rogue accesses to memory. ADI is supported for data fetches only and not instruction fetches. An app can enable ADI on its data pages, set version tags on them and

Re: [RFC PATCH v1 2/6] kernel-doc: replace kernel-doc perl parser with a pure python one (WIP)

2017-01-25 Thread Jani Nikula
On Wed, 25 Jan 2017, Markus Heiser wrote: > Am 25.01.2017 um 11:24 schrieb Jani Nikula : > >> Markus, thanks for your work on this. > > Thanks for your comments! > >> Excuse me for my bluntness, but I think changing everything in a single >> commit, or even a few commits, is strictly not acceptabl

[PATCH v5 0/4] Application Data Integrity feature introduced by SPARC M7

2017-01-25 Thread Khalid Aziz
SPARC M7 processor adds additional metadata for memory address space that can be used to secure access to regions of memory. This additional metadata is implemented as a 4-bit tag attached to each cacheline size block of memory. A task can set a tag on any number of such blocks. Access to such bloc

[PATCH v5 4/4] sparc64: Add support for ADI (Application Data Integrity)

2017-01-25 Thread Khalid Aziz
ADI is a new feature supported on SPARC M7 and newer processors to allow hardware to catch rogue accesses to memory. ADI is supported for data fetches only and not instruction fetches. An app can enable ADI on its data pages, set version tags on them and use versioned addresses to access the data p

Re: [RFC PATCH v1 2/6] kernel-doc: replace kernel-doc perl parser with a pure python one (WIP)

2017-01-25 Thread Markus Heiser
Am 25.01.2017 um 11:24 schrieb Jani Nikula : > Markus, thanks for your work on this. Thanks for your comments! > Excuse me for my bluntness, but I think changing everything in a single > commit, or even a few commits, is strictly not acceptable. OK, I understand. > When I changed *small* thin

[PATCH v4 2/4] arm64: Work around Falkor erratum 1003

2017-01-25 Thread Christopher Covington
The Qualcomm Datacenter Technologies Falkor v1 CPU may allocate TLB entries using an incorrect ASID when TTBRx_EL1 is being updated. When the erratum is triggered, page table entries using the new translation table base address (BADDR) will be allocated into the TLB using the old ASID. All circumst

[PATCH v4 4/4] arm64: Work around Falkor erratum 1009

2017-01-25 Thread Christopher Covington
During a TLB invalidate sequence targeting the inner shareable domain, Falkor may prematurely complete the DSB before all loads and stores using the old translation are observed. Instruction fetches are not subject to the conditions of this erratum. If the original code sequence includes multiple T

Re: [PATCH 1/2] security: Change name of CONFIG_DEBUG_RODATA

2017-01-25 Thread Pavel Machek
On Wed 2017-01-25 12:21:05, Laura Abbott wrote: > On 01/19/2017 08:53 AM, Pavel Machek wrote: > >On Wed 2017-01-18 17:29:05, Laura Abbott wrote: > >> > >>Despite the word 'debug' in CONFIG_DEBUG_RODATA, this kernel option > >>provides key security features that are to be expected on a modern > >>sy

Re: [PATCH 2/2] security: Change name of CONFIG_DEBUG_SET_MODULE_RONX

2017-01-25 Thread Laura Abbott
On 01/19/2017 12:43 PM, Robin Murphy wrote: Hi Laura, On 19/01/17 01:29, Laura Abbott wrote: Despite the word 'debug' in CONFIG_DEBUG_SET_MODULE_RONX, this kernel option provides key security features that are to be expected on a modern system. Change the name to CONFIG_HARDENED_MODULE_MAPPING

Re: [PATCH 1/2] security: Change name of CONFIG_DEBUG_RODATA

2017-01-25 Thread Laura Abbott
On 01/19/2017 12:33 PM, Heiko Carstens wrote: On Thu, Jan 19, 2017 at 10:56:46AM +, Mark Rutland wrote: +config HARDENED_PAGE_MAPPINGS + bool "Mark kernel mappings with stricter permissions (RO/W^X)" + default y + depends on ARCH_HAS_HARDENED_MAPPINGS + help +

Re: [PATCH 1/2] security: Change name of CONFIG_DEBUG_RODATA

2017-01-25 Thread Laura Abbott
On 01/19/2017 11:56 AM, Mark Rutland wrote: Hi Laura, On Wed, Jan 18, 2017 at 05:29:05PM -0800, Laura Abbott wrote: Despite the word 'debug' in CONFIG_DEBUG_RODATA, this kernel option provides key security features that are to be expected on a modern system. Change the name to CONFIG_HARDENED_

Re: [PATCH 1/2] security: Change name of CONFIG_DEBUG_RODATA

2017-01-25 Thread Laura Abbott
On 01/19/2017 08:53 AM, Pavel Machek wrote: On Wed 2017-01-18 17:29:05, Laura Abbott wrote: Despite the word 'debug' in CONFIG_DEBUG_RODATA, this kernel option provides key security features that are to be expected on a modern system. Change the name to CONFIG_HARDENED_PAGE_MAPPINGS which more

Re: [RFC PATCH v1 2/6] kernel-doc: replace kernel-doc perl parser with a pure python one (WIP)

2017-01-25 Thread Daniel Vetter
On Wed, Jan 25, 2017 at 12:24:31PM +0200, Jani Nikula wrote: > Finally, while I'd love to see scripts/kernel-doc go, I do have to ask > if changing roughly 3k lines of Perl to roughly 3k lines of Python (*) > really makes everything better? They both still parse everything using a > large pile of r

Re: [RFC PATCH v1 2/6] kernel-doc: replace kernel-doc perl parser with a pure python one (WIP)

2017-01-25 Thread Jani Nikula
On Wed, 25 Jan 2017, Jonathan Corbet wrote: > On Tue, 24 Jan 2017 20:52:40 +0100 > Markus Heiser wrote: > >> This patch is the initial merge of a pure python implementation >> to parse kernel-doc comments and generate reST from. >> >> It consist mainly of to parts, the parser module (kerneldoc.p

Re: [RFC PATCH v1 3/6] kernel-doc: add kerneldoc-lint command

2017-01-25 Thread Jani Nikula
On Wed, 25 Jan 2017, Markus Heiser wrote: > Am 25.01.2017 um 09:21 schrieb Jani Nikula : >> Yes, see below. It's simplistic and it has an external dependency, but >> it got the job done. And it does not depend on Sphinx; it's just a >> kernel-doc and rst lint, not Sphinx lint. Whether that's a goo

Re: [RFC PATCH v1 3/6] kernel-doc: add kerneldoc-lint command

2017-01-25 Thread Markus Heiser
Am 25.01.2017 um 09:21 schrieb Jani Nikula : > Yes, see below. It's simplistic and it has an external dependency, but > it got the job done. And it does not depend on Sphinx; it's just a > kernel-doc and rst lint, not Sphinx lint. Whether that's a good or a bad > thing is debatable. > > Anyway, I

Re: [RFC PATCH v1 3/6] kernel-doc: add kerneldoc-lint command

2017-01-25 Thread Jani Nikula
On Wed, 25 Jan 2017, Daniel Vetter wrote: > On Tue, Jan 24, 2017 at 08:52:41PM +0100, Markus Heiser wrote: >> this patch adds a command to lint kernel-doc comments.:: >> >> scripts/kerneldoc-lint --help >> >> The lint check include (only) kernel-doc rules described at [1]. It >> does not check