Re: [PATCH 1/5] mmc: sdhci-esdhc-imx: add support for write protect on custom GPIO

2011-02-10 Thread Marc Reilly
Hi Wolfram, First three patches work well on my vpr200 board (mx35). One comment inline... I ran some tests of insert/remove card with the card locked and unlocked, and trying to append a file. It behaved as expected, thus: Tested-by: Marc Reilly > +static unsigned int esdhc_pltfm_get_ro(s

Re: [PATCH 5/5] OMAP: devices: Modify HSMMC device to adapt to hwmod framework

2011-02-10 Thread Kevin Hilman
"Kadiyala, Kishore" writes: [...] > >> >> The board code should simply call some mmc init routine optionally >> passing int the platform_data, just like is done for hsmmc_init. >> >> With common hwmod data, shouldn't it be possible to unify the init of >> MMC and HS-MMC controllers? > > The init

Re: [PATCH 1/5] OMAP2420: hwmod data: Add HSMMC

2011-02-10 Thread Paul Walmsley
On Thu, 10 Feb 2011, Kadiyala, Kishore wrote: > On Wed, Feb 9, 2011 at 4:59 AM, Paul Walmsley wrote: > > On Wed, 2 Feb 2011, Kishore Kadiyala wrote: > > > >> Update the omap2420 hwmod data with the HSMMC info. > > > > Umm, this doesn't look right.  OMAP2420 doesn't have an HSMMC block as far > >

Re: [PATCH] mmc: Ensure prototypes for SD API are visible in sd.c

2011-02-10 Thread Chris Ball
Hi Mark, On Thu, Feb 10, 2011 at 10:58:37AM +, Mark Brown wrote: > So we know the implementation and prototypes agree with each other. > > Signed-off-by: Mark Brown > --- > drivers/mmc/core/sd.c |1 + > 1 files changed, 1 insertions(+), 0 deletions(-) > > diff --git a/drivers/mmc/core/

Re: [PATCH] mmc: Improve MMC_TEST config text.

2011-02-10 Thread Chris Ball
Hi, On Thu, Feb 10, 2011 at 10:41:02AM +, Will Newton wrote: > The test file is created under debugfs, not sysfs. Also remove > the unnecessary default n. > > Signed-off-by: Will Newton > --- > drivers/mmc/card/Kconfig |3 +-- > 1 files changed, 1 insertions(+), 2 deletions(-) > > diff

Re: [PATCH 2/2] dw_mmc: Enable low-power mode for the card clock.

2011-02-10 Thread Chris Ball
Hi, On Thu, Feb 10, 2011 at 10:40:57AM +, Will Newton wrote: > Setting this bit in the clock enable register will stop the clock > when the card is in the IDLE state. > > Signed-off-by: Will Newton > --- > drivers/mmc/host/dw_mmc.c |3 ++- > 1 files changed, 2 insertions(+), 1 deletions

Re: [PATCH 1/2] dw_mmc: Run card detect tasklet during slot initialisation.

2011-02-10 Thread Chris Ball
Hi Will, On Thu, Feb 10, 2011 at 10:40:42AM +, Will Newton wrote: > We need to run the card detect tasklet at the end of slot initialisation > as it is possible that a card has been inserted prior to boot, so we don't > see an insertion interrupt and now the card is sitting there inserted but

Re: [PATCH 2/5] mmc: sdhci-esdhc: broken card detection is not a default quirk

2011-02-10 Thread Wolfram Sang
Adding Anton to Cc... On Thu, Feb 10, 2011 at 08:14:48PM +0100, Wolfram Sang wrote: > It can be worked around using a GPIO which will be done for i.MX later. > > Signed-off-by: Wolfram Sang > --- > drivers/mmc/host/sdhci-esdhc-imx.c |3 ++- > drivers/mmc/host/sdhci-esdhc.h |1 - >

[PATCH 4/5] arm: mach-mx3: pcm043: add write-protect and card-detect for SD1

2011-02-10 Thread Wolfram Sang
Signed-off-by: Wolfram Sang --- arch/arm/mach-mx3/mach-pcm043.c | 13 - 1 files changed, 12 insertions(+), 1 deletions(-) diff --git a/arch/arm/mach-mx3/mach-pcm043.c b/arch/arm/mach-mx3/mach-pcm043.c index bcf83fc..26b686c 100644 --- a/arch/arm/mach-mx3/mach-pcm043.c +++ b/arch/ar

[PATCH 3/5] mmc: sdhci-esdhc-imx: add card detect on custom GPIO

2011-02-10 Thread Wolfram Sang
Signed-off-by: Wolfram Sang --- arch/arm/plat-mxc/include/mach/esdhc.h |2 + drivers/mmc/host/sdhci-esdhc-imx.c | 75 2 files changed, 77 insertions(+), 0 deletions(-) diff --git a/arch/arm/plat-mxc/include/mach/esdhc.h b/arch/arm/plat-mxc/include/mach

[PATCH 0/5] sdhci-esdhc-imx: use gpio for write protection and card detection

2011-02-10 Thread Wolfram Sang
Hi, I finally could do a second version of my write protect-patches and the first version of a card detect approach (thanks to Olof for the inspiration here). Note that these feature are only needed for i.mx25/35 as the i.mx5x-series _finally_ seem to be able to route the gpios to the controller d

[PATCH 5/5] arm: mach-mx3: use IMX_GPIO_NR instead of hard-coded values

2011-02-10 Thread Wolfram Sang
The latter are error-prone because the bank number is one less than one would read in the documentation. Signed-off-by: Wolfram Sang Cc: Eric Bénard Cc: Sascha Hauer --- arch/arm/mach-mx3/eukrea_mbimxsd-baseboard.c |4 ++-- arch/arm/mach-mx3/mach-cpuimx35.c|2 +- arch/arm/m

[PATCH 1/5] mmc: sdhci-esdhc-imx: add support for write protect on custom GPIO

2011-02-10 Thread Wolfram Sang
Signed-off-by: Wolfram Sang --- arch/arm/plat-mxc/include/mach/esdhc.h | 10 +- drivers/mmc/host/sdhci-esdhc-imx.c | 51 +--- 2 files changed, 49 insertions(+), 12 deletions(-) diff --git a/arch/arm/plat-mxc/include/mach/esdhc.h b/arch/arm/plat-mxc/includ

[PATCH 2/5] mmc: sdhci-esdhc: broken card detection is not a default quirk

2011-02-10 Thread Wolfram Sang
It can be worked around using a GPIO which will be done for i.MX later. Signed-off-by: Wolfram Sang --- drivers/mmc/host/sdhci-esdhc-imx.c |3 ++- drivers/mmc/host/sdhci-esdhc.h |1 - drivers/mmc/host/sdhci-of-esdhc.c |3 ++- 3 files changed, 4 insertions(+), 3 deletions(-) dif

McEx/ASSD protocols

2011-02-10 Thread Giuseppe Cavallaro
Hello. I wonder if somebody could help me to understand if both the Advanced Security SD (ASSD) protocol http://www.sdcard.org/developers/tech/ASSD/ and the M-Commerce Extension Specification 1.10 are supported in Linux. Welcome advice and comments. Many thanks in advance. Kind Regards Pippo

Re: [PATCH 1/7] mmc: mxs-mmc: add mmc host driver for i.MX23/28

2011-02-10 Thread Arnd Bergmann
On Friday 11 February 2011, Shawn Guo wrote: > > > > + struct resource *res; > > > + struct resource *dma_res; > > > + struct clk *clk; > > > > are visible in the parent. > > > It seems this is a generally used approach, seen in mxcmmc and pxa

Re: [PATCH 5/5] OMAP: devices: Modify HSMMC device to adapt to hwmod framework

2011-02-10 Thread Kadiyala, Kishore
On Wed, Feb 9, 2011 at 4:35 AM, Kevin Hilman wrote: > Kishore Kadiyala writes: > >> Changes involves: >> 1) Remove controller reset in devices.c which is taken care >>    by hwmod framework. >> 2) Removing all base address macro defines. >> 3) Using omap-device layer to register device and utiliz

Re: [PATCH 1/5] OMAP2420: hwmod data: Add HSMMC

2011-02-10 Thread Kadiyala, Kishore
Hi Paul, On Wed, Feb 9, 2011 at 4:59 AM, Paul Walmsley wrote: > On Wed, 2 Feb 2011, Kishore Kadiyala wrote: > >> Update the omap2420 hwmod data with the HSMMC info. > > Umm, this doesn't look right.  OMAP2420 doesn't have an HSMMC block as far > as I know.  It also uses a different driver than la

[PATCH] mmc: sdhci-tegra: free irq on error and remove

2011-02-10 Thread Wolfram Sang
Signed-off-by: Wolfram Sang Cc: Olof Johansson Cc: Chris Ball --- Found the leak while working on the esdhc-imx driver. Not even compile tested, please check. drivers/mmc/host/sdhci-tegra.c |6 +- 1 files changed, 5 insertions(+), 1 deletions(-) diff --git a/drivers/mmc/host/sdhci-te

Re: [PATCH 1/5] OMAP2420: hwmod data: Add HSMMC

2011-02-10 Thread Kadiyala, Kishore
On Wed, Feb 9, 2011 at 4:06 AM, Kevin Hilman wrote: > Kishore Kadiyala writes: > >> Update the omap2420 hwmod data with the HSMMC info. >> Add a device attribute structure which will be used >> by the host driver to find whether the HSMMC controller >> supports DUAL VOLT cards. >> >> Signed-off-b

Re: [PATCH 3/5] OMAP3: hwmod data: Add HSMMC

2011-02-10 Thread Kadiyala, Kishore
Hi Kevin, On Wed, Feb 9, 2011 at 4:00 AM, Kevin Hilman wrote: > Kishore Kadiyala writes: > >> From: Paul Walmsley >> >> Update the omap3 hwmod data with the HSMMC info. >> >> Signed-off-by: Paul Walmsley >> Signed-off-by: Kevin Hilman >> Signed-off-by: Rajendra Nayak >> Signed-off-by: Kishor

Re: [PATCH 1/7] mmc: mxs-mmc: add mmc host driver for i.MX23/28

2011-02-10 Thread Shawn Guo
Hi Arnd, Sorry for the late response. It really took me some time to address your comments, especially about using mmc core completion to save the one in the driver. On Fri, Feb 04, 2011 at 09:26:52PM +0100, Arnd Bergmann wrote: > On Saturday 05 February 2011 03:18:41 Shawn Guo wrote: > > This a

[PATCH 06/11] sh_mmcif: rename and retype activity variable

2011-02-10 Thread Linus Walleij
The host_sglen is now actually used to keep track of whether DMA is active or not, so rename and retype it to bool. Signed-off-by: Linus Walleij --- drivers/mmc/host/sh_mmcif.c | 18 +- 1 files changed, 9 insertions(+), 9 deletions(-) diff --git a/drivers/mmc/host/sh_mmcif.c b

[PATCH 07/11] sh_mmcif: use dmaengine helpers, drop submit check

2011-02-10 Thread Linus Walleij
Use the new dmaengine helper functions, and drop the error check on the returned cookier from the dmaengine - we recently established that this is really not allowed to fail. Signed-off-by: Linus Walleij --- drivers/mmc/host/sh_mmcif.c | 22 ++ 1 files changed, 6 insertions

[PATCH 11/11] tmio_mmc: use dmaengine helpers, drop submit check

2011-02-10 Thread Linus Walleij
Use the new dmaengine helper functions, and drop the error check on the returned cookier from the dmaengine - we recently established that this is really not allowed to fail. Signed-off-by: Linus Walleij --- drivers/mmc/host/tmio_mmc.c | 17 - 1 files changed, 4 insertions(+),

[PATCH 08/11] tmio_mmc: map DMA buffers on the DMA engine device

2011-02-10 Thread Linus Walleij
As established for the MMCI, it is proper to map the DMA buffers on the DMA engine which is the one actually performing the DMA. Signed-off-by: Linus Walleij --- drivers/mmc/host/tmio_mmc.c | 10 ++ 1 files changed, 6 insertions(+), 4 deletions(-) diff --git a/drivers/mmc/host/tmio_mm

[PATCH 04/11] sh_mmcif: map DMA buffers on the DMA engine device

2011-02-10 Thread Linus Walleij
As established for the MMCI, it is proper to map the DMA buffers on the DMA engine which is the one actually performing the DMA. Signed-off-by: Linus Walleij --- drivers/mmc/host/sh_mmcif.c | 12 1 files changed, 8 insertions(+), 4 deletions(-) diff --git a/drivers/mmc/host/sh_mm

[PATCH 10/11] tmio_mmc: drop dma_sglen state variable

2011-02-10 Thread Linus Walleij
This variable doesn't seem to be used for anything after the other patches so just drop it. Signed-off-by: Linus Walleij --- drivers/mmc/host/tmio_mmc.c |9 ++--- 1 files changed, 2 insertions(+), 7 deletions(-) diff --git a/drivers/mmc/host/tmio_mmc.c b/drivers/mmc/host/tmio_mmc.c inde

[PATCH 01/11] atmel-mci: map DMA sglist on the DMA engine

2011-02-10 Thread Linus Walleij
As established for the MMCI, it is proper to map the DMA buffers on the DMA engine which is the one actually performing the DMA. Signed-off-by: Linus Walleij --- drivers/mmc/host/atmel-mci.c |8 +--- 1 files changed, 5 insertions(+), 3 deletions(-) diff --git a/drivers/mmc/host/atmel-mc

[PATCH 02/11] atmel-mci: conform to DMA-API

2011-02-10 Thread Linus Walleij
Fixes the following: - It is perfectly legal for the dma_map_sg() to return fewer entries than were passed in. - Supply the returned numer of (possibly coalesced) entries to the device_pre_slave_sg() function. - Use the proper original sg_len when unmapping the sglist in the error path. Sign

[PATCH 03/11] atmel-mci: use dmaengine helper functions

2011-02-10 Thread Linus Walleij
Use the new dmaengine helpers to make the code more readable. Signed-off-by: Linus Walleij --- drivers/mmc/host/atmel-mci.c |6 +++--- 1 files changed, 3 insertions(+), 3 deletions(-) diff --git a/drivers/mmc/host/atmel-mci.c b/drivers/mmc/host/atmel-mci.c index df5a135..80bc9a5 100644 ---

[PATCH 05/11] sh_mmcif: unmap with the proper sglen

2011-02-10 Thread Linus Walleij
According to the DMA-API you shall unmap the sglists with the same sglist length as passed into the mapping function, not the returned value from the mapping function. Signed-off-by: Linus Walleij --- drivers/mmc/host/sh_mmcif.c |4 ++-- 1 files changed, 2 insertions(+), 2 deletions(-) diff

[PATCH 09/11] tmio_mmc: unmap with the proper sglen

2011-02-10 Thread Linus Walleij
According to the DMA-API you shall unmap the sglists with the same sglist length as passed into the mapping function, not the returned value from the mapping function. Signed-off-by: Linus Walleij --- drivers/mmc/host/tmio_mmc.c |4 ++-- 1 files changed, 2 insertions(+), 2 deletions(-) diff

[PATCH 00/11] MMC DMA-API/dmaengine fixups

2011-02-10 Thread Linus Walleij
This patch series fixes a number of DMA-API and dmaengine issues that we encountered while working with the recent changes to the MMCI/PL180 driver. It'd be bad to leave bad examples around like this. It's hard for me to regression-compile this let alone test these so ACK:s from maintainers would

Re: [PATCH 02/11] atmel-mci: conform to DMA-API

2011-02-10 Thread Nicolas Ferre
Le 10/02/2011 16:08, Linus Walleij : > Fixes the following: > - It is perfectly legal for the dma_map_sg() to return fewer > entries than were passed in. > - Supply the returned numer of (possibly coalesced) entries to > the device_pre_slave_sg() function. > - Use the proper original sg_len whe

Re: [PATCH 01/11] atmel-mci: map DMA sglist on the DMA engine

2011-02-10 Thread Nicolas Ferre
Le 10/02/2011 16:08, Linus Walleij : > As established for the MMCI, it is proper to map the DMA buffers > on the DMA engine which is the one actually performing the DMA. > > Signed-off-by: Linus Walleij Signed-off-by: Nicolas Ferre > --- > drivers/mmc/host/atmel-mci.c |8 +--- > 1 fil

Re: [PATCH 03/11] atmel-mci: use dmaengine helper functions

2011-02-10 Thread Nicolas Ferre
Le 10/02/2011 16:08, Linus Walleij : > Use the new dmaengine helpers to make the code more readable. > > Signed-off-by: Linus Walleij Signed-off-by: Nicolas Ferre > --- Thanks for this update Linus! (That was on my todo list ;-)) Best regards, > drivers/mmc/host/atmel-mci.c |6 +++--- >

Re: [PATCH v2 0/5] OMAP: HSMMC: hwmod adaptation

2011-02-10 Thread Krishnamoorthy, Balaji T
On Wed, Feb 9, 2011 at 5:14 AM, Tony Lindgren wrote: > * Kishore Kadiyala [110208 12:45]: >> Adding hwmod data for hsmmc device on OMAP2420/OMAP2430/OMAP3/OMAP4. >> Adapting the omap_hsmmc driver to hwmod framework >> >> V2: >> --- >> Updated hwmod data for OMAP2420 & OMAP2430. >> >> The patch se

[PATCH] mmc: Ensure prototypes for SD API are visible in sd.c

2011-02-10 Thread Mark Brown
So we know the implementation and prototypes agree with each other. Signed-off-by: Mark Brown --- drivers/mmc/core/sd.c |1 + 1 files changed, 1 insertions(+), 0 deletions(-) diff --git a/drivers/mmc/core/sd.c b/drivers/mmc/core/sd.c index d18c32b..6dac89f 100644 --- a/drivers/mmc/core/sd.c

[PATCH] mmc: Improve MMC_TEST config text.

2011-02-10 Thread Will Newton
The test file is created under debugfs, not sysfs. Also remove the unnecessary default n. Signed-off-by: Will Newton --- drivers/mmc/card/Kconfig |3 +-- 1 files changed, 1 insertions(+), 2 deletions(-) diff --git a/drivers/mmc/card/Kconfig b/drivers/mmc/card/Kconfig index 2a876c4..3b1f783

[PATCH 2/2] dw_mmc: Enable low-power mode for the card clock.

2011-02-10 Thread Will Newton
Setting this bit in the clock enable register will stop the clock when the card is in the IDLE state. Signed-off-by: Will Newton --- drivers/mmc/host/dw_mmc.c |3 ++- 1 files changed, 2 insertions(+), 1 deletions(-) diff --git a/drivers/mmc/host/dw_mmc.c b/drivers/mmc/host/dw_mmc.c index 0b

[PATCH 1/2] dw_mmc: Run card detect tasklet during slot initialisation.

2011-02-10 Thread Will Newton
We need to run the card detect tasklet at the end of slot initialisation as it is possible that a card has been inserted prior to boot, so we don't see an insertion interrupt and now the card is sitting there inserted but with no power to it. Signed-off-by: Neil Jones Signed-off-by: Will Newton