Re: [PATCH v11] mmc : general purpose partition support.

2011-10-05 Thread Adrian Hunter
On 05/10/11 18:33, Andrei Warkentin wrote: Hi, - Original Message - From: "Namjae Jeon" To: c...@laptop.org, linux-mmc@vger.kernel.org Cc: linux-ker...@vger.kernel.org, awarken...@vmware.com, "adrian hunter", "linus walleij" , "james p freyensee", seb...@gmail.com, "Ulf Hansson" , "st

Re: [PATCH] mmc: core: Add cache control for eMMC4.5 device

2011-10-05 Thread Andrei E. Warkentin
Hi Seungwon, 2011/10/6 Seungwon Jeon : > Adrian Hunter wrote: >> On 08/09/11 10:29, Seungwon Jeon wrote: >> > This patch adds cache feature of eMMC4.5 Spec. >> > If device supports cache capability, host can utilize some specific >> > operations. >> > >> > Signed-off-by: Seungwon Jeon >> > --- I

Re: [PATCH v11] mmc : general purpose partition support.

2011-10-05 Thread Andrei E. Warkentin
HI NamJae, 2011/10/5 NamJae Jeon : > > How about changing patch like this ? > > if (ext_csd[EXT_CSD_BOOT_MULT] && mmc_boot_partition_access(card->host)) { >                        for (idx = 0; idx < MMC_NUM_BOOT_PARTITION; idx++) { >                                part_size = ext_csd[EXT_CSD_BOOT

RE: [PATCH] mmc: core: Add cache control for eMMC4.5 device

2011-10-05 Thread Seungwon Jeon
Adrian Hunter wrote: > On 08/09/11 10:29, Seungwon Jeon wrote: > > This patch adds cache feature of eMMC4.5 Spec. > > If device supports cache capability, host can utilize some specific > > operations. > > > > Signed-off-by: Seungwon Jeon > > --- > > This patch is base on [PATCH v3] mmc: core: Add

[PATCH v5] mmc: core: Add default timeout value for CMD6.

2011-10-05 Thread Seungwon Jeon
EXT_CSD[248] includes the default maximum timeout for CMD6. This field is added at eMMC4.5 Spec. And it can be used for default timeout except for some operations which don't define the timeout(i.e. background operation, sanitize, flush cache) in eMMC4.5 Spec. Signed-off-by: Seungwon Jeon --- dr

Re: [PATCH v11] mmc : general purpose partition support.

2011-10-05 Thread NamJae Jeon
2011/10/6 Andrei Warkentin : > Hi, > > - Original Message - >> From: "Namjae Jeon" >> To: c...@laptop.org, linux-mmc@vger.kernel.org >> Cc: linux-ker...@vger.kernel.org, awarken...@vmware.com, "adrian hunter" >> , "linus walleij" >> , "james p freyensee" >> , seb...@gmail.com, "Ulf Hanss

Re: [PATCH v2] PM: HIBERNATION: add resume_wait param to support MMC-like devices as resume file

2011-10-05 Thread Rafael J. Wysocki
On Wednesday, October 05, 2011, Barry Song wrote: > 在 2011-10-5 上午6:30,"Rafael J. Wysocki" 写道: > > > > On Thursday, September 29, 2011, Barry Song wrote: > > > From: Barry Song > > > > > > Some devices like mmc are async detected very slow. For example, > > > drivers/mmc/host/sdhci.c launchs a 200

[PATCH 08/16] mmc: mmci: Enable module alias autogeneration for AMBA drivers

2011-10-05 Thread Dave Martin
Signed-off-by: Dave Martin --- drivers/mmc/host/mmci.c |2 ++ 1 files changed, 2 insertions(+), 0 deletions(-) diff --git a/drivers/mmc/host/mmci.c b/drivers/mmc/host/mmci.c index b16ea4a..a7d398c 100644 --- a/drivers/mmc/host/mmci.c +++ b/drivers/mmc/host/mmci.c @@ -1496,6 +1496,8 @@ static

[PATCH 00/16] ARM: amba: Enable module alias autogeneration for AMBA drivers

2011-10-05 Thread Dave Martin
There's no special reason why AMBA device drivers should not be auto-loadable via udev, but udev currently has no way to map AMBA device IDs to drivers. As part of the effort to help enable the building of multiple ARM platforms into a single kernel image in the future, it's desirable to be able t

RE: [PATCH 2/3] mmc: Add OF bindings support for mmc host controller capabilities

2011-10-05 Thread Stephen Warren
Thomas Abraham wrote at Wednesday, October 05, 2011 8:28 AM: > On 5 October 2011 18:59, Rob Herring wrote: > > On 10/05/2011 05:13 AM, Thomas Abraham wrote: > >> Device nodes representing sd/mmc controllers in a device tree would include > >> mmc host controller capabilities. Add support for parsi

Re: [PATCH v11] mmc : general purpose partition support.

2011-10-05 Thread Andrei Warkentin
Hi, - Original Message - > From: "Namjae Jeon" > To: c...@laptop.org, linux-mmc@vger.kernel.org > Cc: linux-ker...@vger.kernel.org, awarken...@vmware.com, "adrian hunter" > , "linus walleij" > , "james p freyensee" > , seb...@gmail.com, "Ulf Hansson" > , "stefan xk nilsson" > , "per fo

Re: [PATCH 2/2] mmc: sdhci-pci: add runtime pm support

2011-10-05 Thread Ulf Hansson
Adrian Hunter wrote: Ths patch allows runtime PM for sdhci-pci, runtime suspending after inactivity of 50ms and ensuring runtime resume before SDHC registers are accessed. During runtime suspend, interrupts are masked. The host controller state is restored at runtime resume. For Medfield, the

[PATCH v11] mmc : general purpose partition support.

2011-10-05 Thread Namjae Jeon
It allows gerneral purpose partitions in MMC Device. And I try to simpliy make mmc_blk_alloc_parts using mmc_part structure suggested by Andrei Warkentin. After patching, we can see general purpose partitions like this. > cat /proc/partitions 179 0 847872 mmcblk0 179 192 4096 m

Re: [PATCH 2/3] mmc: Add OF bindings support for mmc host controller capabilities

2011-10-05 Thread Thomas Abraham
Hi Rob, On 5 October 2011 18:59, Rob Herring wrote: > Thomas, > > On 10/05/2011 05:13 AM, Thomas Abraham wrote: >> Device nodes representing sd/mmc controllers in a device tree would include >> mmc host controller capabilities. Add support for parsing of mmc host >> controller capabilities includ

Re: [PATCH 1/2] mmc: core: move ->request() call from atomic context

2011-10-05 Thread Ulf Hansson
Adrian Hunter wrote: mmc_request_done() is sometimes called from interrupt or other atomic context. Mostly all mmc_request_done() does is complete(), however it contains code to retry on error, which uses ->request(). As the error path is certainly not performance critical, this may be moved to

Re: [PATCH 2/3] mmc: Add OF bindings support for mmc host controller capabilities

2011-10-05 Thread Rob Herring
Thomas, On 10/05/2011 05:13 AM, Thomas Abraham wrote: > Device nodes representing sd/mmc controllers in a device tree would include > mmc host controller capabilities. Add support for parsing of mmc host > controller capabilities included in device nodes. > > Signed-off-by: Thomas Abraham > ---

Re: [PATCH v10] mmc : general purpose partition support.

2011-10-05 Thread NamJae Jeon
2011/10/5 Adrian Hunter : > On 05/10/11 14:22, NamJae Jeon wrote: >> >> 2011/10/5 NamJae Jeon: >>> >>> 2011/10/5 Adrian Hunter: On 05/10/11 13:21, NamJae Jeon wrote: > > 2011/10/5 Adrian Hunter: >> >> On 04/10/11 20:45, Namjae Jeon wrote: >>> >>> It allows gerneral

Re: [PATCH] mmc: core: Add cache control for eMMC4.5 device

2011-10-05 Thread Adrian Hunter
On 08/09/11 10:29, Seungwon Jeon wrote: This patch adds cache feature of eMMC4.5 Spec. If device supports cache capability, host can utilize some specific operations. Signed-off-by: Seungwon Jeon --- This patch is base on [PATCH v3] mmc: core: Add default timeout value for CMD6 drivers/mmc/ca

Re: [PATCH v10] mmc : general purpose partition support.

2011-10-05 Thread Adrian Hunter
On 05/10/11 14:22, NamJae Jeon wrote: 2011/10/5 NamJae Jeon: 2011/10/5 Adrian Hunter: On 05/10/11 13:21, NamJae Jeon wrote: 2011/10/5 Adrian Hunter: On 04/10/11 20:45, Namjae Jeon wrote: It allows gerneral purpose partitions in MMC Device. And I try to simpliy make mmc_blk_alloc_parts usi

Re: [PATCH v10] mmc : general purpose partition support.

2011-10-05 Thread NamJae Jeon
2011/10/5 NamJae Jeon : > 2011/10/5 Adrian Hunter : >> On 05/10/11 13:21, NamJae Jeon wrote: >>> >>> 2011/10/5 Adrian Hunter: On 04/10/11 20:45, Namjae Jeon wrote: > > It allows gerneral purpose partitions in MMC Device. > And I try to simpliy make mmc_blk_alloc_parts using mm

Re: [PATCH v10] mmc : general purpose partition support.

2011-10-05 Thread NamJae Jeon
2011/10/5 Adrian Hunter : > On 05/10/11 13:21, NamJae Jeon wrote: >> >> 2011/10/5 Adrian Hunter: >>> >>> On 04/10/11 20:45, Namjae Jeon wrote: It allows gerneral purpose partitions in MMC Device. And I try to simpliy make mmc_blk_alloc_parts using mmc_part structure suggested by

Re: [PATCH v10] mmc : general purpose partition support.

2011-10-05 Thread Adrian Hunter
On 05/10/11 13:21, NamJae Jeon wrote: 2011/10/5 Adrian Hunter: On 04/10/11 20:45, Namjae Jeon wrote: It allows gerneral purpose partitions in MMC Device. And I try to simpliy make mmc_blk_alloc_parts using mmc_part structure suggested by Andrei Warkentin. After patching, we can see general pur

[PATCH 3/3] mmc: sdhci-s3c: Add device tree support

2011-10-05 Thread Thomas Abraham
Add device tree based discovery support for Samsung's sdhci controller Cc: Ben Dooks Signed-off-by: Thomas Abraham --- .../devicetree/bindings/mmc/samsung-sdhci.txt | 75 ++ drivers/mmc/host/sdhci-s3c.c | 150 +++- 2 files changed, 219 inser

Re: [PATCH v10] mmc : general purpose partition support.

2011-10-05 Thread NamJae Jeon
2011/10/5 Adrian Hunter : > On 04/10/11 20:45, Namjae Jeon wrote: >> >> It allows gerneral purpose partitions in MMC Device. >> And I try to simpliy make mmc_blk_alloc_parts using mmc_part structure >> suggested by Andrei Warkentin. >> After patching, we can see general purpose partitions like this

[PATCH 2/3] mmc: Add OF bindings support for mmc host controller capabilities

2011-10-05 Thread Thomas Abraham
Device nodes representing sd/mmc controllers in a device tree would include mmc host controller capabilities. Add support for parsing of mmc host controller capabilities included in device nodes. Signed-off-by: Thomas Abraham --- .../devicetree/bindings/mmc/linux-mmc-host.txt | 11 +++

[PATCH 1/3] mmc: sdhci-s3c: Keep a copy of platform data and use it

2011-10-05 Thread Thomas Abraham
The platform data is copied into driver's private data and the copy is used for all access to the platform data. This simpifies the addition of device tree support for the sdhci-s3c driver. Cc: Ben Dooks Signed-off-by: Thomas Abraham --- drivers/mmc/host/sdhci-s3c.c | 11 +-- 1 files

[PATCH 0/3] mmc: sdhci-s3c: Add device tree support for Samsung's sdhci controller driver

2011-10-05 Thread Thomas Abraham
This patchset adds device tree support for Samsung's sdhci controller driver. The first patch modifies the sdhcis-s3c driver to mainatain a local copy of the platform data, which makes it easier to add device tree support for the driver. The second patch adds support for parsing of mmc host contr

RE: [PATCH v4] mmc: core: Add default timeout value for CMD6.

2011-10-05 Thread Seungwon Jeon
Adrian Hunter wrote: > On 22/09/11 05:12, Seungwon Jeon wrote: > > EXT_CSD[248] includes the default maximum timeout for CMD6. > > This field is added at eMMC4.5 Spec. And it can be used for default > > timeout except for some operations which don't define the timeout(i.e. > > background operation,

Re: [PATCH v10] mmc : general purpose partition support.

2011-10-05 Thread Adrian Hunter
On 04/10/11 20:45, Namjae Jeon wrote: It allows gerneral purpose partitions in MMC Device. And I try to simpliy make mmc_blk_alloc_parts using mmc_part structure suggested by Andrei Warkentin. After patching, we can see general purpose partitions like this. cat /proc/partitions 179

Re: [PATCH] mmc: dw_mmc: Support predefined multiple block transfers.

2011-10-05 Thread Jaehoon Chung
On 10/05/2011 05:02 PM, Seungwon Jeon wrote: > Jaehoon Chung wrote: >> >> Hi Mr.Jeon >> >> One question...if we used predefined transfer, didn't send stop-command? >> then i think that didn't need to enter this condition..how about this? >> >> In __dw_mci_start_reqeust() function(at your patch) >>

RE: [PATCH] mmc: dw_mmc: Support predefined multiple block transfers.

2011-10-05 Thread Seungwon Jeon
Jaehoon Chung wrote: > > Hi Mr.Jeon > > One question...if we used predefined transfer, didn't send stop-command? > then i think that didn't need to enter this condition..how about this? > > In __dw_mci_start_reqeust() function(at your patch) > > if (mrq->stop) > host->stop_cmdr = dw_mci_p

Re: [PATCH 3/3] ARM: SAMSUNG: Add lookup of sdhci-s3c clocks using generic names

2011-10-05 Thread Heiko Stübner
Am Mittwoch, 5. Oktober 2011, 07:31:09 schrieb Rajeshwari Shinde: > Add support for lookup of sdhci-s3c controller clocks using generic names > for s3c2416, s3c64xx, s5pc100, s5pv210 and exynos4 SoC's. > > Signed-off-by: Rajeshwari Shinde > --- [...] > diff --git a/arch/arm/mach-s3c2416/clock.c