[PATCH V2] mmci.c: CMD23 support

2012-02-01 Thread Saugata Das
From: Saugata Das Support added for transmission of CMD23 during multi block read or write. In order to activate this feature, MMC_CAP_CMD23 flag needs to be enabled in the capabilities field. Note that CMD23 support is mandatory to support features like reliable write, data tag, context ID, pack

Re: [PATCH V2] mmc: core: Detect card removal on I/O error

2012-02-01 Thread Namjae Jeon
2012/2/2 Jaehoon Chung : > On 02/02/2012 12:36 PM, Namjae Jeon wrote: > >> 2012/2/2 Jaehoon Chung : >>> On 02/02/2012 09:34 AM, Namjae Jeon wrote: >>> 2012/2/1 Ulf Hansson : > To prevent I/O as soon as possible at card removal, a new > detect work is re-scheduled without a delay to let

Re: [PATCH 1/2] mmc: core: Prevent I/O as soon as possible at card removal

2012-02-01 Thread Jaehoon Chung
On 02/01/2012 06:40 PM, Ulf Hansson wrote: > Jaehoon Chung wrote: >> Hi Ulf. >> On 02/01/2012 12:23 AM, Ulf Hansson wrote: >> >>> Adrian Hunter wrote: On 31/01/12 14:54, Ulf Hansson wrote: > Adrian Hunter wrote: >> On 19/01/12 18:39, Ulf Hansson wrote: >>> Once the card has been d

Re: [PATCH V2] mmc: core: Detect card removal on I/O error

2012-02-01 Thread Jaehoon Chung
On 02/02/2012 12:36 PM, Namjae Jeon wrote: > 2012/2/2 Jaehoon Chung : >> On 02/02/2012 09:34 AM, Namjae Jeon wrote: >> >>> 2012/2/1 Ulf Hansson : To prevent I/O as soon as possible at card removal, a new detect work is re-scheduled without a delay to let a rescan remove the card dev

Re: [PATCH V2] mmc: core: Detect card removal on I/O error

2012-02-01 Thread Namjae Jeon
2012/2/2 Jaehoon Chung : > On 02/02/2012 09:34 AM, Namjae Jeon wrote: > >> 2012/2/1 Ulf Hansson : >>> To prevent I/O as soon as possible at card removal, a new >>> detect work is re-scheduled without a delay to let a rescan >>> remove the card device as soon a possible. >>> >>> Additionally, MMC_CA

Re: [PATCH V2] mmc: core: Detect card removal on I/O error

2012-02-01 Thread Jaehoon Chung
On 02/02/2012 09:34 AM, Namjae Jeon wrote: > 2012/2/1 Ulf Hansson : >> To prevent I/O as soon as possible at card removal, a new >> detect work is re-scheduled without a delay to let a rescan >> remove the card device as soon a possible. >> >> Additionally, MMC_CAP2_DETECT_ON_ERR can now be used t

Re: [PATCH V2] mmc: core: Detect card removal on I/O error

2012-02-01 Thread Namjae Jeon
2012/2/1 Ulf Hansson : > To prevent I/O as soon as possible at card removal, a new > detect work is re-scheduled without a delay to let a rescan > remove the card device as soon a possible. > > Additionally, MMC_CAP2_DETECT_ON_ERR can now be used to handle > "slowly" removed cards that a scheduled

Re: [PATCH] mmc: block: Init sysfs attr to fix lockdep warnings

2012-02-01 Thread Namjae Jeon
2012/2/2 Linus Walleij : > On Wed, Feb 1, 2012 at 4:31 PM, Ulf Hansson > wrote: > >> From: Rabin Vincent >> >> Signed-off-by: Rabin Vincent >> Signed-off-by: Johan Rudholm >> Signed-off-by: Ulf Hansson > > Acked-by: Linus Walleij Reviewed-by: Namjae Jeon Looks good to me! Thanks. > > This

[PATCH] mmc: tegra: Explicitly support Tegra30

2012-02-01 Thread Stephen Warren
Tegra30 differs from Tegra20 in a number of ways. This patch implements a minimal set of differences in order to get the Cardhu board's SD slot and eMMC working. Given the diffs between the mainline sdhci-tegra.c and our downstream versions, I expect we'll eventually need to add many more differenc

Re: [PATCH 1/1] mmc:core: Fix comparison issue in mmc_compare_ext_csds

2012-02-01 Thread Namjae Jeon
2012/2/1 Jurgen Heeks : > Found this issue during code review. Actually, there are two > issues which both compensate together in lucky case. > In unlucky case the bus width probing might not work as expected. > > Signed-off-by: Jurgen Heeks > --- Reviewed-by: Namjae Jeon Good catch! Looks good

Re: [PATCH 0/2] mmc: use PM QoS instead of delayed clock gating

2012-02-01 Thread Rafael J. Wysocki
On Wednesday, February 01, 2012, Guennadi Liakhovetski wrote: > On Sat, 28 Jan 2012, Rafael J. Wysocki wrote: > > > Hi, > > > > On Thursday, January 19, 2012, Guennadi Liakhovetski wrote: > > > Hi all > > > > > > I've already sent one of these two patches yesterday, but I forgot to > > > includ

Re: [PATCH] mmc: block: Init sysfs attr to fix lockdep warnings

2012-02-01 Thread Linus Walleij
On Wed, Feb 1, 2012 at 4:31 PM, Ulf Hansson wrote: > From: Rabin Vincent > > Signed-off-by: Rabin Vincent > Signed-off-by: Johan Rudholm > Signed-off-by: Ulf Hansson Acked-by: Linus Walleij This looks like it should go into stable, Chris will you add Cc: sta...@kernel.org to this if/when y

Re: [PATCH V2] mmc: core: Detect card removal on I/O error

2012-02-01 Thread Linus Walleij
On Wed, Feb 1, 2012 at 2:48 PM, Ulf Hansson wrote: > To prevent I/O as soon as possible at card removal, a new > detect work is re-scheduled without a delay to let a rescan > remove the card device as soon a possible. > > Additionally, MMC_CAP2_DETECT_ON_ERR can now be used to handle > "slowly" r

Re: [PATCH] mmci.c: CMD23 support

2012-02-01 Thread Linus Walleij
On Wed, Feb 1, 2012 at 5:17 AM, Saugata Das wrote: > From: Saugata Das > > Support added for transmission of CMD23 during multi block read or write. In > order to activate this feature, MMC_CAP_CMD23 flag needs to be enabled in the > capabilities field. Note that CMD23 support is mandatory to

Re: [PATCH v3 6/6] mmc: sdhci-s3c: Add device tree support

2012-02-01 Thread Karol Lewandowski
On 31.01.2012 18:56, Thomas Abraham wrote: Add device tree based discovery support for Samsung's sdhci controller Works fine on "nuri hardware" using exynos4-dt (with custom dts). Thanks -- To unsubscribe from this list: send the line "unsubscribe linux-mmc" in the body of a message to majord.

Re: [PATCH] mmc: core: Fix PowerOff Notify suspend/resume

2012-02-01 Thread Saugata Das
On 31 January 2012 15:44, Girish K S wrote: > Modified the mmc_poweroff to resume before sending the > poweroff notification command. In sleep mode only AWAKE > and RESET commands are allowed, so before sending the > poweroff notification command resume from sleep mode and > then send the notifica

[PATCH] mmc: block: Init sysfs attr to fix lockdep warnings

2012-02-01 Thread Ulf Hansson
From: Rabin Vincent Signed-off-by: Rabin Vincent Signed-off-by: Johan Rudholm Signed-off-by: Ulf Hansson --- drivers/mmc/card/block.c |1 + 1 files changed, 1 insertions(+), 0 deletions(-) diff --git a/drivers/mmc/card/block.c b/drivers/mmc/card/block.c index 176b78e..a7c75d8 100644 ---

[RFC] MMC-4.5 Context ID

2012-02-01 Thread Saugata Das
From: Saugata Das This patch groups the read or write transfers to eMMC in different contexts based on the block number. Transfers to consecutive blocks are grouped to a common context. So several small transfers combine to give performance like a large multi block transfer. The patch creates a

TMIO/SDHI and MMCIF fixes for 3.3

2012-02-01 Thread Guennadi Liakhovetski
Hi Chris Just to make sure, they don't get forgotten: there are 2 patches, that I sent to the ML earlier, that are bug-fixes and should go into 3.3: http://article.gmane.org/gmane.linux.ports.sh.devel/13216 http://article.gmane.org/gmane.linux.kernel.mmc/12381 Please, push with your next MMC fi

[PATCH V2] mmc: core: Detect card removal on I/O error

2012-02-01 Thread Ulf Hansson
To prevent I/O as soon as possible at card removal, a new detect work is re-scheduled without a delay to let a rescan remove the card device as soon a possible. Additionally, MMC_CAP2_DETECT_ON_ERR can now be used to handle "slowly" removed cards that a scheduled detect work did not detect as remo

Re: [PATCH 0/2] mmc: use PM QoS instead of delayed clock gating

2012-02-01 Thread Guennadi Liakhovetski
On Sat, 28 Jan 2012, Rafael J. Wysocki wrote: > Hi, > > On Thursday, January 19, 2012, Guennadi Liakhovetski wrote: > > Hi all > > > > I've already sent one of these two patches yesterday, but I forgot to > > include Rafael on the CC list and forgot to mention, that the patch should > > be tre

[PATCH 1/1] mmc:core: Fix comparison issue in mmc_compare_ext_csds

2012-02-01 Thread Jurgen Heeks
Found this issue during code review. Actually, there are two issues which both compensate together in lucky case. In unlucky case the bus width probing might not work as expected. Signed-off-by: Jurgen Heeks --- drivers/mmc/core/mmc.c |4 ++-- 1 files changed, 2 insertions(+), 2 deletions(-)

[PATCH V3 01/12] dmaengine/dw_dmac: Hibernation support in dw_dmac

2012-02-01 Thread Viresh Kumar
From: Rajeev KUMAR The suspend and resume implementation is through dev_pm_ops in dmac. So in order to support hibernation, freeze, thaw, restore and poweroff features are required. Signed-off-by: Rajeev Kumar Acked-by: Viresh Kumar --- drivers/dma/dw_dmac.c |4 1 files changed, 4 in

[PATCH V3 03/12] dmaengine: Pass dma_slave_config .device_fc = NULL for all existing users

2012-02-01 Thread Viresh Kumar
.device_fc is added in struct dma_slave_config recently. All user drivers, which want DMA to be the flow controller must pass this field as false. As earlier driver don't look to use this feature, mark it false for now. Signed-off-by: Viresh Kumar Acked-by: Linus Walleij --- drivers/mmc/host/mm

[PATCH V3 11/12] dmaengine/dw_dmac: Fix dw_dmac user drivers to adapt to slave_config changes

2012-02-01 Thread Viresh Kumar
There are few existing user drivers of dw_dmac. They will break as soon as we remove unused fields from struct dw_dma_slave. This patch focuses to fix these user drivers to use dma_slave_config() routine. Signed-off-by: Viresh Kumar --- arch/avr32/mach-at32ap/at32ap700x.c | 13

[PATCH V3 12/12] dmaengine/dw_dmac: Remove unused fields in struct dw_dma_slave

2012-02-01 Thread Viresh Kumar
Signed-off-by: Viresh Kumar --- drivers/dma/dw_dmac_regs.h | 12 include/linux/dw_dmac.h| 38 -- 2 files changed, 12 insertions(+), 38 deletions(-) diff --git a/drivers/dma/dw_dmac_regs.h b/drivers/dma/dw_dmac_regs.h index 2005d30..eec0481

[PATCH V3 02/12] dmaengine: Add flow controller information to dma_slave_config

2012-02-01 Thread Viresh Kumar
Flow controller is programmable for few controllers and there are few intelligent peripherals like, Synopsys JPEG controller, that needs to be a flow controller of DMA transfers on dest side. For this, currently two drivers, pl08x and dw_dmac, support flow controller to be passed from platform to

[PATCH V3 08/12] dmaengine/dw_dmac: Unmap all memory buffers after completion of non-slave transfers

2012-02-01 Thread Viresh Kumar
Currently, after completion of transfer, source address or destination address of only the first LLI descriptor is unmapped. And length passed for unmap is total length of all descriptors in the list. Which means unmapping code assumed that the memory buffers pointed to by the descriptors will be p

[PATCH V3 06/12] dmaengine/dw_dmac: Use dev_get_platdata() instead of accessing dev directly

2012-02-01 Thread Viresh Kumar
Use already defined function dev_get_platdata() instead of accessing pdev->dev.data. Signed-off-by: Viresh Kumar --- drivers/dma/dw_dmac.c |2 +- 1 files changed, 1 insertions(+), 1 deletions(-) diff --git a/drivers/dma/dw_dmac.c b/drivers/dma/dw_dmac.c index 1577394..f3aecb3 100644 --- a/d

[PATCH V3 09/12] dmaengine/dw_dmac: Add 64 bit access width support for slave xfers on mem side

2012-02-01 Thread Viresh Kumar
64 bit transfers are possible on both sides in slave transfers (memory as well as peripherals). This patch adds support for it memory side 64 bit transfers. Signed-off-by: Viresh Kumar --- drivers/dma/dw_dmac.c | 20 1 files changed, 16 insertions(+), 4 deletions(-) diff

[PATCH V3 07/12] dmaengine/dw_dmac: Don't handle block interrupts

2012-02-01 Thread Viresh Kumar
Block interrupts give interrupt on completion of every LLI, which is actually too much interrupts. This is just not required for current functioning of dw_dmac. So, just don't handle them at all. Signed-off-by: Viresh Kumar --- drivers/dma/dw_dmac.c | 36 ++--

[PATCH V3 10/12] dmaengine/dw_dmac: Add support for DMA_SLAVE_CONFIG

2012-02-01 Thread Viresh Kumar
This patch adds support for DMA_SLAVE_CONFIG in dwc DMAC controller. Fields in struct dw_dma_slave for passing similar data are preserved in this patch untill all existing users are fixed. That will be handled later in this patchset. Signed-off-by: Viresh Kumar --- drivers/dma/dw_dmac.c |

[PATCH V3 05/12] dmaengine/dw_dmac: Don't use magic number for total number of channels

2012-02-01 Thread Viresh Kumar
Total number of channels is passed in pdata->nr_channels variable, thus we must not use magic number '7' for total number of channels. Signed-off-by: Viresh Kumar --- drivers/dma/dw_dmac.c |2 +- 1 files changed, 1 insertions(+), 1 deletions(-) diff --git a/drivers/dma/dw_dmac.c b/drivers/d

[PATCH V3 04/12] dmaengine/amba-pl08x: Take flow controller info from DMA_SLAVE_CONFIG

2012-02-01 Thread Viresh Kumar
Flow controller information is passed now from DMA_SLAVE_CONFIG option. This patch makes changes in pl08x driver to use device_fc from it instead of platform data. Signed-off-by: Viresh Kumar Acked-by: Linus Walleij --- drivers/dma/amba-pl08x.c |4 +++- include/linux/amba/pl08x.h |8 +

[PATCH V3 00/12] dmaengine: Pl08x and dw_dmac updates

2012-02-01 Thread Viresh Kumar
Hi Vinod/Dan, This patchset does following: - Includes earlier patchset sent by Rajeev for cleanly applying this patchset - Adds device_fc (device flow control) field in struct DMA_SLAVE_CONFIG - Fixes existing users of DMAENGINE for device_fc. - Updates pl08x driver according to th

Re: [PATCH 0/2] Improve handling of card removal

2012-02-01 Thread Ulf Hansson
Adrian Hunter wrote: On 31/01/12 17:40, Ulf Hansson wrote: Adrian Hunter wrote: On 31/01/12 15:00, Ulf Hansson wrote: Adrian Hunter wrote: On 19/01/12 18:39, Ulf Hansson wrote: These patches is based upon the patch recently pushed to the mmc mailing list: mmc: core: Force a "detect" to handl

Re: [PATCH 1/2] mmc: core: Prevent I/O as soon as possible at card removal

2012-02-01 Thread Ulf Hansson
Jaehoon Chung wrote: Hi Ulf. On 02/01/2012 12:23 AM, Ulf Hansson wrote: Adrian Hunter wrote: On 31/01/12 14:54, Ulf Hansson wrote: Adrian Hunter wrote: On 19/01/12 18:39, Ulf Hansson wrote: Once the card has been detected to be removed by the mmc_detect_card_removed function, schedule a new

Re: [PATCH 0/2] Improve handling of card removal

2012-02-01 Thread Adrian Hunter
On 31/01/12 17:40, Ulf Hansson wrote: > Adrian Hunter wrote: >> On 31/01/12 15:00, Ulf Hansson wrote: >>> Adrian Hunter wrote: On 19/01/12 18:39, Ulf Hansson wrote: > These patches is based upon the patch recently pushed to the mmc mailing > list: > mmc: core: Force a "detect" to h