[PATCH v1 1/1] mmc: host: add SDHCI platform driver for msm chipsets

2013-01-08 Thread Asutosh Das
This platform driver adds the support of Secure Digital Host Controller Interface compliant controller in MSM chipsets. Signed-off-by: Asutosh Das Signed-off-by: Venkat Gopalakrishnan --- .../devicetree/bindings/mmc/sdhci-msm.txt | 49 + drivers/mmc/host/Kconfig

Re: [PATCH 5/5] kfifo: log based kfifo API

2013-01-08 Thread Yuanhan Liu
On Tue, Jan 08, 2013 at 10:16:46AM -0800, Dmitry Torokhov wrote: > Hi Yuanhan, > > On Tue, Jan 08, 2013 at 10:57:53PM +0800, Yuanhan Liu wrote: > > The current kfifo API take the kfifo size as input, while it rounds > > _down_ the size to power of 2 at __kfifo_alloc. This may introduce > > potent

[PATCH] mmc: sdhci-s3c: Use devm_clk_get()

2013-01-08 Thread Jingoo Han
The devm_ functions allocate memory that is released when a driver detaches. This patch uses devm_clk_get() for these functions. These make the code smaller and a bit simpler. Signed-off-by: Jingoo Han --- drivers/mmc/host/sdhci-s3c.c | 17 ++--- 1 files changed, 2 insertions(+), 1

Re: [PATCH 5/5] kfifo: log based kfifo API

2013-01-08 Thread Andy Walls
Dmitry Torokhov wrote: >Hi Yuanhan, > >On Tue, Jan 08, 2013 at 10:57:53PM +0800, Yuanhan Liu wrote: >> The current kfifo API take the kfifo size as input, while it rounds >> _down_ the size to power of 2 at __kfifo_alloc. This may introduce >> potential issue. >> >> Take the code at drivers/hid

Re: [PATCH 1/1] mmc: mmci: Use devm_regulator_get API

2013-01-08 Thread Ulf Hansson
On 8 January 2013 10:42, Sachin Kamat wrote: > devm_regulator_get is device managed and saves some cleanup > and exit code. > > Signed-off-by: Sachin Kamat > --- > Compile tested against linux-next tree (20130108). > --- > drivers/mmc/host/mmci.c |3 +-- > 1

Re: [PATCH v5 0/4] mmc: core: Signal voltage switch procedure for UHS mode

2013-01-08 Thread Ulf Hansson
On 8 January 2013 20:36, Nicolas Pitre wrote: > On Tue, 8 Jan 2013, Johan Rudholm wrote: > >> This patch series attempts to make the 1.8V signal voltage switch >> required for UHS mode work according to the SD specification. >> >> These patches have been tested with a couple of UHS SD cards, one o

Re: [PATCH v5 0/4] mmc: core: Signal voltage switch procedure for UHS mode

2013-01-08 Thread Nicolas Pitre
On Tue, 8 Jan 2013, Johan Rudholm wrote: > This patch series attempts to make the 1.8V signal voltage switch > required for UHS mode work according to the SD specification. > > These patches have been tested with a couple of UHS SD cards, one of > which sometimes requires up to five power cycles

Re: [PATCH 5/5] kfifo: log based kfifo API

2013-01-08 Thread Dmitry Torokhov
Hi Yuanhan, On Tue, Jan 08, 2013 at 10:57:53PM +0800, Yuanhan Liu wrote: > The current kfifo API take the kfifo size as input, while it rounds > _down_ the size to power of 2 at __kfifo_alloc. This may introduce > potential issue. > > Take the code at drivers/hid/hid-logitech-dj.c as example: >

Re: [RFC PATCH 00/11] [FS, MM, block, MMC]: eMMC High Priority Interrupt Feature

2013-01-08 Thread Sergey Priporov
Hi Venkat, I was looking for some explanations of eMMC behavior in products we are developing now and found your comments around eMMC here. Our observation shows that that eMMC performance vary significantly and depends on volume of data to write during time slot and temperature. After a heavy

[PATCH 5/5] kfifo: log based kfifo API

2013-01-08 Thread Yuanhan Liu
The current kfifo API take the kfifo size as input, while it rounds _down_ the size to power of 2 at __kfifo_alloc. This may introduce potential issue. Take the code at drivers/hid/hid-logitech-dj.c as example: if (kfifo_alloc(&djrcv_dev->notif_fifo, DJ_MAX_NUMBER_

Re: [PATCH v5 0/4] mmc: core: Signal voltage switch procedure for UHS mode

2013-01-08 Thread Ulf Hansson
On 8 January 2013 15:05, Johan Rudholm wrote: > This patch series attempts to make the 1.8V signal voltage switch > required for UHS mode work according to the SD specification. > > These patches have been tested with a couple of UHS SD cards, one of > which sometimes requires up to five power cyc

Re: [PATCH v4 3/4] mmc: core: Break out start_signal_voltage_switch

2013-01-08 Thread Ulf Hansson
On 8 January 2013 11:23, Johan Rudholm wrote: > Hi Kevin and Ulf, > > 2013/1/8 Ulf Hansson : >> On 8 January 2013 01:56, Kevin Liu wrote: >>> 2013/1/8 Ulf Hansson : On 7 January 2013 16:10, Johan Rudholm wrote: > Allow callers to access the start_signal_voltage_switch host_ops >>>

Re: [PATCH v5 3/4] mmc: core: Break out start_signal_voltage_switch

2013-01-08 Thread Ulf Hansson
On 8 January 2013 15:06, Johan Rudholm wrote: > Allow callers to access the start_signal_voltage_switch host_ops > member without going through any cmd11 logic. This is mostly a > preparation for the following signal voltage switch patch. > > Also, reset ios.signal_voltage to its original value if

[PATCH v5 0/4] mmc: core: Signal voltage switch procedure for UHS mode

2013-01-08 Thread Johan Rudholm
This patch series attempts to make the 1.8V signal voltage switch required for UHS mode work according to the SD specification. These patches have been tested with a couple of UHS SD cards, one of which sometimes requires up to five power cycles before it accepts the signal voltage switch. The pat

[PATCH v5 4/4] mmc: core: Fixup signal voltage switch

2013-01-08 Thread Johan Rudholm
When switching SD and SDIO cards from 3.3V to 1.8V signal levels, the clock should be gated for 5 ms during the step. After enabling the clock, the host should wait for at least 1 ms before checking for failure. Failure by the card to switch is indicated by dat[0:3] being pulled low. The host shoul

[PATCH v5 1/4] mmc: core: Add mmc_power_cycle

2013-01-08 Thread Johan Rudholm
Add mmc_power_cycle which can be used to power cycle for instance SD-cards. Signed-off-by: Johan Rudholm --- drivers/mmc/core/core.c |8 drivers/mmc/core/core.h |1 + 2 files changed, 9 insertions(+) diff --git a/drivers/mmc/core/core.c b/drivers/mmc/core/core.c index aaed768..

[PATCH v5 3/4] mmc: core: Break out start_signal_voltage_switch

2013-01-08 Thread Johan Rudholm
Allow callers to access the start_signal_voltage_switch host_ops member without going through any cmd11 logic. This is mostly a preparation for the following signal voltage switch patch. Also, reset ios.signal_voltage to its original value if start_signal_voltage_switch fails. Signed-off-by: Joha

[PATCH v5 2/4] mmc: core: Add card_busy to host_ops

2013-01-08 Thread Johan Rudholm
This host_ops member is used to test if the card is signaling busy by pulling dat[0:3] low. Signed-off-by: Johan Rudholm --- include/linux/mmc/host.h |3 +++ 1 file changed, 3 insertions(+) diff --git a/include/linux/mmc/host.h b/include/linux/mmc/host.h index 61a10c1..3b56ef2 100644 --- a/

[PATCH] fix multiple mark_page_accessed called when sequentially writing a file with blocksize less than PAGE_SIZE ,which might pollute the LRU.

2013-01-08 Thread Qiang Gao
sequential write to a file with blocksize less than PAGE_SIZE will call mark_page_accessed multiple times, if (!pagevec_space(pvec)) __pagevec_lru_add(pvec, lru); it seems this trick fix this problem,but not quite thoroughly. there's a chance that when another page was add

Re: [PATCH v4 3/4] mmc: core: Break out start_signal_voltage_switch

2013-01-08 Thread Johan Rudholm
Hi Kevin and Ulf, 2013/1/8 Ulf Hansson : > On 8 January 2013 01:56, Kevin Liu wrote: >> 2013/1/8 Ulf Hansson : >>> On 7 January 2013 16:10, Johan Rudholm wrote: Allow callers to access the start_signal_voltage_switch host_ops member without going through any cmd11 logic. This is mostly

RE: [PATCH] mmc: correct the EXCEPTION_EVENTS_STATUS vaule comment

2013-01-08 Thread Zhang, YiX X
yes, you are right, I will change them later, thanks. Regards Zhang,Yi. -Original Message- From: linux-mmc-ow...@vger.kernel.org [mailto:linux-mmc-ow...@vger.kernel.org] On Behalf Of Konstantin Dorfman Sent: Tuesday, January 08, 2013 4:23 PM To: Zhang, YiX X Cc: c...@laptop.org; linux-m

[PATCH v4 4/8] MFD:rtsx: Add callback function switch_output_voltage

2013-01-08 Thread wei_wang
From: Wei WANG Different card reader has different method to switch output voltage, add this callback to let the card reader implement its individual switch function. Signed-off-by: Wei WANG --- drivers/mfd/rtl8411.c| 16 drivers/mfd/rts5209.c| 20 +

[PATCH v4 2/8] MFD:rtsx: Remove redundant code

2013-01-08 Thread wei_wang
From: Wei WANG In function rtsx_pci_add_sg_tbl, the statement "ptr++" is useless. Signed-off-by: Wei WANG Acked-by: Borislav Petkov --- drivers/mfd/rtsx_pcr.c |1 - 1 file changed, 1 deletion(-) diff --git a/drivers/mfd/rtsx_pcr.c b/drivers/mfd/rtsx_pcr.c index 3a44efa..fa2c2bc 100644 --

[PATCH v4 6/8] MFD:rtsx: Add callback function conv_clk_and_div_n

2013-01-08 Thread wei_wang
From: Wei WANG Add callback function conv_clk_and_div_n to convert between SSC clock and its divider N. For rtl8411, the formula to calculate SSC clock divider N is different with the other card reader models. Signed-off-by: Wei WANG --- drivers/mfd/rtl8411.c | 13 + dr

[PATCH v4 3/8] MFD:rtsx: Declare that the DMA address limitation is 32bit explicitly

2013-01-08 Thread wei_wang
From: Wei WANG Realtek PCIe card reader only supports 32bit DMA. This declaration can improve the readability Signed-off-by: Wei WANG --- drivers/mfd/rtsx_pcr.c |4 1 file changed, 4 insertions(+) diff --git a/drivers/mfd/rtsx_pcr.c b/drivers/mfd/rtsx_pcr.c index fa2c2bc..1dc64bb 100

[PATCH v4 8/8] MFD:rtsx: Use macro defines to replace some variables

2013-01-08 Thread wei_wang
From: Wei WANG In function rtsx_pci_switch_clock, some variables, such as min_n, max_n, and max_div, are not necessary. And those assigned values look very obscure for others. It's more proper to use macro definitions here to replace these variables. Signed-off-by: Wei WANG Acked-by: Borislav P

[PATCH v4 7/8] MFD:rtsx: Fix checkpatch warning

2013-01-08 Thread wei_wang
From: Wei WANG WARNING: Avoid CamelCase: + u8 N, min_N, max_N, clk_divider; WARNING: Avoid CamelCase: + u8 N, min_N, max_N, clk_divider; Signed-off-by: Wei WANG --- drivers/mfd/rtsx_pcr.c | 26 +- 1 file changed, 13 insertions(+), 13 deletions(-) diff

[PATCH v4 5/8] MMC:rtsx: Using callback function to switch output voltage

2013-01-08 Thread wei_wang
From: Wei WANG Different card reader has different method to switch output voltage, so we have to use the callback function provided by MFD driver to switch output pad voltage. Signed-off-by: Wei WANG --- drivers/mmc/host/rtsx_pci_sdmmc.c | 30 +- 1 file changed,

[PATCH v4 0/8] rtsx patchset for MFD and MMC tree

2013-01-08 Thread wei_wang
From: Wei WANG v2: 1. Add commit message for patch 2 2. Move pci_set_dma_mask before the pci_enable_device(pcidev) call v3: 1. Add commit message for patch 3 2. Add patch 8: Use macro defines to replace some variables v4: 1. Describe why patch 3 is needed 2. Modify a comment character in patch

[PATCH v4 1/8] MFD:rtsx: Fix typo in comment

2013-01-08 Thread wei_wang
From: Wei WANG Fix a misspelling word in comment Signed-off-by: Wei WANG --- include/linux/mfd/rtsx_pci.h |2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/include/linux/mfd/rtsx_pci.h b/include/linux/mfd/rtsx_pci.h index 060b721..bebe9f9 100644 --- a/include/linux/mfd/rts

[PATCH 1/1] mmc: mmci: Use devm_regulator_get API

2013-01-08 Thread Sachin Kamat
devm_regulator_get is device managed and saves some cleanup and exit code. Signed-off-by: Sachin Kamat --- Compile tested against linux-next tree (20130108). --- drivers/mmc/host/mmci.c |3 +-- 1 files changed, 1 insertions(+), 2 deletions(-) diff --git a/drivers/mmc/host/mmci.c b/drivers

Re: [PATCH v4 4/4] mmc: core: Fixup signal voltage switch

2013-01-08 Thread Ulf Hansson
On 7 January 2013 16:10, Johan Rudholm wrote: > When switching SD and SDIO cards from 3.3V to 1.8V signal levels, the > clock should be gated for 5 ms during the step. After enabling the > clock, the host should wait for at least 1 ms before checking for > failure. Failure by the card to switch is

Re: [PATCH v4 3/4] mmc: core: Break out start_signal_voltage_switch

2013-01-08 Thread Ulf Hansson
On 8 January 2013 01:56, Kevin Liu wrote: > 2013/1/8 Ulf Hansson : >> On 7 January 2013 16:10, Johan Rudholm wrote: >>> Allow callers to access the start_signal_voltage_switch host_ops >>> member without going through any cmd11 logic. This is mostly a >>> preparation for the following signal volt

Re: [PATCH] mmc: correct the EXCEPTION_EVENTS_STATUS vaule comment

2013-01-08 Thread Konstantin Dorfman
May be it is worth to change all this struct comments to be: u8 raw_exception_status; /* EXT_CSD_EXP_EVENTS_STATUS */ This will reference actual offset value from "include/linux/mmc/mmc.h" Thanks, On 01/08/2013 08:07 AM, Zhang, YiX X wrote: From aaea3405944d844f53679b295d4082584f33d9