Re: [PATCH V3] mmc:core: Avoid useless detecting task when card is busy

2013-09-23 Thread Zhang Haijun
Hi, Ulf I had update the patch according to your suggestion. I test on my platform during last night. About 200G random continuous data was written to 32G SDHC Card. No call trace was encountered. I think it can meet with your demand and solve the problem. 于 2013/9/24 10:08, Haijun Zhang 写道: > W

Re: [PATCH 1/2] Add defines for ext_csd field MAX_ENH_SIZE_MULT

2013-09-23 Thread Ben Gardiner
On Mon, Sep 23, 2013 at 2:40 AM, Oliver Metz wrote: > Signed-off-by: Oliver Metz > --- > mmc.h | 3 +++ > mmc_cmds.c | 6 -- > 2 files changed, 7 insertions(+), 2 deletions(-) Looks good to me. Reviewed-by: Ben Gardiner -- To unsubscribe from this list: send the line "unsubscribe lin

Re: [PATCH 2/2] Don't use u8 for fields with more than 1 byte

2013-09-23 Thread Ben Gardiner
On Mon, Sep 23, 2013 at 2:40 AM, Oliver Metz wrote: > Signed-off-by: Oliver Metz > --- > mmc_cmds.c | 19 ++- > 1 file changed, 10 insertions(+), 9 deletions(-) Looks good to me. Reviewed-by: Ben Gardiner -- To unsubscribe from this list: send the line "unsubscribe linux-mmc"

[PATCH V3] mmc:core: Avoid useless detecting task when card is busy

2013-09-23 Thread Haijun Zhang
When card is in cpu polling mode to detect card present. Card detecting task will be scheduled about once every second. When card is busy in large file transfer, detecting task will be hang and call trace will be prompt. When handling the request, CMD13 is always followed by every command when it w

[PATCHv2 3/3] arm: dts: socfpga: Add support for SD/MMC

2013-09-23 Thread dinguyen
From: Dinh Nguyen Add bindings for SD/MMC for SOCFPGA. Signed-off-by: Dinh Nguyen Reviewed-by: Pavel Machek Cc: Pavel Machek CC: Arnd Bergmann CC: Olof Johansson Cc: Rob Herring Cc: Pawel Moll Cc: Mark Rutland Cc: Stephen Warren Cc: Ian Campbell Cc: Chris Ball Cc: Jaehoon Chung Cc: S

[PATCHv2 1/3] arm: socfpga: Set the SDMMC clock phase in system manager

2013-09-23 Thread dinguyen
From: Dinh Nguyen Add functionality in the System Manager to set the SDR settings for the SD/MMC IP. Signed-off-by: Dinh Nguyen Cc: Pavel Machek CC: Arnd Bergmann CC: Olof Johansson Cc: Rob Herring Cc: Pawel Moll Cc: Mark Rutland Cc: Stephen Warren Cc: Ian Campbell Cc: Chris Ball Cc: J

[PATCHv2 2/3] mmc: dw_mmc-socfpga: Clean up SOCFPGA platform specific functionality

2013-09-23 Thread dinguyen
From: Dinh Nguyen The SDR timing registers for the SD/MMC IP block for SOCFPGA is located in the system manager. This system manager IP block is located outside of the SD IP block itself. Therefore, the function to set the SDR timing register should be in the platform specific code so that the SD

Re: [PATCH] mmc: core: remove dead function mmc_try_claim_host

2013-09-23 Thread Chris Ball
Hi Grant, On Mon, Sep 23 2013, Grant Grundler wrote: > On Fri, Sep 20, 2013 at 12:35 AM, Ulf Hansson wrote: >> On 20 September 2013 03:21, Grant Grundler wrote: >>> cscsope says there are no callers for mmc_try_claim_host in the kernel. >>> No reason to keep it. >>> >>> Signed-off-by: Grant Grun

Re: [PATCH] mmc: core: remove dead function mmc_try_claim_host

2013-09-23 Thread Grant Grundler
On Fri, Sep 20, 2013 at 12:35 AM, Ulf Hansson wrote: > On 20 September 2013 03:21, Grant Grundler wrote: >> cscsope says there are no callers for mmc_try_claim_host in the kernel. >> No reason to keep it. >> >> Signed-off-by: Grant Grundler > > Acked-by: Ulf Hansson Thank you Ulf! In which ma

Re: [PATCH] mmc: sdhci-esdhc-imx: Allow the usage of mmc aliases

2013-09-23 Thread Stephen Warren
On 09/22/2013 08:38 PM, Fabio Estevam wrote: > From: Fabio Estevam > > On embedded devices, there is often a combination of removable mmc > devices (e.g. MMC/SD cards) and hard wired ones (e.g. eMMC). > Depending on the hardware configuration, the 'mmcblkN' node might > change if the removable de

Re: [RFC/PATCH] mmc: core: Signal wakeup event at card insert/removal

2013-09-23 Thread Zoran Markovic
Hi Ulf, I like the fact that wakeups are now quite simplified. A couple of comments below: > By signaling the wakeup event for a time of 5 s for devices configured > as wakeup capable, we likely will be prevent a sleep long enough to let > user space consume the event. Given that there is no pm_re

Re: [PATCH 36/51] DMA-API: usb: use dma_set_coherent_mask()

2013-09-23 Thread Russell King - ARM Linux
On Mon, Sep 23, 2013 at 02:27:39PM -0400, Alan Stern wrote: > On Thu, 19 Sep 2013, Russell King wrote: > > > The correct way for a driver to specify the coherent DMA mask is > > not to directly access the field in the struct device, but to use > > dma_set_coherent_mask(). Only arch and bus code s

[PATCH v2 2/4] rename ARCH_BCM to ARCH_BCM_MOBILE (clocksource)

2013-09-23 Thread Christian Daudt
Currently ARCH_BCM has been used for Broadcom Mobile V7 based SoCs. In order to allow other Broadcom SoCs to also use mach-bcm directory and files, this patch renames the original ARCH_BCM to ARCH_BCM_MOBILE, and uses ARCH_BCM to define any Broadcom chip residing in mach-bcm directory. Signed-off-

[PATCH v2 4/4] rename ARCH_BCM to ARCH_BCM_MOBILE (dt)

2013-09-23 Thread Christian Daudt
Currently ARCH_BCM has been used for Broadcom Mobile V7 based SoCs. In order to allow other Broadcom SoCs to also use mach-bcm directory and files, this patch renames the original ARCH_BCM to ARCH_BCM_MOBILE, and uses ARCH_BCM to define any Broadcom chip residing in mach-bcm directory. Signed-off-

[PATCH v2 1/4] rename ARCH_BCM to ARCH_BCM_MOBILE (mach-bcm)

2013-09-23 Thread Christian Daudt
Currently ARCH_BCM has been used for Broadcom Mobile V7 based SoCs. In order to allow other Broadcom SoCs to also use mach-bcm directory and files, this patch renames the original ARCH_BCM to ARCH_BCM_MOBILE, and uses ARCH_BCM to define any Broadcom chip residing in mach-bcm directory. Signed-off-

[PATCH v2 3/4] rename ARCH_BCM to ARCH_BCM_MOBILE (mmc)

2013-09-23 Thread Christian Daudt
Currently ARCH_BCM has been used for Broadcom Mobile V7 based SoCs. In order to allow other Broadcom SoCs to also use mach-bcm directory and files, this patch renames the original ARCH_BCM to ARCH_BCM_MOBILE, and uses ARCH_BCM to define any Broadcom chip residing in mach-bcm directory. Signed-off-

[PATCH v2 0/4] ARCH_BCM rename

2013-09-23 Thread Christian Daudt
Rename ARCH_BCM to ARCH_BCM_MOBILE. Currently only the Broadcom mobile SoCs reside in the mach-bcm directory and are chosen by the ARCH_BCM config option. This patchset changes so that ARCH_BCM becomes a menu select for Broadcom ARM SoCs. ARCH_BCM_MOBILE is created to signify the (multiplatform

Re: [PATCH 4/7] pcmcia: at91_cf: fix deferred probe from __init

2013-09-23 Thread Nicolas Ferre
On 23/09/2013 16:27, Johan Hovold : Move probe out of __init section and don't use platform_driver_probe which cannot be used with deferred probing. Since commit e9354576 ("gpiolib: Defer failed gpio requests by default") this driver might return -EPROBE_DEFER if a gpio_request fails. Cc: Jean-

Re: [PATCH 0/7] driver core: prevent deferred probe with platform_driver_probe

2013-09-23 Thread Sascha Hauer
On Mon, Sep 23, 2013 at 05:20:18PM +0200, Johan Hovold wrote: > On Mon, Sep 23, 2013 at 04:50:29PM +0200, Sascha Hauer wrote: > > On Mon, Sep 23, 2013 at 04:27:25PM +0200, Johan Hovold wrote: > > > Deferred probing cannot be used with platform_driver_probe as by the > > > time probing is retried ei

Re: [PATCH 0/7] driver core: prevent deferred probe with platform_driver_probe

2013-09-23 Thread Johan Hovold
On Mon, Sep 23, 2013 at 04:50:29PM +0200, Sascha Hauer wrote: > On Mon, Sep 23, 2013 at 04:27:25PM +0200, Johan Hovold wrote: > > Deferred probing cannot be used with platform_driver_probe as by the > > time probing is retried either the driver has been unregistered or its > > probe function has be

Re: [PATCH 0/7] driver core: prevent deferred probe with platform_driver_probe

2013-09-23 Thread Sascha Hauer
On Mon, Sep 23, 2013 at 04:27:25PM +0200, Johan Hovold wrote: > Deferred probing cannot be used with platform_driver_probe as by the > time probing is retried either the driver has been unregistered or its > probe function has been set to platform_drv_probe_fail. > > With commit e9354576 ("gpiolib

[PATCH 0/7] driver core: prevent deferred probe with platform_driver_probe

2013-09-23 Thread Johan Hovold
Deferred probing cannot be used with platform_driver_probe as by the time probing is retried either the driver has been unregistered or its probe function has been set to platform_drv_probe_fail. With commit e9354576 ("gpiolib: Defer failed gpio requests by default") the gpio subsystem started ret

[PATCH 5/7] usb: gadget: pxa25x_udc: fix deferred probe from __init

2013-09-23 Thread Johan Hovold
Move probe out of __init section and don't use platform_driver_probe which cannot be used with deferred probing. Since commit e9354576 ("gpiolib: Defer failed gpio requests by default") this driver might return -EPROBE_DEFER if a gpio_request fails. Cc: Eric Miao Cc: Russell King Cc: Haojian Zh

[PATCH 6/7] usb: phy: gpio-vbus: fix deferred probe from __init

2013-09-23 Thread Johan Hovold
Move probe out of __init section and don't use platform_driver_probe which cannot be used with deferred probing. Since commit e9354576 ("gpiolib: Defer failed gpio requests by default") and 04bf3011 ("regulator: Support driver probe deferral") this driver might return -EPROBE_DEFER if a gpio_reque

[PATCH 1/7] driver core: prevent deferred probe with platform_driver_probe

2013-09-23 Thread Johan Hovold
Prevent drivers relying on platform_driver_probe from requesting deferred probing in order to avoid further futile probe attempts (either the driver has been unregistered or its probe function has been set to platform_drv_probe_fail when probing is retried). Note that several platform drivers curr

[PATCH 3/7] mtd: atmel_nand: fix deferred probe from __init

2013-09-23 Thread Johan Hovold
Move probe out of __init section and don't use platform_driver_probe which cannot be used with deferred probing. Since commit e9354576 ("gpiolib: Defer failed gpio requests by default") this driver might return -EPROBE_DEFER if a gpio_request fails. Cc: David Woodhouse Cc: Josh Wu Signed-off-by

[PATCH 4/7] pcmcia: at91_cf: fix deferred probe from __init

2013-09-23 Thread Johan Hovold
Move probe out of __init section and don't use platform_driver_probe which cannot be used with deferred probing. Since commit e9354576 ("gpiolib: Defer failed gpio requests by default") this driver might return -EPROBE_DEFER if a gpio_request fails. Cc: Jean-Christophe PLAGNIOL-VILLARD Cc: Nicol

[PATCH 2/7] mmc: mvsdio: fix deferred probe from __init

2013-09-23 Thread Johan Hovold
Move probe out of __init section and don't use platform_driver_probe which cannot be used with deferred probing. Since commit e9354576 ("gpiolib: Defer failed gpio requests by default") this driver might return -EPROBE_DEFER if the mmc_gpio_request_cd fails. Cc: Nicolas Pitre Cc: Chris Ball Sig

[PATCH 7/7] backlight: atmel-pwm-bl: fix deferred probe from __init

2013-09-23 Thread Johan Hovold
Move probe out of __init section and don't use platform_driver_probe which cannot be used with deferred probing. Since commit e9354576 ("gpiolib: Defer failed gpio requests by default") this driver might return -EPROBE_DEFER if a gpio_request fails. Cc: Richard Purdie Cc: Jingoo Han Cc: Jean-Ch

Re: [RFC/PATCH] mmc: core: Signal wakeup event at card insert/removal

2013-09-23 Thread Jaehoon Chung
On 09/23/2013 09:11 PM, Ulf Hansson wrote: > On 23 September 2013 12:55, Jaehoon Chung wrote: >> Hi Ulf, >> >> On 09/20/2013 06:48 PM, Ulf Hansson wrote: >>> We want to give user space provision to fully consume a card >>> insert/remove event, when the event was caused by a wakeup irq. >>> >>> By

Re: [PATCH 37/51] DMA-API: usb: use new dma_coerce_mask_and_coherent()

2013-09-23 Thread Nicolas Ferre
On 20/09/2013 00:02, Russell King : Signed-off-by: Russell King --- drivers/usb/chipidea/ci_hdrc_imx.c |4 +--- drivers/usb/dwc3/dwc3-exynos.c |4 +--- drivers/usb/host/ehci-atmel.c |4 +--- For Atmel driver: Acked-by: Nicolas Ferre [..] diff --git a/drivers/usb/ho

Re: [PATCH 36/51] DMA-API: usb: use dma_set_coherent_mask()

2013-09-23 Thread Nicolas Ferre
On 20/09/2013 00:01, Russell King : The correct way for a driver to specify the coherent DMA mask is not to directly access the field in the struct device, but to use dma_set_coherent_mask(). Only arch and bus code should access this member directly. Convert all direct write accesses to using t

Re: [RFC/PATCH] mmc: core: Signal wakeup event at card insert/removal

2013-09-23 Thread Ulf Hansson
On 23 September 2013 12:55, Jaehoon Chung wrote: > Hi Ulf, > > On 09/20/2013 06:48 PM, Ulf Hansson wrote: >> We want to give user space provision to fully consume a card >> insert/remove event, when the event was caused by a wakeup irq. >> >> By signaling the wakeup event for a time of 5 s for dev

Re: [alsa-devel] [PATCH 43/51] DMA-API: dma: edma.c: no need to explicitly initialize DMA masks

2013-09-23 Thread Russell King - ARM Linux
On Mon, Sep 23, 2013 at 03:55:33PM +0530, Vinod Koul wrote: > On Fri, Sep 20, 2013 at 12:15:39AM +0100, Russell King wrote: > > register_platform_device_full() can setup the DMA mask provided the > > appropriate member is set in struct platform_device_info. So lets > > make that be the case. This

Re: [alsa-devel] [PATCH 24/51] DMA-API: dma: pl330: add dma_set_mask_and_coherent() call

2013-09-23 Thread Vinod Koul
On Sat, Sep 21, 2013 at 09:00:00PM +0100, Russell King - ARM Linux wrote: > On Fri, Sep 20, 2013 at 07:26:27PM +0200, Heiko Stübner wrote: > > Am Donnerstag, 19. September 2013, 23:49:01 schrieb Russell King: > > > The DMA API requires drivers to call the appropriate dma_set_mask() > > > functions

Re: [alsa-devel] [PATCH 43/51] DMA-API: dma: edma.c: no need to explicitly initialize DMA masks

2013-09-23 Thread Vinod Koul
On Fri, Sep 20, 2013 at 12:15:39AM +0100, Russell King wrote: > register_platform_device_full() can setup the DMA mask provided the > appropriate member is set in struct platform_device_info. So lets > make that be the case. This avoids a direct reference to the DMA > masks by this driver. > > S

Re: [alsa-devel] [PATCH 23/51] DMA-API: dma: pl08x: add dma_set_mask_and_coherent() call

2013-09-23 Thread Vinod Koul
On Thu, Sep 19, 2013 at 10:48:01PM +0100, Russell King wrote: > The DMA API requires drivers to call the appropriate dma_set_mask() > functions before doing any DMA mapping. Add this required call to > the AMBA PL08x driver. > > Signed-off-by: Russell King Acked-by: Vinod Koul ~Vinod > --- >

Re: [RFC/PATCH] mmc: core: Signal wakeup event at card insert/removal

2013-09-23 Thread Jaehoon Chung
Hi Ulf, On 09/20/2013 06:48 PM, Ulf Hansson wrote: > We want to give user space provision to fully consume a card > insert/remove event, when the event was caused by a wakeup irq. > > By signaling the wakeup event for a time of 5 s for devices configured > as wakeup capable, we likely will be pre