AW: Strange NFS client ACK behaviour

2013-09-09 Thread Markus Stockhausen
> Von: Wendy Cheng [s.wendy.ch...@gmail.com] > Gesendet: Montag, 9. September 2013 22:03 > An: Markus Stockhausen > Cc: linux-rdma@vger.kernel.org > Betreff: Re: Strange NFS client ACK behaviour > > On Sun, Sep 8, 2013 at 11:24 AM, Markus Stockhausen > wrote: > > >> > we observed a performance d

[PATCH V2 4/4] IB/usnic: Cisco VIC - driver part 3/3

2013-09-09 Thread Upinder Malhi (umalhi)
Signed-off-by: Upinder Malhi --- MAINTAINERS | 5 + drivers/infiniband/Kconfig | 1 + drivers/infiniband/Makefile | 1 + drivers/infiniband/hw/usnic/Kconfig | 11 +++ drivers/infiniband/hw/usnic/Makefile | 15 +++ 5 files cha

[PATCH V2 1/4] IB/core: Cisco VIC - usNIC rdma node and transport

2013-09-09 Thread Upinder Malhi (umalhi)
This patch adds new rdma node and new rdma transport, and supporting code used by Cisco's low latency driver called usNIC. usNIC uses its own transport, distinct from IB and iWARP. Signed-off-by: Upinder Malhi Signed-off-by: Jeff Squyres --- drivers/infiniband/core/sysfs.c | 1 + drivers/infin

[PATCH V2 0/4] Add driver for Cisco's VIC series adapters

2013-09-09 Thread Upinder Malhi (umalhi)
usNIC is the kernel driver for userspace bypass networking on Cisco's VIC series adapters. usNIC devices are advertised as SRIOV VFs by the VIC adapters and these VFs are owned by usNIC. The driver works in conjuction with Cisco's ethernet driver, which owns the PFs, and does priviledged firmware

Re: [PATCH 0/8] IB SRP initiator patches for kernel 3.12

2013-09-09 Thread David Dillow
On Tue, 2013-08-20 at 14:41 +0200, Bart Van Assche wrote: > Changes since the previous patch series are: > - Rewrote the srp_tmo_valid() to improve readability (requested by Dave >Dillow). > - The combination (reconnect_delay < 0 && fast_io_fail_tmo < 0 && >dev_loss_tmo < 0) is now rejected

Re: [PATCH 8/8] IB/srp: Make queue size configurable

2013-09-09 Thread David Dillow
On Tue, 2013-08-20 at 14:50 +0200, Bart Van Assche wrote: > @@ -2227,6 +2270,7 @@ static const match_table_t srp_opt_tokens = { > { SRP_OPT_SG_TABLESIZE, "sg_tablesize=%u" }, > { SRP_OPT_COMP_VECTOR, "comp_vector=%u"}, > { SRP_OPT_TL_RETRY_COUN

Re: [PATCH 4/6] IB/qib: Use pcie_set_mps() and pcie_get_mps() to simplify code

2013-09-09 Thread Yijing Wang
On 2013/9/9 22:55, Marciniszyn, Mike wrote: >> Subject: [PATCH 4/6] IB/qib: Use pcie_set_mps() and pcie_get_mps() to >> simplify >> code >> >> Refactor qib_tune_pcie_caps() function, use pcie_set_mps() and >> pcie_get_mps() to simply code. Because pci core caches the "PCI-E Max >> Payload Size Sup

Re: Strange NFS client ACK behaviour

2013-09-09 Thread Wendy Cheng
On Sun, Sep 8, 2013 at 11:24 AM, Markus Stockhausen wrote: >> > we observed a performance drop in our IPoIB NFS backup >> > infrastructure since we switched to machines with newer >> > kernels. > Not sure how your backup infrastructure works but the symptoms seem to match with this discussion: h

Re: rtnl_lock deadlock on 3.10

2013-09-09 Thread Steve Wise
On 9/6/2013 6:19 PM, Shawn Bohrer wrote: On Thu, Sep 05, 2013 at 10:14:51AM -0500, Steve Wise wrote: Roland, what do you think? As I've said, I think we should go ahead with using the rtnl lock in the core. Is there a complete patch available for review? looks like the original was a partial

Re: [PATCH 5/6] staging/et131x: Use cached pci_dev->pcie_mpss and pcie_set_readrq() to simplif code

2013-09-09 Thread Greg Kroah-Hartman
On Mon, Sep 09, 2013 at 09:13:07PM +0800, Yijing Wang wrote: > The PCI core caches the "PCI-E Max Payload Size Supported" in > pci_dev->pcie_mpss, so use that instead of pcie_capability_read_dword(). > Also use pcie_set_readrq() instead of pcie_capability_clear_and_set_word() > to simplify code. >

RE: [PATCH 3/6] IB/qib: Use pci_is_root_bus() to check whether it is a root bus

2013-09-09 Thread Marciniszyn, Mike
> Subject: [PATCH 3/6] IB/qib: Use pci_is_root_bus() to check whether it is a > root > bus > Thanks for the patch! Acked-by: Mike Marciniszyn -- To unsubscribe from this list: send the line "unsubscribe linux-rdma" in the body of a message to majord...@vger.kernel.org More majordomo info at h

RE: [PATCH 4/6] IB/qib: Use pcie_set_mps() and pcie_get_mps() to simplify code

2013-09-09 Thread Marciniszyn, Mike
> Subject: [PATCH 4/6] IB/qib: Use pcie_set_mps() and pcie_get_mps() to simplify > code > > Refactor qib_tune_pcie_caps() function, use pcie_set_mps() and > pcie_get_mps() to simply code. Because pci core caches the "PCI-E Max > Payload Size Supported" in pci_dev->pcie_mpss, so use that instead of

Re: [PATCHv2] IB/srp: add change_queue_depth and change_queue_type support

2013-09-09 Thread David Dillow
On Mon, 2013-09-09 at 14:12 +0200, Jack Wang wrote: > On 08/28/2013 10:19 AM, Jack Wang wrote: > > Hi, > > > > Below patch is new version which address comments from Bart. > > > > Hi Roland, > > Could you included this in your tree or do you need me resend it? Acked-by: David Dillow I expect

[ANNOUNCE] libmlx5 1.0.0 released

2013-09-09 Thread Eli Cohen
Hi, I would like to announce the availability of libmlx5, the provider library for Mellanox Connect-IB devices. The library can be found here: www.openfabrics.org/downloads/mlx5/libmlx5-1.0.0.tar.gz Thanks, Eli -- To unsubscribe from this list: send the line "unsubscribe linux-rdma" in the body of

[PATCH 2/6] title/pci: use cached pci_dev->pcie_mpss to simplify code

2013-09-09 Thread Yijing Wang
The PCI core caches the "PCI-E Max Payload Size Supported" in pci_dev->pcie_mpss, so use that instead of pcie_capability_read_dword(). Signed-off-by: Yijing Wang --- arch/tile/kernel/pci.c |7 ++- 1 files changed, 2 insertions(+), 5 deletions(-) diff --git a/arch/tile/kernel/pci.c b/arc

[PATCH 1/6] PCI: Export pcie_set_mps() and pcie_get_mps()

2013-09-09 Thread Yijing Wang
Export pcie_get_mps() and pcie_set_mps() functions, so driver can use them to simplify code. Signed-off-by: Yijing Wang --- drivers/pci/pci.c |2 ++ 1 files changed, 2 insertions(+), 0 deletions(-) diff --git a/drivers/pci/pci.c b/drivers/pci/pci.c index b821a62..e35f7ec 100644 --- a/driver

[PATCH 3/6] IB/qib: Use pci_is_root_bus() to check whether it is a root bus

2013-09-09 Thread Yijing Wang
Use pci_is_root_bus() instead of "if (bus->parent)" statement for better readability. Signed-off-by: Yijing Wang --- drivers/infiniband/hw/qib/qib_pcie.c |2 +- 1 files changed, 1 insertions(+), 1 deletions(-) diff --git a/drivers/infiniband/hw/qib/qib_pcie.c b/drivers/infiniband/hw/qib/qi

[PATCH 6/6] radeon: Use pcie_get_readrq() and pcie_set_readrq() to simplify code

2013-09-09 Thread Yijing Wang
Use pcie_get_readrq() and pcie_set_readrq() functions to simplify code. Signed-off-by: Yijing Wang --- drivers/gpu/drm/radeon/evergreen.c | 19 ++- 1 files changed, 6 insertions(+), 13 deletions(-) diff --git a/drivers/gpu/drm/radeon/evergreen.c b/drivers/gpu/drm/radeon/everg

[PATCH 0/6] Simplify some mps and mrrs setting related code

2013-09-09 Thread Yijing Wang
This series simplify mps and mrrs setting related code in drivers. Export the pcie_set/get_mps() like pcie_set/get_readrq(). So drivers can use these interfaces to simplify code that set mps and mrrs. Patch 2 use pci_is_root_bus() instead of if (bus->parent) statement for better readability. Yijin

[PATCH 5/6] staging/et131x: Use cached pci_dev->pcie_mpss and pcie_set_readrq() to simplif code

2013-09-09 Thread Yijing Wang
The PCI core caches the "PCI-E Max Payload Size Supported" in pci_dev->pcie_mpss, so use that instead of pcie_capability_read_dword(). Also use pcie_set_readrq() instead of pcie_capability_clear_and_set_word() to simplify code. Signed-off-by: Yijing Wang --- drivers/staging/et131x/et131x.c | 1

[PATCH 4/6] IB/qib: Use pcie_set_mps() and pcie_get_mps() to simplify code

2013-09-09 Thread Yijing Wang
Refactor qib_tune_pcie_caps() function, use pcie_set_mps() and pcie_get_mps() to simply code. Because pci core caches the "PCI-E Max Payload Size Supported" in pci_dev->pcie_mpss, so use that instead of pcie_capability_read_word(). Remove the unused val2fld() and fld2val(). Signed-off-by: Yijing W

Re: [PATCHv2] IB/srp: add change_queue_depth and change_queue_type support

2013-09-09 Thread Jack Wang
On 08/28/2013 10:19 AM, Jack Wang wrote: > Hi, > > Below patch is new version which address comments from Bart. > Hi Roland, Could you included this in your tree or do you need me resend it? Best regards, Jack > > From 62d87b4d546066b251e44a3cb468b16783df7ee4 Mon Sep 17 00:00:00 2001 > Fro