[PATCH v2] ibsim: support LID portions of directed-route SMPs

2011-08-11 Thread Rolf Manderscheid
Heed the DRSLID and DRDLID fields in DR SMPs. Signed-off-by: Rolf Manderscheid --- changes from v1: - pass a NULL path for LID-routed MADs at both call sites ibsim/sim_mad.c | 38 +++--- 1 files changed, 27 insertions(+), 11 deletions(-) diff --git a/ibsim

Re: [PATCH] ibsim: support LID portions of directed-route SMPs

2011-08-11 Thread Rolf Manderscheid
Hi Alex, route_MAD() breaks the LID route support. I think the change to route_MAD() is sound, there's no change in behaviour for LID-routed packets. The path argument is expected to be NULL in the case of a LID routed MAD, which causes an early return, but this is only an optimization. Even

Re: [PATCH] ibsim: fix size of slid/dlid fields in sim_request structure

2011-08-10 Thread Rolf Manderscheid
Hi Alex, There are more places where lids defined as integer. Why did you choose to change only these two? This structure defines what request packets look like on the wire to the simulator. The motivation for the change is a simulator client for python-rdma, and this issue shows up when cre

Re: [PATCH] ibsim: fix non-debug path in run_opensm.sh script

2011-08-10 Thread Rolf Manderscheid
Hi Alex, On 11-08-09 08:57 AM, Alex Netes wrote This is what I get, when running the commands in the old way: ... I get: time: cannot run LD_PRELOAD=scripts/../umad2sim/libumad2sim.so: No such file or directory Command exited with non-zero status 127 0.00user 0.00system 0:00.00elapsed ?%CPU

[PATCH] ibsim: fix non-debug path in run_opensm.sh script

2011-08-05 Thread Rolf Manderscheid
Signed-off-by: Rolf Manderscheid --- scripts/run_opensm.sh |2 +- 1 files changed, 1 insertions(+), 1 deletions(-) diff --git a/scripts/run_opensm.sh b/scripts/run_opensm.sh index a225d81..a299dc0 100755 --- a/scripts/run_opensm.sh +++ b/scripts/run_opensm.sh @@ -29,7 +29,7 @@ if [ -z

[PATCH] ibsim: support LID portions of directed-route SMPs

2011-08-05 Thread Rolf Manderscheid
Heed the DRSLID and DRDLID fields in DR SMPs. Signed-off-by: Rolf Manderscheid --- ibsim/sim_mad.c | 35 +-- 1 files changed, 25 insertions(+), 10 deletions(-) diff --git a/ibsim/sim_mad.c b/ibsim/sim_mad.c index 61d4866..9396ca3 100644 --- a/ibsim/sim_mad.c

[PATCH] ibsim: fix size of slid/dlid fields in sim_request structure

2011-08-05 Thread Rolf Manderscheid
The code treats them as 16-bit fields (by using htons), make the structure match. This also avoids the 32 bits of padding before the length field. Signed-off-by: Rolf Manderscheid --- include/ibsim.h |4 ++-- 1 files changed, 2 insertions(+), 2 deletions(-) diff --git a/include/ibsim.h b

Re: [PATCH] opensm/osm_sa_path_record.c: separate router guid resolution code

2009-10-05 Thread Rolf Manderscheid
Sasha Khapyorsky wrote: Move off subnet destination (router address) resolution code to separate function to improve readability. ... +static ib_net64_t find_router(osm_sa_t *sa, ib_net64_t prefix) Much better. The *sa argument to find_router() can even be const. Rolf -- To unsubscribe fr