Author: jkim
Date: Thu Jul 29 16:41:21 2010
New Revision: 210614
URL: http://svn.freebsd.org/changeset/base/210614

Log:
  Rename PCB_USER_FPU to PCB_USERFPU not to clash with a macro from fpu.h.

Modified:
  head/sys/amd64/acpica/acpi_switch.S
  head/sys/amd64/amd64/cpu_switch.S
  head/sys/amd64/amd64/genassym.c

Modified: head/sys/amd64/acpica/acpi_switch.S
==============================================================================
--- head/sys/amd64/acpica/acpi_switch.S Thu Jul 29 16:40:45 2010        
(r210613)
+++ head/sys/amd64/acpica/acpi_switch.S Thu Jul 29 16:41:21 2010        
(r210614)
@@ -156,7 +156,7 @@ ENTRY(acpi_restorecpu)
        movq    PCPU(FPCURTHREAD), %rax
        testq   %rax, %rax
        je      1f
-       fxrstor WAKEUP_PCB(USER_FPU)
+       fxrstor WAKEUP_PCB(USERFPU)
 1:
 
        /* Restore CR0 with FPU mode. */

Modified: head/sys/amd64/amd64/cpu_switch.S
==============================================================================
--- head/sys/amd64/amd64/cpu_switch.S   Thu Jul 29 16:40:45 2010        
(r210613)
+++ head/sys/amd64/amd64/cpu_switch.S   Thu Jul 29 16:41:21 2010        
(r210614)
@@ -421,7 +421,7 @@ ENTRY(savectx2)
        testq   %rax,%rax
        je      1f
        clts
-       fxsave  PCB_USER_FPU(%r8)
+       fxsave  PCB_USERFPU(%r8)
 1:
 
        movl    $1, %eax

Modified: head/sys/amd64/amd64/genassym.c
==============================================================================
--- head/sys/amd64/amd64/genassym.c     Thu Jul 29 16:40:45 2010        
(r210613)
+++ head/sys/amd64/amd64/genassym.c     Thu Jul 29 16:41:21 2010        
(r210614)
@@ -140,7 +140,7 @@ ASSYM(PCB_DR2, offsetof(struct pcb, pcb_
 ASSYM(PCB_DR3, offsetof(struct pcb, pcb_dr3));
 ASSYM(PCB_DR6, offsetof(struct pcb, pcb_dr6));
 ASSYM(PCB_DR7, offsetof(struct pcb, pcb_dr7));
-ASSYM(PCB_USER_FPU, offsetof(struct pcb, pcb_user_save));
+ASSYM(PCB_USERFPU, offsetof(struct pcb, pcb_user_save));
 ASSYM(PCB_TSSP, offsetof(struct pcb, pcb_tssp));
 ASSYM(PCB_FULL_IRET, offsetof(struct pcb, pcb_full_iret));
 ASSYM(PCB_DBREGS, PCB_DBREGS);
_______________________________________________
svn-src-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/svn-src-all
To unsubscribe, send any mail to "svn-src-all-unsubscr...@freebsd.org"

Reply via email to