Comment #72 on issue 1598 by mattpap: New polynomials manipulation module
http://code.google.com/p/sympy/issues/detail?id=1598

[1] GFP, DUP, DMP, DMF, SDP, ANP -> short but meaningful names, at least to me. When the module will be fully operational, you won't see any of those names during your work with sympy (although at the moment you can encounter them, e.g. in error messages).

[2] self `op` other -> overlong and meaningless, but f `op` g or a `op` b etc., is
much better in some situations in my opinion.

[3] Maybe a little bit, AlgebraicStructure or Domain might be a better name.

[4] Possibly yes, although get_* sounds better here.

[5] K[X] is sugar, you have Algebra.{poly_ring,frac_field} do do the thing or you can use Poly's domain parser. K(X) is reserved for creating instances of K.dtype.

[6] It depends on the point of view. exquo(f, g) means that we know that remainder of f and g is zero, so we don't want to spend time for checking this, and quo(f, g)
means that we have no such knowledge so it will check the remainder first.

[7] Because runtests.py was using any() and wasn't importing it. However, this issue was fixed in master a few weeks after this commit, so the additional import is not
needed any more (overlooked during rebase).

[8] make_list() was a bad idea of mine, and as_Add and as_Mul are more meaningful.

[9] I guess we use OO approach is a few places so a.gcd(b) is not that weird at all. If you don't like this, you can always use gcd(a, b) which will call a.gcd(b) anyway.


--
You received this message because you are listed in the owner
or CC fields of this issue, or because you starred this issue.
You may adjust your issue notification preferences at:
http://code.google.com/hosting/settings

--
You received this message because you are subscribed to the Google Groups 
"sympy-issues" group.
To post to this group, send email to sympy-iss...@googlegroups.com.
To unsubscribe from this group, send email to 
sympy-issues+unsubscr...@googlegroups.com.
For more options, visit this group at 
http://groups.google.com/group/sympy-issues?hl=en.

Reply via email to