Re: RFR: 8315585: Optimization for decimal to string [v11]

2023-10-21 Thread Shaojin Wen
> I submitted PR #1 before, and there were too many changes. I split it > into multiple PRs with small changes. This one is one of them. > > this PR removed the duplicate code for getChars in > BigDecimal#StringBuilderHelper, i also make performance faster. > Please review and don't

Re: RFR: 8254693: Add Panama feature to pass heap segments to native code [v11]

2023-10-21 Thread Jorn Vernee
> Add the ability to pass heap segments to native code. This requires using > `Linker.Option.critical(true)` as a linker option. It has the same > limitations as normal critical calls, namely: upcalls into Java are not > allowed, and the native function should return relatively quickly. Heap >

Re: RFR: 8315585: Optimization for decimal to string [v7]

2023-10-21 Thread Shaojin Wen
On Thu, 19 Oct 2023 11:58:26 GMT, Claes Redestad wrote: >> @cl4es >> >>> Good, narrows it down to what's going on in `prepend(long, byte[], >>> String)`. Might boil down to `System.arraycopy`. This method might not be >>> optimized for tiny arrays on all platforms. Specializing for

Re: RFR: 8318027: Support alternative name to jdk.internal.vm.compiler [v4]

2023-10-21 Thread Doug Simon
On Sat, 21 Oct 2023 10:56:01 GMT, Doug Simon wrote: >> The Graal code base has >> [renamed](https://github.com/oracle/graal/commit/1e41203d10db321f86723eac90f6cd0573b08b33) >> its module to `jdk.compiler.graal` as part of preparations for Project >> Galahad. Due to the way Java modules work,

Re: RFR: 8318027: Support alternative name to jdk.internal.vm.compiler [v4]

2023-10-21 Thread Doug Simon
> The Graal code base has > [renamed](https://github.com/oracle/graal/commit/1e41203d10db321f86723eac90f6cd0573b08b33) > its module to `jdk.compiler.graal` as part of preparations for Project > Galahad. Due to the way Java modules work, this requires a JDK change. The > core of the issue is

Re: RFR: JDK-8318476: Add resource consumption note to BigInteger and BigDecimal

2023-10-21 Thread Alan Bateman
On Sat, 21 Oct 2023 00:56:21 GMT, Joe Darcy wrote: > Add informative notes to BigInteger and BigDecimal about possible running > times, etc. The wording looks okay to me and I expect it will appear as an API note in BigInteger. However, for BigDecimal I suspect the h2 headings (for the next

Re: RFR: 8316969: Improve CDS module graph support for --module option [v3]

2023-10-21 Thread Alan Bateman
On Fri, 20 Oct 2023 20:24:26 GMT, Calvin Cheung wrote: > I tried the above but got the following build error: > > ``` > Optimizing the exploded image > Error occurred during initialization of boot layer > java.lang.NullPointerException > ExplodedImageOptimize.gmk:39: recipe for target >

Re: RFR: 8316969: Improve CDS module graph support for --module option [v3]

2023-10-21 Thread Alan Bateman
On Sat, 21 Oct 2023 07:42:06 GMT, Alan Bateman wrote: >>> Yes, because of the following code further up in the same method: >> >> I think what you are actually doing here is supporting archiving of the boot >> layer when the main module transitively depends on an incubator module. We >> might

Re: RFR: 8316969: Improve CDS module graph support for --module option [v3]

2023-10-21 Thread Alan Bateman
On Sat, 21 Oct 2023 06:54:16 GMT, Alan Bateman wrote: > > Yes, because of the following code further up in the same method: > > I think what you are actually doing here is supporting archiving of the boot > layer when the main module transitively depends on an incubator module. We > might

Re: RFR: 8316969: Improve CDS module graph support for --module option [v3]

2023-10-21 Thread Alan Bateman
On Fri, 20 Oct 2023 20:22:31 GMT, Calvin Cheung wrote: > Yes, because of the following code further up in the same method: I think what you are actually doing here is supporting archiving of the boot layer when the main module transitively depends on an incubator module. We might have to add