Integrated: 8316996: Catalog API Enhancement: add a factory method

2023-10-27 Thread Joe Wang
On Wed, 4 Oct 2023 22:56:28 GMT, Joe Wang wrote: > Add a new factory method so that a CatalogResolver can be created with a > resolve property on top of the Catalog object. This pull request has now been integrated. Changeset: 96bec358 Author:Joe Wang URL:

Re: RFR: 8316996: Catalog API Enhancement: add a factory method [v5]

2023-10-27 Thread Naoto Sato
On Fri, 27 Oct 2023 22:21:41 GMT, Joe Wang wrote: >> src/java.xml/share/classes/javax/xml/catalog/CatalogResolver.java line 283: >> >>> 281: return type; >>> 282: } >>> 283: } >> >> Instead of looping through all the elements, `Enum.valueOf()`

Re: RFR: 8316996: Catalog API Enhancement: add a factory method [v5]

2023-10-27 Thread Joe Wang
On Fri, 27 Oct 2023 20:41:59 GMT, Naoto Sato wrote: >> Joe Wang has updated the pull request incrementally with one additional >> commit since the last revision: >> >> Impl CSR Changes: change the parameter type from String to Enum > >

Re: RFR: 8316996: Catalog API Enhancement: add a factory method [v6]

2023-10-27 Thread Joe Wang
> Add a new factory method so that a CatalogResolver can be created with a > resolve property on top of the Catalog object. Joe Wang has updated the pull request incrementally with one additional commit since the last revision: add IAE - Changes: - all:

Re: RFR: 8316996: Catalog API Enhancement: add a factory method [v5]

2023-10-27 Thread Naoto Sato
On Fri, 27 Oct 2023 19:20:01 GMT, Joe Wang wrote: >> Add a new factory method so that a CatalogResolver can be created with a >> resolve property on top of the Catalog object. > > Joe Wang has updated the pull request incrementally with one additional > commit since the last revision: > >

Re: RFR: 8316996: Catalog API Enhancement: add a factory method [v5]

2023-10-27 Thread Lance Andersen
On Fri, 27 Oct 2023 19:16:33 GMT, Joe Wang wrote: >> Add a new factory method so that a CatalogResolver can be created with a >> resolve property on top of the Catalog object. > > Joe Wang has updated the pull request incrementally with one additional > commit since the last revision: > >

Re: RFR: 8316996: Catalog API Enhancement: add a factory method [v5]

2023-10-27 Thread Joe Wang
> Add a new factory method so that a CatalogResolver can be created with a > resolve property on top of the Catalog object. Joe Wang has updated the pull request incrementally with one additional commit since the last revision: Impl CSR Changes: change the parameter type from String to Enum

Re: RFR: JDK-8317612: ChoiceFormat and MessageFormat constructors call non-final public method [v4]

2023-10-27 Thread Lance Andersen
On Fri, 27 Oct 2023 18:40:56 GMT, Justin Lu wrote: >> Please review this PR which updates ChoiceFormat and MessageFormat to no >> longer call overridable methods in their constructors. >> >> The overridable methods called in the constructors are: >> _ChoiceFormat::applyPattern_,

Re: RFR: 8316969: Improve CDS module graph support for --module option [v3]

2023-10-27 Thread Calvin Cheung
On Fri, 27 Oct 2023 17:40:12 GMT, Alan Bateman wrote: >> I reran the script you sent me few days ago and got the expected results >> with the latest changes. >> The checking of the main module name matches between dump time and runtime >> is performed in the VM code. If an archive (even the

Re: RFR: JDK-8317612: ChoiceFormat and MessageFormat constructors call non-final public method [v4]

2023-10-27 Thread Naoto Sato
On Fri, 27 Oct 2023 18:40:56 GMT, Justin Lu wrote: >> Please review this PR which updates ChoiceFormat and MessageFormat to no >> longer call overridable methods in their constructors. >> >> The overridable methods called in the constructors are: >> _ChoiceFormat::applyPattern_,

Re: RFR: JDK-8317612: ChoiceFormat and MessageFormat constructors call non-final public method [v4]

2023-10-27 Thread Justin Lu
> Please review this PR which updates ChoiceFormat and MessageFormat to no > longer call overridable methods in their constructors. > > The overridable methods called in the constructors are: > _ChoiceFormat::applyPattern_, _ChoiceFormat::setChoices_, and > _MessageFormat::applyPattern_. The

Re: RFR: JDK-8317612: ChoiceFormat and MessageFormat constructors call non-final public method [v3]

2023-10-27 Thread Justin Lu
On Fri, 27 Oct 2023 18:00:38 GMT, Naoto Sato wrote: >> Justin Lu has updated the pull request incrementally with two additional >> commits since the last revision: >> >> - additional cleanup/wording changes >> - replace spec fix with private methods > >

Re: RFR: 8316996: Catalog API Enhancement: add a factory method [v4]

2023-10-27 Thread Joe Wang
> Add a new factory method so that a CatalogResolver can be created with a > resolve property on top of the Catalog object. Joe Wang has updated the pull request with a new target base due to a merge or a rebase. The incremental webrev excludes the unrelated changes brought in by the

Re: RFR: JDK-8317612: ChoiceFormat and MessageFormat constructors call non-final public method [v3]

2023-10-27 Thread Naoto Sato
On Fri, 27 Oct 2023 17:31:43 GMT, Justin Lu wrote: >> Please review this PR which updates ChoiceFormat and MessageFormat to no >> longer call overridable methods in their constructors. >> >> The overridable methods called in the constructors are: >> _ChoiceFormat::applyPattern_,

Re: RFR: 8316969: Improve CDS module graph support for --module option [v3]

2023-10-27 Thread Alan Bateman
On Fri, 27 Oct 2023 16:23:04 GMT, Calvin Cheung wrote: > I reran the script you sent me few days ago and got the expected results with > the latest changes. The checking of the main module name matches between dump > time and runtime is performed in the VM code. If an archive (even the default

Re: RFR: JDK-8317612: ChoiceFormat and MessageFormat constructors call non-final public method [v3]

2023-10-27 Thread Justin Lu
> Please review this PR and [CSR](https://bugs.openjdk.org/browse/JDK-8317630) > which makes the implications of overriding _ChoiceFormat::applyPattern_ and > _MessageFormat::applyPattern_ apparent by adding a implSpec tag to the > method. > > That is, the constructors of both ChoiceFormat

Re: RFR: 8316969: Improve CDS module graph support for --module option [v6]

2023-10-27 Thread Ioi Lam
On Thu, 26 Oct 2023 21:24:46 GMT, Calvin Cheung wrote: >> Please review this changeset for adding support for `--module` (-m) option >> for CDS. >> Changes in the `ModuleBootstrap.java` are needed so that the >> `ArchivedModuleGraph.archive` and `ArchivedBootLayer.archive` are called if >>

Re: RFR: 8316969: Improve CDS module graph support for --module option [v3]

2023-10-27 Thread Calvin Cheung
On Fri, 27 Oct 2023 13:57:38 GMT, Alan Bateman wrote: >> I've pushed another update with the following changes: >> >> - in the VM code, skip archiving full module graph if there's an incubator >> module by checking if the ArchivedBootLayer::archivedBootLayer is available; >> - included your

Re: RFR: 8318839: Update test thread factory to catch all exceptions

2023-10-27 Thread Leonid Mesnik
On Fri, 27 Oct 2023 05:55:43 GMT, David Holmes wrote: >> It is still used in tests and we should ignore it like jtreg doing. > > Shouldn't this code first retrieve the current default exception handler, and > then check whether t is a virtual thread, and if so handle the exception as >

Re: RFR: 8318586: Explicitly handle upcall stub allocation failure [v5]

2023-10-27 Thread Jorn Vernee
> Explicitly handle UpcallStub allocation failures by terminating. We currently > might try to use the returned `nullptr` which would fail sooner or later. > This patch just makes the termination explicit. Jorn Vernee has updated the pull request incrementally with one additional commit since

Re: RFR: 8254693: Add Panama feature to pass heap segments to native code [v12]

2023-10-27 Thread Yasumasa Suenaga
On Fri, 27 Oct 2023 11:28:29 GMT, Martin Doerr wrote: >> @YaSuenag `r12` is restored in `reinit_heapbase()` if needed and no, `r12` >> does not need remembering because it is a constant and can be restored from >> somewhere else. > > I think your code is fine. Restoring `r12_heapbase` at this

Re: RFR: 8316969: Improve CDS module graph support for --module option [v3]

2023-10-27 Thread Alan Bateman
On Thu, 26 Oct 2023 21:08:07 GMT, Calvin Cheung wrote: > I've pushed another update with the following changes: > > * in the VM code, skip archiving full module graph if there's an incubator > module by checking if the ArchivedBootLayer::archivedBootLayer is available; I think we still have

Update on JEP-461: Stream Gatherers (Preview)

2023-10-27 Thread Viktor Klang
Greetings, As you may have already seen, Stream Gatherers is now a Preview JEP with Candidate status Work-in-progress (interfaces, implementation, tests, benches, and documentation) for JEP-461 is currently available

Re: RFR: JDK-8266431: Dual-Pivot Quicksort improvements (Radix sort) [v9]

2023-10-27 Thread null
On Wed, 20 Sep 2023 16:33:56 GMT, Paul Sandoz wrote: >>> > Alan, you mentioned that DualPivotQuicksort will need detailed review. >>> > Can we go ahead and start reviewing? Laurent checked performance, JMH >>> > results look fine. >>> >>> As before, I think the main question with this change

Re: RFR: 8316662: Remove one allocation per conversion in Double.toString(double) and Float.toString(float) [v3]

2023-10-27 Thread Raffaello Giulietti
> By correctly sizing an intermediate `byte[]` and making use of the internal > `newStringNoRepl()` method, one allocation per conversion can be avoided when > the runtime uses compact strings. Raffaello Giulietti has updated the pull request with a new target base due to a merge or a rebase.

Re: RFR: 8254693: Add Panama feature to pass heap segments to native code [v12]

2023-10-27 Thread Martin Doerr
On Fri, 27 Oct 2023 10:23:43 GMT, Quan Anh Mai wrote: >> Question: `r12` does not need to remember? >> >> According to [CallingSequences in OpenJDK >> Wiki](https://wiki.openjdk.org/display/HotSpot/CallingSequences), `r12` may >> be reserved for HeapBase if COOP is enabled. >> (`r12` is

Re: RFR: 8305734: BitSet.get(int, int) always returns the empty BitSet when the Integer.MAX VALUE is set

2023-10-27 Thread Alan Bateman
On Sat, 22 Jul 2023 04:44:21 GMT, Stuart Marks wrote: >> See https://bugs.java.com/bugdatabase/view_bug?bug_id=8305734 and >> https://bugs.java.com/bugdatabase/view_bug?bug_id=JDK-8311905 > > Hi, thanks for the background and the discussion of the alternatives. I'm not > sure that drafting the

Re: RFR: 8305734: BitSet.get(int, int) always returns the empty BitSet when the Integer.MAX VALUE is set

2023-10-27 Thread null
On Sat, 22 Jul 2023 04:44:21 GMT, Stuart Marks wrote: >> See https://bugs.java.com/bugdatabase/view_bug?bug_id=8305734 and >> https://bugs.java.com/bugdatabase/view_bug?bug_id=JDK-8311905 > > Hi, thanks for the background and the discussion of the alternatives. I'm not > sure that drafting the

Re: RFR: 8254693: Add Panama feature to pass heap segments to native code [v12]

2023-10-27 Thread Quan Anh Mai
On Fri, 27 Oct 2023 03:49:17 GMT, Yasumasa Suenaga wrote: >> src/hotspot/cpu/x86/downcallLinker_x86_64.cpp line 110: >> >>> 108: __ mov(rsp, r12); // restore sp >>> 109: __ reinit_heapbase(); >>> 110: } >> >> This is a minor cleanup to share this code for the three use sites below. > >

Integrated: 8288899: java/util/concurrent/ExecutorService/CloseTest.java failed with "InterruptedException: sleep interrupted"

2023-10-27 Thread Doug Lea
On Sat, 3 Jun 2023 14:08:02 GMT, Doug Lea wrote: > Addresses Jdk 8288899 : java/util/concurrent/ExecutorService/CloseTest.java > failed with "InterruptedException: sleep interrupted" and related issues. > > This is a major ForkJoin update (and hard to review -- sorry) that finally > addresses

Re: RFR: 8318586: Explicitly handle upcall stub allocation failure [v4]

2023-10-27 Thread Jorn Vernee
> Explicitly handle UpcallStub allocation failures by terminating. We currently > might try to use the returned `nullptr` which would fail sooner or later. > This patch just makes the termination explicit. Jorn Vernee has updated the pull request incrementally with three additional commits

Re: RFR: 8318586: Explicitly handle upcall stub allocation failure [v3]

2023-10-27 Thread Jorn Vernee
On Thu, 26 Oct 2023 18:11:01 GMT, Jorn Vernee wrote: >> Explicitly handle UpcallStub allocation failures by terminating. We >> currently might try to use the returned `nullptr` which would fail sooner or >> later. This patch just makes the termination explicit. > > Jorn Vernee has updated the

Re: Integrated: 8318964: Fix build failures caused by 8315097

2023-10-27 Thread Roberto CastaƱeda Lozano
On Fri, 27 Oct 2023 09:48:00 GMT, Leo Korinth wrote: > Update method name after huge renaming conflict Looks good and trivial. - Marked as reviewed by rcastanedalo (Reviewer). PR Review: https://git.openjdk.org/jdk/pull/16395#pullrequestreview-1701407759

Re: Integrated: 8318964: Fix build failures caused by 8315097

2023-10-27 Thread Leo Korinth
On Fri, 27 Oct 2023 09:48:00 GMT, Leo Korinth wrote: > Update method name after huge renaming conflict Thanks!!! - PR Comment: https://git.openjdk.org/jdk/pull/16395#issuecomment-1782627439

Integrated: 8318964: Fix build failures caused by 8315097

2023-10-27 Thread Leo Korinth
On Fri, 27 Oct 2023 09:48:00 GMT, Leo Korinth wrote: > Update method name after huge renaming conflict This pull request has now been integrated. Changeset: b9dcd4b7 Author:Leo Korinth URL: https://git.openjdk.org/jdk/commit/b9dcd4b74138dd77faa46525f101b985248fffc5 Stats: 5

Re: Integrated: 8318964: Fix build failures caused by 8315097

2023-10-27 Thread Axel Boldt-Christmas
On Fri, 27 Oct 2023 09:48:00 GMT, Leo Korinth wrote: > Update method name after huge renaming conflict Marked as reviewed by aboldtch (Reviewer). Trivial fix. - PR Review: https://git.openjdk.org/jdk/pull/16395#pullrequestreview-1701406738 PR Comment:

Integrated: 8318964: Fix build failures caused by 8315097

2023-10-27 Thread Leo Korinth
Update method name after huge renaming conflict - Commit messages: - 8318964: Fix build failures caused by 8315097 Changes: https://git.openjdk.org/jdk/pull/16395/files Webrev: https://webrevs.openjdk.org/?repo=jdk=16395=00 Issue: https://bugs.openjdk.org/browse/JDK-8318964

Re: RFR: 8318586: Explicitly handle upcall stub allocation failure [v3]

2023-10-27 Thread Jorn Vernee
On Fri, 27 Oct 2023 08:52:42 GMT, Maurizio Cimadamore wrote: >> OOME is pretty much understood to be possible anywhere, given it is a >> VirtualMachineError. We often do not document it explicitly. The risk with >> documenting it is that it gives the impression that other methods, which >>

Re: RFR: 8254693: Add Panama feature to pass heap segments to native code [v12]

2023-10-27 Thread Jorn Vernee
On Fri, 27 Oct 2023 03:49:17 GMT, Yasumasa Suenaga wrote: >> src/hotspot/cpu/x86/downcallLinker_x86_64.cpp line 110: >> >>> 108: __ mov(rsp, r12); // restore sp >>> 109: __ reinit_heapbase(); >>> 110: } >> >> This is a minor cleanup to share this code for the three use sites below. > >

Re: RFR: 8318737: Fallback linker passes bad JNI handle [v3]

2023-10-27 Thread Jorn Vernee
On Fri, 27 Oct 2023 05:26:47 GMT, David Holmes wrote: > @JornVernee please don't forget that all non-trivial (as defined by the dev > guide) hotspot changes require at least 2 reviews and a 24 hour wait before > integration. Thanks. Right, sorry. I think I confused this PR with

Re: RFR: 8315097: Rename createJavaProcessBuilder [v7]

2023-10-27 Thread Leo Korinth
On Wed, 25 Oct 2023 08:44:29 GMT, Leo Korinth wrote: >> This pull request renames `createJavaProcessBuilder` to >> `createLimitedTestJavaProcessBuilder` and renames `createTestJvm` to >> `createTestJavaProcessBuilder`. Both are implemented through a private >> `createJavaProcessBuilder`. It

Re: RFR: 8318586: Explicitly handle upcall stub allocation failure [v3]

2023-10-27 Thread Maurizio Cimadamore
On Fri, 27 Oct 2023 04:54:04 GMT, David Holmes wrote: >> src/java.base/share/classes/java/lang/foreign/Linker.java line 532: >> >>> 530: * @throws IllegalArgumentException if an invalid combination of >>> linker options is given. >>> 531: * @throws IllegalCallerException If the

Re: RFR: 8318586: Explicitly handle upcall stub allocation failure [v3]

2023-10-27 Thread Maurizio Cimadamore
On Fri, 27 Oct 2023 04:54:04 GMT, David Holmes wrote: >> src/java.base/share/classes/java/lang/foreign/Linker.java line 532: >> >>> 530: * @throws IllegalArgumentException if an invalid combination of >>> linker options is given. >>> 531: * @throws IllegalCallerException If the

Integrated: 8315097: Rename createJavaProcessBuilder

2023-10-27 Thread Leo Korinth
On Mon, 28 Aug 2023 15:54:08 GMT, Leo Korinth wrote: > This pull request renames `createJavaProcessBuilder` to > `createLimitedTestJavaProcessBuilder` and renames `createTestJvm` to > `createTestJavaProcessBuilder`. Both are implemented through a private > `createJavaProcessBuilder`. It also

Re: RFR: 8318650: Optimized subword gather for x86 targets. [v2]

2023-10-27 Thread Xiaohong Gong
On Fri, 27 Oct 2023 05:09:15 GMT, Jatin Bhateja wrote: >> src/jdk.incubator.vector/share/classes/jdk/incubator/vector/ByteVector.java >> line 3062: >> >>> 3060: // Constant folding should sweep out following conditonal >>> logic. >>> 3061: if (isp.length() >

Withdrawn: 8317993: Add capturing factories to classes in java.util.function package

2023-10-27 Thread Per Minborg
On Tue, 17 Oct 2023 08:05:09 GMT, Per Minborg wrote: > This PR proposes to add a number of "capturing factories" in classes in the > `java.util.function` package. > > The PR additionally (an optionally) proposes to add a new function > `UnaryOperator::andThenUnary` to allow composition while

Re: RFR: 8318650: Optimized subword gather for x86 targets. [v2]

2023-10-27 Thread Xiaohong Gong
On Fri, 27 Oct 2023 05:09:23 GMT, Jatin Bhateja wrote: >> src/hotspot/share/opto/vectorIntrinsics.cpp line 1486: >> >>> 1484: // Check whether the predicated gather/scatter node is supported >>> by architecture. >>> 1485: VectorMaskUseType mask = (is_scatter || >>>

Re: RFR: 8314986: Module readability resolution is slow with large numbers of automatic modules

2023-10-27 Thread Alan Bateman
On Tue, 26 Sep 2023 14:57:58 GMT, Alan Bateman wrote: >> Fixes the issue (hopefully) by resolving automatic modules and automatic >> module dependencies after propagation of non-automatic transitive >> dependencies. The module tests run. >> >> I also added a few asserts to validate that the