On Fri, 2 Apr 2021 00:12:58 GMT, Sergey Bylokhov <s...@openjdk.org> wrote:

>> I do not suggest that the change should be moved forth and back, but I think 
>> that the second conditions should always be shifted, and if this causes 80 
>> chars overflow then some other line split/rename/etc should be done to 
>> prevent that.
>> 
>> Recent example of such style...:
>>             if ((getColorSpaceType (p) == ColorSpace.TYPE_RGB) &&
>>                 (getData (p, icSigMediaWhitePointTag) != null) &&
>>                 (getData (p, icSigRedColorantTag) != null) &&
>>                 (getData (p, icSigGreenColorantTag) != null) &&
>>                 (getData (p, icSigBlueColorantTag) != null) &&
>>                 (getData (p, icSigRedTRCTag) != null) &&
>>                 (getData (p, icSigGreenTRCTag) != null) &&
>>                 (getData (p, icSigBlueTRCTag) != null)) {
>>                 thisProfile = new ICC_ProfileRGB (p);
>> 
>> Is that really looks fine?
>
>> To make it clear, you're for keeping the indentation as it was in the 
>> original PR to visually separate condition from the statement in the if 
>> block. Do I get it right, @mrserb?
> 
> I think it looks better.

BTW another solution is to move { to the next line if the previous statement 
was split across few lines.

-------------

PR: https://git.openjdk.java.net/jdk/pull/3151

Reply via email to