upload_progress is an add-on module … maybe for some reason it’s not working hence the config failure? I don’t know anything about cnmaestro itself but NGINX changed it’s default behaviour with this module in 0.9 release so if you did any software upgrades recently then the timing may co-incide? Just a guess….
> On Sep 18, 2016, at 9:56 PM, Mike Hammett <[email protected]> wrote: > > root@cnmaestro:/home/cambium# tail /var/log/syslog > Sep 19 01:51:22 cnmaestro monit[845]: 'nginx' trying to restart > Sep 19 01:51:22 cnmaestro monit[845]: 'nginx' start: /etc/init.d/nginx > Sep 19 01:51:53 cnmaestro monit[845]: 'nginx' failed to start > Sep 19 01:52:53 cnmaestro monit[845]: 'nginx' process is not running > Sep 19 01:52:53 cnmaestro monit[845]: 'nginx' trying to restart > Sep 19 01:52:53 cnmaestro monit[845]: 'nginx' start: /etc/init.d/nginx > Sep 19 01:53:23 cnmaestro monit[845]: 'nginx' failed to start > Sep 19 01:54:23 cnmaestro monit[845]: 'nginx' process is not running > Sep 19 01:54:23 cnmaestro monit[845]: 'nginx' trying to restart > Sep 19 01:54:23 cnmaestro monit[845]: 'nginx' start: /etc/init.d/nginx > > > root@cnmaestro:/home/cambium# tail /var/log/nginx/error.log > 2016/09/19 01:42:18 [emerg] 3895#3895: unknown directive "upload_progress" in > /etc/nginx/conf.d/default.conf:56 > 2016/09/19 01:43:49 [emerg] 4937#4937: unknown directive "upload_progress" in > /etc/nginx/conf.d/default.conf:56 > 2016/09/19 01:45:20 [emerg] 5977#5977: unknown directive "upload_progress" in > /etc/nginx/conf.d/default.conf:56 > 2016/09/19 01:46:50 [emerg] 7057#7057: unknown directive "upload_progress" in > /etc/nginx/conf.d/default.conf:56 > 2016/09/19 01:47:02 [emerg] 7204#7204: unknown directive "upload_progress" in > /etc/nginx/conf.d/default.conf:56 > 2016/09/19 01:48:21 [emerg] 8111#8111: unknown directive "upload_progress" in > /etc/nginx/conf.d/default.conf:56 > 2016/09/19 01:49:51 [emerg] 9131#9131: unknown directive "upload_progress" in > /etc/nginx/conf.d/default.conf:56 > 2016/09/19 01:51:22 [emerg] 10258#10258: unknown directive "upload_progress" > in /etc/nginx/conf.d/default.conf:56 > 2016/09/19 01:52:53 [emerg] 11268#11268: unknown directive "upload_progress" > in /etc/nginx/conf.d/default.conf:56 > 2016/09/19 01:54:23 [emerg] 12383#12383: unknown directive "upload_progress" > in /etc/nginx/conf.d/default.conf:56 > > > # reserve 1MB under the name 'uploads' to track uploads > upload_progress uploads 1m; > > > > Thoughts? > > > > ----- > Mike Hammett > Intelligent Computing Solutions <http://www.ics-il.com/> > <https://www.facebook.com/ICSIL> > <https://plus.google.com/+IntelligentComputingSolutionsDeKalb> > <https://www.linkedin.com/company/intelligent-computing-solutions> > <https://twitter.com/ICSIL> > Midwest Internet Exchange <http://www.midwest-ix.com/> > <https://www.facebook.com/mdwestix> > <https://www.linkedin.com/company/midwest-internet-exchange> > <https://twitter.com/mdwestix> > The Brothers WISP <http://www.thebrotherswisp.com/> > <https://www.facebook.com/thebrotherswisp> > <https://www.youtube.com/channel/UCXSdfxQv7SpoRQYNyLwntZg>
