When amdgpu_gart_invalidate_tlb helper is introduced this part was left
out of the conversion. Avoid the code duplication here.

Signed-off-by: Yunxiang Li <yunxiang...@amd.com>
---
 drivers/gpu/drm/amd/amdgpu/amdgpu_gart.c | 5 +----
 1 file changed, 1 insertion(+), 4 deletions(-)

diff --git a/drivers/gpu/drm/amd/amdgpu/amdgpu_gart.c 
b/drivers/gpu/drm/amd/amdgpu/amdgpu_gart.c
index c623e23049d1..eb172388d99e 100644
--- a/drivers/gpu/drm/amd/amdgpu/amdgpu_gart.c
+++ b/drivers/gpu/drm/amd/amdgpu/amdgpu_gart.c
@@ -325,10 +325,7 @@ void amdgpu_gart_unbind(struct amdgpu_device *adev, 
uint64_t offset,
                        page_base += AMDGPU_GPU_PAGE_SIZE;
                }
        }
-       mb();
-       amdgpu_device_flush_hdp(adev, NULL);
-       for_each_set_bit(i, adev->vmhubs_mask, AMDGPU_MAX_VMHUBS)
-               amdgpu_gmc_flush_gpu_tlb(adev, 0, i, 0);
+       amdgpu_gart_invalidate_tlb(adev);
 
        drm_dev_exit(idx);
 }
-- 
2.34.1

Reply via email to