On 14/07/2026 09:51, Timur Kristóf wrote:
On Monday, July 13, 2026 12:15:13 PM Central European Summer Time Tvrtko
Ursulin wrote:
On 11/07/2026 12:30, Timur Kristóf wrote:
The current name is too long and triggers a warning.
Signed-off-by: Timur Kristóf <[email protected]>
---
drivers/gpu/drm/amd/display/amdgpu_dm/amdgpu_dm.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/drivers/gpu/drm/amd/display/amdgpu_dm/amdgpu_dm.c
b/drivers/gpu/drm/amd/display/amdgpu_dm/amdgpu_dm.c index
b97ceabe6173..6299f0e384f1 100644
--- a/drivers/gpu/drm/amd/display/amdgpu_dm/amdgpu_dm.c
+++ b/drivers/gpu/drm/amd/display/amdgpu_dm/amdgpu_dm.c
@@ -829,9 +829,9 @@ static int amdgpu_dm_init(struct amdgpu_device *adev)
}
if (adev->dm.dc->caps.max_links > 0) {
adev->dm.hdmi_frl_status_polling_wq =
-
create_singlethread_workqueue("hdmi_frl_status_polling_workqueue");
+
create_singlethread_workqueue("hdmi_frl_status_polling_wq");
if (!adev->dm.hdmi_frl_status_polling_wq)
- drm_err(adev_to_drm(adev), "failed to
initialize
hdmi_frl_status_polling_workqueue\n"); +
drm_err(adev_to_drm(adev),
"failed to initialize hdmi_frl_status_polling_wq\n");>
}
if (dc_is_dmub_outbox_supported(adev->dm.dc)) {
init_completion(&adev->dm.dmub_aux_transfer_done);
This one does not require display knowledge so I feel okay to review it:
Reviewed-by: Tvrtko Ursulin <[email protected]>
Two nitpicks would be that the _wq suffix is even redundant since for
the task name it will have the kworker/ prefix anyway.
Ok, what name do you suggest to use then?
Dropping the suffix. :)
Second one is
that while touching this it may make sense to replace the variable name
from the error message with a human readable name like "failed to
initialize HDMI FLR status polling".
Ok, can do.
You can leave it for follow up work. Perhaps to clarify things, when I
give r-b that implies it is acceptable as is. Otherwise I would have
said "with that fixed r-b".
In fact, is this even an error or
should be a warning given I do not see an immediate exit?
No idea, I just wanted to fix the warning that I saw.
drm_warn or drm_notice I would say is appropriate for things which
failed, were expected to work, but do not prevent the driver to probe
and work. Btw, on a glance, the neighbouring code is already confused
with a mix or drm_err and drm_info for this class of issues.
Regards,
Tvrtko