From: Taimur Hassan <[email protected]>

This version brings along the following updates:

 - Move the DML wrapper out of DML2 into its own component.
 - Expand amdgpu_dm KUnit coverage across DM init, teardown and IRQs.
 - Add KUnit tests to cover amdgpu_dm_* modules
 - Remove fixpt and custom float duplicated code.
 - Move custom float structures from opp.h to custom_float.h.
 - Fix the DPP PRE_GAM register offset on DCN60.
 - Update HDMI link rate and DSC handling for DCN60.
 - Fix DCN5/6 DML2 compilation warnings.
 - Fix order of operation in CalculateFlipSchedule.
 - Clean up the per-DPM struct.
 - Remove the const qualifier from non-pointer fields.
 - Model ASSERT as a path terminator.
 - Set the gpuvm min page size to 4K on dcn35/36.
 - Fix backlight control for luminance-capable OLED panels.
 - Restore the native cursor mode early return for disabled CRTCs.
 - Move cursor SDR white level calculation out of the hwss executor.
 - Avoid a NULL hubp deref for the remaining mpcc_id assignment.
 - Guard DAL port idle optimizations by ASIC revision.
 - Change RBBMIF timeout control conditions.
 - Re-enable multi-dwb support.
 - Remove the pipe_ctx param from MPC_VISUAL_CONFIRM.
 - Add a debug bit for force p2cpm.
 - Add a max_downscale_src_width debugfs for IGT validation.

Signed-off-by: Taimur Hassan <[email protected]>
Signed-off-by: Alex Hung <[email protected]>
---
 drivers/gpu/drm/amd/display/dc/dc.h | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/drivers/gpu/drm/amd/display/dc/dc.h 
b/drivers/gpu/drm/amd/display/dc/dc.h
index c7d5d60ff4c6..e1f1b0602b6d 100644
--- a/drivers/gpu/drm/amd/display/dc/dc.h
+++ b/drivers/gpu/drm/amd/display/dc/dc.h
@@ -66,7 +66,7 @@ struct dcn_dsc_reg_state;
 struct dcn_optc_reg_state;
 struct dcn_dccg_reg_state;
 
-#define DC_VER "3.2.395"
+#define DC_VER "3.2.396"
 
 /**
  * MAX_SURFACES - representative of the upper bound of surfaces that can be 
piped to a single CRTC
-- 
2.43.0

Reply via email to