To ease readability, use switch to set unique_id as supported for the
supported IP_VERSIONs, and set it to unsupported by default for all
other ASICs.
This makes it easier to add IP_VERSIONs later on, and makes it obvious
that it is not supported by default, instead of the current logic that
assumes that it is supported unless it is not one of the specified
IP_VERSIONs.

v2: Rebase onto previous IP_VERSION change

Signed-off-by: Kent Russell <kent.russ...@amd.com>
Reviewed-by: Alex Deucher <alexander.deuc...@amd.com>
Reviewed-by: Kevin Wang <kevinyang.w...@amd.com>
---
 drivers/gpu/drm/amd/pm/amdgpu_pm.c | 13 +++++++++----
 1 file changed, 9 insertions(+), 4 deletions(-)

diff --git a/drivers/gpu/drm/amd/pm/amdgpu_pm.c 
b/drivers/gpu/drm/amd/pm/amdgpu_pm.c
index 9ce597ded31d..4151db2678fb 100644
--- a/drivers/gpu/drm/amd/pm/amdgpu_pm.c
+++ b/drivers/gpu/drm/amd/pm/amdgpu_pm.c
@@ -1988,11 +1988,16 @@ static int default_attr_update(struct amdgpu_device 
*adev, struct amdgpu_device_
                if (adev->flags & AMD_IS_APU)
                        *states = ATTR_STATE_UNSUPPORTED;
        } else if (DEVICE_ATTR_IS(unique_id)) {
-               if (gc_ver != IP_VERSION(9, 0, 1) &&
-                   gc_ver != IP_VERSION(9, 4, 0) &&
-                   gc_ver != IP_VERSION(9, 4, 1) &&
-                   gc_ver != IP_VERSION(9, 4, 2))
+               switch (gc_ver) {
+               case IP_VERSION(9, 0, 1):
+               case IP_VERSION(9, 4, 0):
+               case IP_VERSION(9, 4, 1):
+               case IP_VERSION(9, 4, 2):
+                       *states = ATTR_STATE_SUPPORTED;
+                       break;
+               default:
                        *states = ATTR_STATE_UNSUPPORTED;
+               }
        } else if (DEVICE_ATTR_IS(pp_features)) {
                if (adev->flags & AMD_IS_APU || gc_ver < IP_VERSION(9, 0, 0))
                        *states = ATTR_STATE_UNSUPPORTED;
-- 
2.25.1

Reply via email to