On Fri, Mar 07, 2014 at 09:31:25AM -0800, john.johan...@canonical.com wrote:
> Make it more generic so that it can be shared with signals.
> 
> Signed-off-by: John Johansen <john.johan...@canonical.com>

So this looks good enough for Acked-by: Steve Beattie <st...@nxnw.org>,
just one question:

> +static int parse_X_sub_mode(const char *X, const char *str_mode, int 
> *result, int fail, const char *mode_desc __unused)
> +{
> +     int mode = 0;
> +     const char *p;
> +
> +     PDEBUG("Parsing X mode: %s\n", X, str_mode);
> +
> +     if (!str_mode)
> +             return 0;
> +
> +     p = str_mode;
> +     while (*p) {
> +             char current = *p;
> +             char lower;
> +
> +reeval:
> +             switch (current) {
> +             case COD_READ_CHAR:
> +                     PDEBUG("Parsing %s mode: found %s READ\n", X, 
> mode_desc);
> +                     mode |= AA_DBUS_RECEIVE;
> +                     break;
> +
> +             case COD_WRITE_CHAR:
> +                     PDEBUG("Parsing %s mode: found %s WRITE\n", X,
> +                            mode_desc);
> +                     mode |= AA_DBUS_SEND;

If this function is to be shared between dbus and signals, should
AA_DBUS_RECEIVE and AA_DBUS SEND be morphed into something more generic?
Or does that occur in the patch that introduces signal support?

-- 
Steve Beattie
<sbeat...@ubuntu.com>
http://NxNW.org/~steve/

Attachment: signature.asc
Description: Digital signature

-- 
AppArmor mailing list
AppArmor@lists.ubuntu.com
Modify settings or unsubscribe at: 
https://lists.ubuntu.com/mailman/listinfo/apparmor

Reply via email to