-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviewboard.asterisk.org/r/4010/#review13370
-----------------------------------------------------------


Your explanation wasn't immediately obvious to me, but basically you want to 
separate the CHANNEL(musicclass) from the Queue-musicclass, where the 
Queue-musicclass is the one as set in the specific queue context.

  musiconhold.conf:
  preferqueueclass=yes

  queues.conf:
  [queue1]
  musicclass=queuemusic

  extensions.conf:
  CHANNEL(musicclass)=holdmusic
  Queue(queue1) ; gets queuemusic

Sounds like a good idea.


/trunk/configs/samples/musiconhold.conf.sample
<https://reviewboard.asterisk.org/r/4010/#comment23857>

    I don't like the term 'appoverridechannel'.
    
    Could you rename that to 'preferqueueclass'?
    
    Description:
    "The musicclass defined in the music on hold class takes precedence over 
any CHANNEL set musicclass. Defaults to no."



/trunk/res/res_musiconhold.c
<https://reviewboard.asterisk.org/r/4010/#comment23859>

    Don't touch chan->musicclass, use ast_channel_musicclass(chan).



/trunk/res/res_musiconhold.c
<https://reviewboard.asterisk.org/r/4010/#comment23858>

    (A) If !MOH_APPOVERRIDECHANNEL, then you're loading this twice. Don't do 
that, especially not when there is realtime involved. Add a 
MOH_APPOVERRIDECHANNEL test.
    
    (B) chan->musicclass? Looks like old code. Did this compile on trunk? You 
mean ast_channel_musicclass(chan)..


- wdoekes


On Sept. 22, 2014, 7:35 a.m., Kristian Høgh wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviewboard.asterisk.org/r/4010/
> -----------------------------------------------------------
> 
> (Updated Sept. 22, 2014, 7:35 a.m.)
> 
> 
> Review request for Asterisk Developers.
> 
> 
> Bugs: ASTERISK-24276
>     https://issues.asterisk.org/jira/browse/ASTERISK-24276
> 
> 
> Repository: Asterisk
> 
> 
> Description
> -------
> 
> General option to musiconhold.conf, to make applications MOH override 
> channels musicclass.
> Defaults to no, as it is current behavior.
> 
> 
> We use a single trunk for multiple users. The default musicclass from 
> sip.conf is therefore the same for all calls.
> The trunk is connected to a kamailio server, where all in- and outgoing calls 
> are send/received.
> Each customer (identified by custom headers) can choose a musicclass for MOH, 
> which we apply to the channel.
> When a user dials an extension, which point to a queue, we want the user to 
> receive the queue music.
> But we still want the user to keep the preferred musicclass, if the call is 
> put on hold later.
> Therefore we cant unset musicclass before calling the queue.
> Company A prefer musicclass heavy-metal.
> That musicclass is therefore applied to incoming calls.
> The customer service need to calm people down. Therefore they use other music 
> as queue music.
> 
> 
> Diffs
> -----
> 
>   /trunk/res/res_musiconhold.c 423656 
>   /trunk/configs/samples/musiconhold.conf.sample 423656 
> 
> Diff: https://reviewboard.asterisk.org/r/4010/diff/
> 
> 
> Testing
> -------
> 
> Whithout this patch or new option appoverridechannel=no or no 
> appoverridechannel set in musiconhold.conf:
> - The queue "myqueue", has musicclass=queueclass
> - Set(CHANNEL(musiconhold)=mohclass) followed by Queue(myqueue), makes caller 
> hear "mohclass" while waiting for agent to answer.
> 
> Whith appoverridechannel=yes in musiconhold.conf:
> - The queue "myqueue", has musicclass=queueclass
> - Set(CHANNEL(musiconhold)=myclass) followed by Queue(myqueue), makes caller 
> hear "queueclass" while waiting for agent to answer.
> 
> 
> Thanks,
> 
> Kristian Høgh
> 
>

-- 
_____________________________________________________________________
-- Bandwidth and Colocation Provided by http://www.api-digital.com --

asterisk-dev mailing list
To UNSUBSCRIBE or update options visit:
   http://lists.digium.com/mailman/listinfo/asterisk-dev

Reply via email to