ath5k svn trunk has been updated to reflect wireless-2.6.git as of v2.6.24-rc1-155-g792296c. This update consists of 16 patches, their respective log is below. These changes fix a few important bugs and also enhances the reporting of your card upon load.
http://svn.madwifi.org/ath5k/trunk commit 286c21f7d6b7a0315d717bdaf5efc320bbd19df6 Author: Luis R. Rodriguez <[EMAIL PROTECTED]> Date: Thu Nov 1 23:11:31 2007 -0400 ath5k: Add documentation for struct ath5k_rate This adds documentation for struct ath5k_rate. This also removes some unused variables, lp_ack_duration and sp_ack_duration which are simply unnecessary. We're now just missing information about rate hw values: 3-5 16 17-23 28-32 If anyone knows what those are, please let us know. Changes to ath5k.h Changes-licensed-under: ISC Signed-off-by: Luis R. Rodriguez <[EMAIL PROTECTED]> Signed-off-by: John W. Linville <[EMAIL PROTECTED]> commit 9041185a6b7e26cc311d61394d5b5bdced13f76d Author: Luis R. Rodriguez <[EMAIL PROTECTED]> Date: Thu Nov 1 17:55:53 2007 -0400 ath5k: Clear up settings of AR5K_RSSI_THR register settings Clear up settings of AR5K_RSSI_THR register settings. These are split between AR5K_TUNE_BMISS_THRES and AR5K_TUNE_RSSI_THRES. Changes to ath5k.h, hw.c Changes-licensed-under: ISC Signed-off-by: Luis R. Rodriguez <[EMAIL PROTECTED]> Signed-off-by: John W. Linville <[EMAIL PROTECTED]> commit 84ec69f4ff5a27f518c0be9069065cc9046eb42a Author: Luis R. Rodriguez <[EMAIL PROTECTED]> Date: Thu Nov 1 17:53:18 2007 -0400 ath5k: Move OFDM timings into a helper routine This move the OFDM timings on ath5k_hw_reset() onto a helper, ath5k_hw_write_ofdm_timings() to make code cleaner. Changes to ath5k.h, hw.c Changes-licensed-under: ISC Signed-off-by: Luis R. Rodriguez <[EMAIL PROTECTED]> Signed-off-by: John W. Linville <[EMAIL PROTECTED]> commit 8a041a0be5cd322f018de4b1aea6b2511183925b Author: Luis R. Rodriguez <[EMAIL PROTECTED]> Date: Thu Nov 1 00:38:16 2007 -0400 ath5k: Fix clock on OFDM timing computation We were setting the clock to the turbo sampling rate always, lets fix this for plain OFDM sampling rate at 40 MHz. I believe this tunes the PLL to the desired frequency, by setting the mantissa and the exponent. Changes to hw.c Changes-licensed-under: ISC Signed-off-by: Luis R. Rodriguez <[EMAIL PROTECTED]> Signed-off-by: John W. Linville <[EMAIL PROTECTED]> commit a4652a02120b518f0399440178f575802a690758 Author: Luis R. Rodriguez <[EMAIL PROTECTED]> Date: Thu Nov 1 17:50:30 2007 -0400 ath5k: Clean up ath5k rate duration settings Replace ath5k's rate duration computations for one using mac80211's internals. Another consideration here is to simply remove these and put them into initval values. They seem to be static values based only on mode. We can do this later though once we can physically confirm by trial and error these are indeed just used for ACK timeout. The next puzzle is figuring out which registers are actually setting the control rates. Changes to ath5k.h, hw.c Changes-licensed-under: ISC Signed-off-by: Luis R. Rodriguez <[EMAIL PROTECTED]> Signed-off-by: John W. Linville <[EMAIL PROTECTED]> commit 3521cf5856b3577a65c1e3c8aeba95a6395c290c Author: Luis R. Rodriguez <[EMAIL PROTECTED]> Date: Thu Nov 1 00:35:20 2007 -0400 ath5k: Remove opaque pointers from ath5k_hw_attach() Since we don't have a HAL anymore there is no point to use opaque pointers in ath5k_hw_attach(). This will also give hw.c access to ath5k_softc structure now when needed. While we're at it, lets also give some ah_sh a reasonable name, ah_sh --> ah_iobase. Changes to base.c Changes-licensed-under: 3-clause-BSD Changes to ath5k.h, hw.c Changes-licensed-under: ISC Signed-off-by: Luis R. Rodriguez <[EMAIL PROTECTED]> Signed-off-by: John W. Linville <[EMAIL PROTECTED] commit f00b836d70c20dc72642c6c702b0206cc960f1e3 Author: Luis R. Rodriguez <[EMAIL PROTECTED]> Date: Thu Nov 1 00:34:24 2007 -0400 ath5k: Fix initval/eeprom/IQ calibration for G mode ath5k_hw_reset() was always setting initval and eeprom settings for B mode when using G mode. This is because a B channel was being picked up first. We should first instead check for G channel. This patch also introduces a driver_mode variable which should be used instead for determing more reliably the mode we're in. This fixing another bug where IQ calibration was not being run for G mode as CHANNEL_B was always being picked up first. We now instead check for driver_mode. Similar problem was occurring in ath5k_hw_rf5112_rfregs(), we fix this there too. Changes to phy.c, hw.c Changes-licensed-under: ISC Signed-off-by: Luis R. Rodriguez <[EMAIL PROTECTED]> Signed-off-by: John W. Linville <[EMAIL PROTECTED]> commit 7c9873193d01789688f7699d47a49455dfddfd64 Author: Ulrich Meis <[EMAIL PROTECTED]> Date: Tue Oct 30 22:20:56 2007 +0100 ath5k: 4word tx descriptor setup doesn't set BUF_LEN This line got lost when the descriptor setup and fill functions were merged. Applies ontop of Nick's patches. Changes-licensed-under: ISC Signed-off-by: Ulrich Meis <[EMAIL PROTECTED]> Signed-off-by: John W. Linville <[EMAIL PROTECTED]> commit 596d594f301545a2ff17995783ff20a7062a8f73 Author: Nick Kossifidis <[EMAIL PROTECTED]> Date: Sun Oct 28 02:58:27 2007 +0300 ath5k: Remove fill_tx_desc fill_tx_desc is used for fast frames operation, since we don't support fast frames (and since fill_tx_desc had a bug -thanx to Ulrich Meis for finding that out-) these functions are not needed (+ they are misleading because they don't "fill" any tx descriptor). I couldn't test this patch much so plz someone ACK it... It applies on top of my previous patches (i just thought that [PATCH 8/7] won't look nice ;-) ). Changes-licensed-under: ISC Signed-off-by: Ulrich Meis <[EMAIL PROTECTED]> Signed-Off-by: Nick Kossifidis <[EMAIL PROTECTED]> Signed-off-by: John W. Linville <[EMAIL PROTECTED]> commit e18665b50d165cd59e914e4b18b6f38cf916cc5f Author: Nick Kossifidis <[EMAIL PROTECTED]> Date: Sun Oct 28 02:44:18 2007 +0300 ath5k: Warn on partially supported chips *Warn on partially supported chips (eg. 5414/5424) These chips need work on PHY part, recently Reyk posted a workaround so that they can work on 2GHz but i believe that the problem is related to PHY initialization. Plz we need help with these... I did some tests on a 5414 at 5GHz and it seemed to work but i didn't test it at 2GHz. I'll try to find one of these and play with. Changes-licensed-under: ISC Signed-Off-by: Nick Kossifidis <[EMAIL PROTECTED]> Signed-off-by: John W. Linville <[EMAIL PROTECTED]> commit 912f62dce645b5b8d0ae385e3889e4f56912612a Author: Nick Kossifidis <[EMAIL PROTECTED]> Date: Sun Oct 28 02:31:13 2007 +0300 ath5k: Add PCI IDs for newer chips *Add PCI IDs for 5416/5418. *Print a message during attach that these chips are not yet supported. for base.c Changes-licensed-under: 3-clause-BSD for ath5k.h Changes-licensed-under: ISC Signed-Off-by: Nick Kossifidis <[EMAIL PROTECTED]> Signed-off-by: John W. Linville <[EMAIL PROTECTED]> commit a85dc26859a0ea76a1b89264f6baceacde697f52 Author: Nick Kossifidis <[EMAIL PROTECTED]> Date: Sun Oct 28 02:24:59 2007 +0300 athk: Use SREV to identify single-chip solutions Use SREV instead of pci id to identify single chip solutions. Srev is more accurate info to identify the chip + this makes it possible to identify some 5424 chips found on thinkpads with faulty 5212 pci id. Changes-licensed-under: ISC Signed-Off-by: Nick Kossifidis <[EMAIL PROTECTED]> Signed-off-by: John W. Linville <[EMAIL PROTECTED]> commit e04127274799db52ceff2a59c434d35348b5a722 Author: Nick Kossifidis <[EMAIL PROTECTED]> Date: Sun Oct 28 02:20:33 2007 +0300 ath5k: Add SREV values for newer chips * Add new Silicon Revision values (hex values written on chip) to be able to identify them. * Give more infos about mac/phy/radio revision during attach. for ath5k.h Changes-licensed-under: ISC for base.c Changes-licensed-under: 3-clause-BSD Signed-Off-by: Nick Kossifidis <[EMAIL PROTECTED]> Signed-off-by: John W. Linville <[EMAIL PROTECTED]> commit 2ee34d56f98bfd98fb8379f4dff44d970d1e87bf Author: Nick Kossifidis <[EMAIL PROTECTED]> Date: Sun Oct 28 02:13:32 2007 +0300 ath5k: Remove obsolete sysctl stuff Remove sysctl tables. We shouldn't use /proc to configure things. Changes-licensed-under: 3-clause-BSD Signed-Off-by: Nick Kossifidis <[EMAIL PROTECTED]> Signed-off-by: John W. Linville <[EMAIL PROTECTED]> commit 303bfb389b5b45053c651b3b6cc389f53e032df0 Author: Nick Kossifidis <[EMAIL PROTECTED]> Date: Sun Oct 28 02:06:42 2007 +0300 ath5k: Rename some functions I've renamed some functions for better maintainability... ath5k_mode_init -> ath5k_mode_setup ath5k_rxbuf_init -> ath5k_rxbuf_setup Because it's not just initialization + we use "setup" on the rest of the code (eg. beacon_setup). ath5k_tx_bf -> ath5k_txbuf_setup Obvious ath5k_cleanup_txbuf -> ath5k_txbuf_free Previous name is misleading because someone might think that it cleans all tx buffers, we use "free" to declare that it only cleans one given buffer. ath5k_tx_draintxq -> ath5k_txq_drainq ath5k_draintxq -> ath5k_txq_cleanup Same here ath5k_draintxq seems to refer to only one queue when in fact it drains all queues, so we use "cleanup" as above. ath5k_tx_cleanup -> ath5k_txq_release This one doesn't do any cleanup, it just calls hw_release for each queue. ath5k_startrecv -> ath5k_rx_start ath5k_stoprecv -> ath5k_rx_stop As above i try to maintain a naming scheme that links with the sorting i've done. Eg. ath5k_desc for descriptor related funcions, ath5k_rx/tx for general rx/tx functions, ath5k_txq for tx queues, ath5k_hw (inside hw.c and rest) for hw related functions and so on. This helps us track down things more easily. Changes-licensed-under: 3-clause-BSD Signed-Off-by: Nick Kossifidis <[EMAIL PROTECTED]> Signed-off-by: John W. Linville <[EMAIL PROTECTED]> commit 098c5ce6be93417b94e96b4da8e848e4539d2d19 Author: Nick Kossifidis <[EMAIL PROTECTED]> Date: Sun Oct 28 02:04:25 2007 +0300 ath5k: Maintain coding style * Sort functions in segments like we do on the rest of the code (eg. hw.c). This improves readability and maintainability. * Add myself as module author (a patch for this was submited some time ago as part of SFLC's changes but wasn't applied) * Declare that this driver is or 5xxx chipset series only in MODULE_SUPPORTED_DEVICE and MODULE_DESCRIPTION. Changes-licensed-under: 3-clause-BSD Signed-Off-by: Nick Kossifidis <[EMAIL PROTECTED]> Signed-off-by: John W. Linville <[EMAIL PROTECTED]> _______________________________________________ ath5k-devel mailing list ath5k-devel@lists.ath5k.org https://lists.ath5k.org/mailman/listinfo/ath5k-devel