On 09/23/2010 01:33 AM, Johannes Berg wrote:
> On Wed, 2010-09-22 at 21:58 -0700, Ben Greear wrote:
>
>
>> + * @addr2: local address (vif->sdata->dev->dev_addr).  Can be NULL for 
>> 'any'.
>>     *
>>     * This function must be called under RCU lock and the
>>     * resulting pointer is only valid under RCU lock as well.
>> @@ -2434,7 +2435,8 @@ struct ieee80211_sta *ieee80211_find_sta(struct 
>> ieee80211_vif *vif,
>>     * DO NOT USE THIS FUNCTION.
>>     */
>>    struct ieee80211_sta *ieee80211_find_sta_by_hw(struct ieee80211_hw *hw,
>> -                                              const u8 *addr);
>> +                                              const u8 *addr,
>> +                                              const u8 *localaddr);
>
> That's not going to generate proper documentation. Also, it now probably
> shouldn't be called "by_hw" any more.

I can't think of a better name, and it still does take the hw struct,
but if you have a suggestion you like better, I will use it.

I re-posted with the rest of the changes you suggested.  Seems to
be working fine.

Thanks,
Ben

-- 
Ben Greear <gree...@candelatech.com>
Candela Technologies Inc  http://www.candelatech.com
_______________________________________________
ath9k-devel mailing list
ath9k-devel@lists.ath9k.org
https://lists.ath9k.org/mailman/listinfo/ath9k-devel

Reply via email to