Bartosz Markowski <bartosz.markow...@tieto.com> writes:

> --- a/drivers/net/wireless/ath/ath10k/core.c
> +++ b/drivers/net/wireless/ath/ath10k/core.c
> @@ -663,6 +663,31 @@ void ath10k_core_unregister(struct ath10k *ar)
>  }
>  EXPORT_SYMBOL(ath10k_core_unregister);
>  
> +#if defined(CONFIG_PM_SLEEP)
> +int ath10k_pdev_suspend_target(struct ath10k *ar) {
> +     int ret;
> +
> +     ath10k_dbg(ATH10K_DBG_CORE, "%s: called", __func__);
> +
> +     ret = ath10k_wmi_pdev_suspend_target(ar);
> +
> +     return ret;
> +}
> +EXPORT_SYMBOL(ath10k_pdev_suspend_target);
> +
> +int ath10k_pdev_resume_target(struct ath10k *ar) {
> +
> +     int ret;
> +
> +     ath10k_dbg(ATH10K_DBG_CORE, "%s: called", __func__);
> +
> +     ret = ath10k_wmi_pdev_resume_target(ar);
> +
> +     return ret;
> +}
> +EXPORT_SYMBOL(ath10k_pdev_resume_target);

Please rename them to ath10k_core_suspend() and _resume() or something
like that.

-- 
Kalle Valo
_______________________________________________
ath9k-devel mailing list
ath9k-devel@lists.ath9k.org
https://lists.ath9k.org/mailman/listinfo/ath9k-devel

Reply via email to