A more gentle version of C, thoughts and suggestions?

Hi all,
OK, before I dive into what I am trying to do, let me point out a few things:
1. I don't want anyone posting on this thread who simply wants to reprimand me on how C isn't meant for this. I am not trying to make a better version of C, I just want to make my own version of it, for more basic people who are starting to learn how to program, and who want to learn C, yet they don't want to use all the symbols like <<, >>, <=, >=, <<=, >>=, etc. Basically, I'm trying to do something a little more English-like.
2. I don't want people to criticize me and tell me not to do this. Its my first try at building a parser; probably a successful one at that, so I don't want people to immediately tell me off it. You need to try it out before you just go and yell at me for it. Of course, I can't exactly let you try it out; I just want to see your thoughts and suggestions you might want to add to the language.
OK, so here's my idea:
I came upon a parser named DParser. I was looking for a good parser generator (there are a total of 170 parser generators, at least that's how many there are on Wikipedia's Comparison of parser generators page, found at http://en.wikipedia.org/wiki/Comparison … generators ). I really wanted to see which one was good for me. I tryed flex and bison; no luck there, and many others. However, I hadn't loked at DParser, so I did. Its very interesting, and I like it. I found this ANSI C Grammar, and decided to mold it to my needs. So, I came up with this new language. Its not developed yet, and I hope to try it out some day. However, I'll give you a little of the final result (if I ever complete it!) Here's a little code sample, at least I hope it looks like this in the end:
include "io.h"
// A when loop (when loops are very similar to while loops)
void main():
bool display_window_id = false
when display_window_id is equal to true:
print ("Hi!")
end when
end void
// An if statement:
if 34814 times 93 is equal to 3237702, then
int result = 34819 times 93
or
int result = 0
end if
I hope it looks like that, anyways.
Right now, I'm stuck on the following grammar line:
shift_expression : additive_expression (('<<' | '>>') additive_expression)* ;
This sets the << and >> to be bitwise operators, but I need names for them. << is the bitwise left shift, and >> is the bitwise right shift. What would be good names for these two operators?
For now, I'll keep them as << and >>, but if anyone comes up with good names that make sense, please tell me.

_______________________________________________
Audiogames-reflector mailing list
Audiogames-reflector@sabahattin-gucukoglu.com
https://sabahattin-gucukoglu.com/cgi-bin/mailman/listinfo/audiogames-reflector

Reply via email to