o bugfix
- bugfix: increment sbinfo generation in cases of br_mod() for sensing
whiteout, xino/noxino and udba=inotify, too. introducing
au_is_whable() and sbr_is_whable(). call au_sigen_inc() from
do_opts(), reported by Jorgen P. Tjerno.
o news
- support sysfs and NFS-exporting, introducing sysaufs.c,
CONFIG_AUFS_SYSAUFS, export.c, CONFIG_AUFS_EXPORT and a new module
parameter 'brs.'
- remove AUFS_DEBUG_RWSEM.
- workaround an application bug when 'dlgt' is specified.
generally, read(2) or write(2) may return the value shorter
than requested. But many applications don't support it,
for example bash.
- support file gid when 'dlgt' is set.
o misc
- add a note about SMP.
- add a note about lockdep, still testing.
- add a note about performance test.
- convert branch permission bits into an integer.
- add an branch mode alias 'rowh' which is equivalent to 'ro+wh.'
- macro functions are converted to inline function.
- rename some symbols.
- merge hidden_notify_change() into vfsub_notify_change().
- convert the type of aufs_nwkq to short, since linux/kernel/params.c
prints as '%c' for 'byte'.
- accounting in workqueue, refine the algorithm of choosing the thread.
- refined LHASH_PATCH and DLGT condition for lkup_one() and lkup_hash().
- refine file read/write when 'dlgt' is specified.
- refine DLGT condition for minor optimization.
- stop setting the first branch mode to 'rw' by default, when the mount
flag is 'ro.'
Junjiro Okajima
----------------------------------------------------------------------
Index: Kconfig.in
Index: local.mk
- support sysfs and NFS-exporting, introducing sysaufs.c,
CONFIG_AUFS_SYSAUFS, export.c, CONFIG_AUFS_EXPORT and a new module
parameter 'brs.'
- remove AUFS_DEBUG_RWSEM.
Index: README
- add a note about SMP.
- add a note about lockdep, still testing.
- add a note about performance test.
Index: branch.h
- convert branch permission bits into an integer.
- macro functions are converted to inline function.
- rename some macros 'AufsXxx' to 'AuXxx.'
- move mnt_nfs() from dentry.h, with renaming to au_nfsmnt().
- move do_mnt_nfs() from super.h, with renaming to au_do_nfsmnt().
- bugfix: increment sbinfo generation in cases of br_mod() for sensing
whiteout, xino/noxino and udba=inotify, too. introducing
au_is_whable() and sbr_is_whable(). call au_sigen_inc() from
do_opts(), reported by Jorgen P. Tjerno.
Index: cpup.h
Index: whout.h
- macro functions are converted to inline function.
Index: debug.h
- move MtxMustLock() from misc.h.
- simplified lockdep subclasses, move them to dentry.h and inode.h,
still testing.
Index: dentry.h
- macro functions are converted to inline function.
- move mnt_nfs() to branch.h, with renaming to au_nfsmnt().
- refined LHASH_PATCH and DLGT condition for lkup_one() and lkup_hash().
- prefixed by 'au_',
digen(), direval_test(), direval_inc(), direval_dec(), h_dptr_i(),
h_dptr()
- simplified lockdep subclasses, still testing.
Index: dir.h
- n_hash() macro function is converted to inline function, with
renaming to au_name_hash().
Index: file.h
- macro functions are converted to inline function
- prefixed by 'au_',
h_fptr_i(), h_fptr(), figen(), is_mmapped()
- lockdep subclasses is unnecessary.
Index: inode.h
- move the declaration of inode operations to i_op.c.
- prefixed by 'au_',
h_iptr_i(), h_iptr()
- simplified lockdep subclasses, still testing.
- macro functions are converted to inline function.
- rename aufs_new_inode() to au_new_inode().
Index: misc.h
- remove CONFIG_AUFS_DEBUG_RWSEM.
- macro functions are converted to inline function.
- merge hidden_notify_change() into vfsub_notify_change().
- prefixed by 'au_',
kzrealloc()
- move is_kthread() macro from wkq.h, with renaming to au_is_kthread().
Index: module.h
- prefixed by 'au_',
esc_chars, dir_ro_flags
- convert the type of aufs_nwkq to short, since linux/kernel/params.c
prints as '%c' for 'byte'.
- new global variable au_wkq.
- rename AUFS_CACHE_xxx to AuCache_xxx.
- macro functions are converted to inline function.
Index: opts.h
- convert branch permission bits into an integer.
- prefixed by 'au_',
free_opts(), parse_opts(), do_opts()
Index: super.h
- prefixed by 'au_',
sbtype()
- rename them
SB_AUFS() au_is_aufs()
SB_NFS() au_is_nfs()
SB_REMOTE() au_is_remote()
MS_xxx flags AuFlag_xxx
MS_SET() au_flag_set()
MS_CLR() au_flag_clr()
IS_MS() au_flag_test(), au_flag_test_udba(), au_flag_test_coo()
- move do_mnt_nfs() to branch.h, with renaming to au_do_nfsmnt().
- macro functions are converted to inline function.
Index: vfsub.h
- merge hidden_notify_change() into vfsub_notify_change().
- macro functions are converted to inline function.
- simplified lockdep subclasses, still testing.
Index: wkq.h
- accounting wkq workload.
- rename AufsXXX macros to AuXXX.
- move is_kthread() macro to debug.h with renaming au_is_kthread().
Index: branch.c
- remove CONFIG_AUFS_DEBUG_RWSEM.
- convert branch permission bits into an enumerated integer.
- simplified lockdep, still testing.
- bugfix: increment sbinfo generation in cases of br_mod() for sensing
whiteout, xino/noxino and udba=inotify, too. introducing
au_is_whable() and sbr_is_whable(). call au_sigen_inc() from
do_opts(), reported by Jorgen P. Tjerno.
- follow the renamed symbols.
Index: dentry.c
- refined LHASH_PATCH and DLGT condition for lkup_one() and lkup_hash().
- follow the renamed symbols.
- bugfix: increment sbinfo generation in cases of br_mod() for sensing
whiteout, xino/noxino and udba=inotify, too. introducing
au_is_whable() and sbr_is_whable(). call au_sigen_inc() from
do_opts(), reported by Jorgen P. Tjerno.
- remove CONFIG_AUFS_DEBUG_RWSEM.
Index: f_op.c
- follow the renamed symbols.
- refine file read/write when 'dlgt' is specified.
- simplified lockdep, still testing.
Index: finfo.c
Index: hinotify.c
- follow the renamed symbols.
- remove CONFIG_AUFS_DEBUG_RWSEM.
Index: i_op.c
- refine DLGT condition for minor optimization.
- convert branch permission bits into an enumerated integer.
- follow the renamed symbols.
- move the delcarations of inode operation from inode.h.
Index: misc.c
- merge hidden_notify_change() into vfsub_notify_change().
- follow the renamed symbols.
Index: module.c
- follow the renamed symbols.
- convert the type of aufs_nwkq from char to short, since
param_set_byte() print it as '%c'.
Index: opts.c
- follow the renamed symbols.
- convert branch permission bits into an enumerated integer.
- remove CONFIG_AUFS_DEBUG_RWSEM.
- stop setting the first branch mode to 'rw' by default, when the mount
flag is 'ro.'
- add an branch mode alias 'rowh' which is equivalent to 'ro+wh.'
- bugfix: increment sbinfo generation in cases of br_mod() for sensing
whiteout, xino/noxino and udba=inotify, too. introducing
au_is_whable() and sbr_is_whable(). call au_sigen_inc() from
do_opts(), reported by Jorgen P. Tjerno.
Index: super.c
- follow the renamed symbols.
- remove CONFIG_AUFS_DEBUG_RWSEM.
- bugfix: increment sbinfo generation in cases of br_mod() for sensing
whiteout, xino/noxino and udba=inotify, too. introducing
au_is_whable() and sbr_is_whable(). call au_sigen_inc() from
do_opts(), reported by Jorgen P. Tjerno.
- simplified lockdep, still testing.
Index: vfsub.c
- merge hidden_notify_change() into vfsub_notify_change().
- workaround an application bug when 'dlgt' is specified.
generally, read(2) or write(2) may return the value shorter
than requested. But many applications don't support it,
for example bash.
- follow the renamed symbols.
- refine DLGT condition for minor optimization.
Index: whout.c
- follow the renamed symbols.
- convert branch permission bits into an enumerated integer.
Index: wkq.c
- accounting in workqueue, refine the algorithm of choosing the thread.
- support file gid when 'dlgt' is set.
- follow the renamed symbols.
Index: dinfo.c
Index: sbinfo.c
- follow the renamed symbols.
- simplified lockdep, still testing.
Index: cpup.c
Index: debug.c
Index: dir.c
Index: file.c
Index: i_op_add.c
Index: i_op_del.c
Index: i_op_ren.c
Index: iinfo.c
Index: inode.c
Index: vdir.c
Index: xino.c
- follow the renamed symbols.
Index: util/aufs.in.5
- support sysfs and NFS-exporting, introducing sysaufs.c,
CONFIG_AUFS_SYSAUFS, export.c, CONFIG_AUFS_EXPORT and a new module
parameter 'brs.'
- add an branch mode alias 'rowh' which is equivalent to 'ro+wh.'
- remove AUFS_DEBUG_RWSEM.
- remove a note about lockdep, still testing.
Index: include/linux/aufs_type.h
- less important change
-------------------------------------------------------------------------
Take Surveys. Earn Cash. Influence the Future of IT
Join SourceForge.net's Techsay panel and you'll get the chance to share your
opinions on IT & business topics through brief surveys-and earn cash
http://www.techsay.com/default.php?page=join.php&p=sourceforge&CID=DEVDEV