Hi,
Just working my way through a setup using the new 3 series cgi editor.
When i edit "Email Settings", Dest Domain or other and save, it blitzes
the config.pl file, and BackupPC cannot start.
its all to do with the "Email headers" section.
Previously I had this in the config file.....
$Conf{EMailHeaders} = <<EOF;
MIME-Version: 1.0
Content-Type: text/plain; charset="iso-8859-1"
EOF
even if i don't modify EmailHeaders, but modify something else and save,
the "EmailHeaders" in config.pl ends up looking like....
$Conf{EMailHeaders} = 'MIME-Version: 1.0
Content-Type: text/plain; charset="iso-8859-1"
';
';
Consequently this pops up in the cgi....
Error: Unable to read config.pl or language strings!!
and this when you try to restart......
[EMAIL PROTECTED] conf.d]# service backuppc restart
Shutting down BackupPC: [ OK ]
Starting BackupPC: Bareword found where operator expected at
/etc/BackupPC/config.pl line 1872, near "# by spaces, in
$Conf{CgiAdminUsers}. If you don't"
(Might be a runaway multi-line '' string starting on line 1857)
(Missing operator before t?)
Couldn't execute /etc/BackupPC/config.pl: syntax error at
/etc/BackupPC/config.pl line 1872, near "# by spaces, in
$Conf{CgiAdminUsers}. If you don't want "
BackupPC::Lib->new failed
[FAILED]
it has happened on an upgraded FC4, and a fresh install on RHEL3.
Any ideas?
TIA
Regards,
Les
-------------------------------------------------------------------------
Using Tomcat but need to do more? Need to support web services, security?
Get stuff done quickly with pre-integrated technology to make your job easier
Download IBM WebSphere Application Server v.1.0.1 based on Apache Geronimo
http://sel.as-us.falkag.net/sel?cmd=lnk&kid=120709&bid=263057&dat=121642
_______________________________________________
BackupPC-users mailing list
[email protected]
https://lists.sourceforge.net/lists/listinfo/backuppc-users
http://backuppc.sourceforge.net/