This is a continuation of the patch previously sent as a single patch. Additionally I added a patch cleaning up the FILE_SIZE_STREAM disambiguity. The problem is that we overloaded the inode size with a flag indicating that the inode belongs to a stream with undefined file size. The new patch solves this by adding extra flags to struct inode.
Signed-off-by: Sascha Hauer <[email protected]> --- Sascha Hauer (2): fs: track streaming and unknown-size files in dedicated inode fields fs: reject inodes whose size the superblock cannot address fs/devfs.c | 7 ++++++- fs/fs.c | 37 +++++++++++++++++++++++++++++++++---- fs/tftp.c | 2 +- include/linux/fs.h | 2 ++ 4 files changed, 42 insertions(+), 6 deletions(-) --- base-commit: 42e510a258d7c276c35f06c103e685c80d376eab change-id: 20260908-fs-filesize-fixes-2f932f665027 Best regards, -- Sascha Hauer <[email protected]>
