I  am planning to distribut my module, but am confused on what to call
it.

I have a series of modules in a directory that I will call Rtf2xml. (I
checked on Cpan, and don't believe this name space is taken.)

I named each module by a simple name--for example Pict.pm. In the main
script, I have:

use Rtf2xml::Pict
...
&Pict::process_pict()


In the actual module, I have:

package Pict;


Everything works fine this way. But when I look at other modules, I
notice that they use a different naming convention. 

My question is if I should follow this syntax:

package Rtf2xml::Pict # for the actual module

&Rtf::Pict::process_pict() # for calling on a subroutin in the pacage


I believe that the second way provides a more distinct namespace?

I *have* read the documentation on how to distribute a module, but I
couldn't follow most of the jargon. 

Thanks

Paul

-- 

************************
*Paul Tremblay         *
*[EMAIL PROTECTED]*
************************

-- 
To unsubscribe, e-mail: [EMAIL PROTECTED]
For additional commands, e-mail: [EMAIL PROTECTED]

Reply via email to