On Aug 4, Perl said:

>die "You must enter an argument. \n" if $#ARGV <0;

I'd suggest using:

  die ... if @ARGV == 0;

because it's easier to read and understand.

>$logfile = chomp ($ARGV);

Is that really your code?  That doesn't make any sense to me.  I think you
meant:

  $logfile = $ARGV[0];

There's no reason to chomp() here, and besides, chomp() doesn't return the
modified string, it returns a number.

-- 
Jeff "japhy" Pinyan         %  How can we ever be the sold short or
RPI Acacia Brother #734     %  the cheated, we who for every service
http://japhy.perlmonk.org/  %  have long ago been overpaid?
http://www.perlmonks.org/   %    -- Meister Eckhart



-- 
To unsubscribe, e-mail: [EMAIL PROTECTED]
For additional commands, e-mail: [EMAIL PROTECTED]
<http://learn.perl.org/> <http://learn.perl.org/first-response>


Reply via email to