Just a comment on some of the variable naming within the Cmake files. There
are already some folks embedding the entire boost-cmake distribution into
their own projects, then using "add_subdirectory()" to try and build just
the parts that they need. Since Cmake does not really have a namespace I
think that a few of the variables may need to be prefixed with "BOOST_":


 ENABLE_DEBUG                     ON
 ENABLE_MULTI_THREADED            ON
 ENABLE_RELEASE                   ON
 ENABLE_SHARED                    OFF
 ENABLE_SINGLE_THREADED           OFF
 ENABLE_STATIC                    ON

Probably should be BOOST_ ENABLE_DEBUG.... Or Boost-Cmake may start to have
some unintended name clashing. Plus this helps keep all the boost variables
together in the Cmake-GUI and CCMake applications.

Thoughts? 

Mike Jackson
<http://www.bluequartz.net>



_______________________________________________
Boost-cmake mailing list
Boost-cmake@lists.boost.org
http://lists.boost.org/mailman/listinfo.cgi/boost-cmake

Reply via email to