> > [Anthony Williams]
> > > On Windows, for example, you can use GlobalAlloc to
> > allocate some memory,
> > and
> > > you get an HGLOBAL back --- a handle to the memory.
[..]
> > This sounds like a perfect case where using a smart_PTR would be very
> > confusing, maybe dangerously so!

[Gennadiy]
> The only place where you will see usage of the name smart_ptr is somewhere
> deep in library code:
>
> typedef smart_ptr <...> GlobalMemoryHandler;
>
> After that you will use non-confusing name GlobalMemoryHandler.

It may work out that way in this case - but why not make the name
non-confusing in the first place?
You appear here to concede that it *is* confusing.
We are talking about smart_ptr and a potential smart_resource concept - not
GloalMemoryHandler - that was just an example of where the naming becomes
particularly confusing - whether it is buried deep in library code or not.

I still have yet to hear why you do not like the idea of putting these
concepts in their appropriate order?

Thanks for your comments,

Regards,

[)o
IhIL..

_______________________________________________
Unsubscribe & other changes: http://lists.boost.org/mailman/listinfo.cgi/boost

Reply via email to