David Abrahams wrote:
Dave Gomboc <[EMAIL PROTECTED]> writes:


Ah, naming again. My favourite. :-)

It's not my favourite, but it matters.



I like create_path_and_directory. I prefer this order of the two terms because logically the path exists before the directory itself does.


create_full_path(path, 'd')
create_full_path(path, 'f')

I'de like to get away from create. As I understand it, what we really want is to make sure a directory path actually exists without necessarily creating any directories. To me calling a create function for something that already exists should be an error. I can't see a reasonable way to have these semantics with create_directories.


What about something like this:

ensure_path_exists(path);

Thomas


_______________________________________________ Unsubscribe & other changes: http://lists.boost.org/mailman/listinfo.cgi/boost

Reply via email to