Hi Ray,
You wrote:
> I have a system I just had to rebuild due to disk failure. :=[[[
> I built a Fedora 33 release from the USB download and encountered a
> couple problems (one reported to redhat), but this one is with "df" and
> redhat does not cover that.
>
> Anyway, after I have been logged in a while DF emits an extra error
> line first before doing its normal job. If I re-login this goes away
> only to come back in time. I normally just suspend my computer so re-
> login only happens normally when I do a "dnf upgrade" and get a new OS.
>
> This does NOT happen on the other system I have which was upgraded from
> fedora32 to 33.
>
> Here is the first few lines from df - I cut the rest - note the first.
> Not a big issue, but annoying and confusing. Yes I am user 1000, of
> course.
>
> [ray <at> thoth ~]$ df
> df: /run/user/1000/doc: Operation not permitted
> Filesystem 1K-blocks Used Available Use% Mounted on
> devtmpfs 4007688 0 4007688 0% /dev
> ...
Apologies for the delayed response.
This issue should be fixed as of the following Gnulib commit:
$ commit 9a38d499ca16f2f4304992eb1ab0894cd0b478e1
Author: Kamil Dudka <[email protected]>
AuthorDate: Mon Jun 7 14:43:03 2021 +0200
Commit: Pádraig Brady <[email protected]>
CommitDate: Mon Jun 7 23:15:30 2021 +0100
mountlist: recognize fuse.portal as dummy file system
This was originally proposed at:
https://lists.gnu.org/archive/html/bug-gnulib/2021-02/msg00053.html
As the full review might take some time, would it be possible to apply
at least the part related to fuse.portal file systems? They started to
cause problems recently:
https://bugs.launchpad.net/ubuntu/+source/xdg-desktop-portal/+bug/1905623
https://github.com/muesli/duf/issues/35
https://bugzilla.redhat.com/1913358
That commit was included in coreutils-9.0.
Whether or not it was a coreutils bug is debatable. My understanding is
that statfs ("/run/user/1000/doc", ...) was returning EPERM on a FUSE
file system mounted by xdg-desktop-portal, which is a bit strange. You
can see more discussion about this here [1].
It looks like has since been fixed with this commit to provide a mostly
zero-ed out struct statfs without failing [2].
Also, I want to be clear that I am not blaming the xdg-desktop-portal
developers for this. I say that because people were pushy and quite rude
to them when reporting this [3][4], unfortunately.
Closing this one, thanks for the report!
Collin
[1]
https://askubuntu.com/questions/1227667/df-command-throws-error-on-run-user-1000-doc-folder
[2] https://github.com/flatpak/xdg-desktop-portal/pull/1807
[3] https://github.com/flatpak/xdg-desktop-portal/issues/512
[4] https://github.com/flatpak/xdg-desktop-portal/issues/553