Rosen Penev wrote:
For vectors and strings (what ddrescue uses) empty() is defined as 'size()
== 0'. So nothing is gained with this change.

I agree it's the same. Whether it's cleaner or not is subjective.

I generally find cleaner to avoid negations:

if( foo.size() && bar.size() )
if( !foo.empty() && !bar.empty() )


I can resubmit if you would like. My guess is no.

You guess well. :-) I never apply patches like this one. I directly modify the parts of the code that I think the patch improves, and ignore the rest.


Best regards,
Antonio.

_______________________________________________
Bug-ddrescue mailing list
Bug-ddrescue@gnu.org
https://lists.gnu.org/mailman/listinfo/bug-ddrescue

Reply via email to