This is a bug fix release -- there are certainly more than I would have predicted. Luckily for my ego, most are not new :-) The rm -i bug was introduced with the rewrite that appeared in fileutils-4.1.9.
Special thanks to Andreas Schwab (and SuSE, I presume) for two of the reports-and-fixes. There is one new feature: tail's sleep interval may now be specified as a floating point number. Jim ftp://alpha.gnu.org/gnu/fetish/coreutils-4.5.2.tar.gz (5.4 MB) ftp://alpha.gnu.org/gnu/fetish/coreutils-4.5.2.tar.bz2 (3.5 MB) http://fetish.sf.net/coreutils-4.5.2.tar.gz (5.4 MB) http://fetish.sf.net/coreutils-4.5.2.tar.bz2 (3.5 MB) And here are xdelta-style diffs ftp://alpha.gnu.org/gnu/fetish/coreutils-4.5.1-4.5.2.xdelta (600 KB) http://fetish.sf.net/coreutils-4.5.1-4.5.2.xdelta (600 KB) Here are GPG detached signatures: ftp://alpha.gnu.org/gnu/fetish/coreutils-4.5.2.tar.gz.sig ftp://alpha.gnu.org/gnu/fetish/coreutils-4.5.2.tar.bz2.sig http://fetish.sf.net/coreutils-4.5.2.tar.gz.sig http://fetish.sf.net/coreutils-4.5.2.tar.bz2.sig Here are the MD5 and SHA1 signatures: 28c7a2974fd3c0a4f8baf5c8edad9804 coreutils-4.5.2.tar.gz 131325047b6cd608faba0a1fa69e42de coreutils-4.5.2.tar.bz2 9d9bd174ef0339f1c8442ac78d91836b coreutils-4.5.1-4.5.2.xdelta 14077fd6e9c16302eb1659a62f8bf92ed0e08979 coreutils-4.5.2.tar.gz f3360dab7441107229552904d7576cb6e91e7eba coreutils-4.5.2.tar.bz2 c91ca09f99f75eefd9e4a322e9a9fc618dd4d5ba coreutils-4.5.1-4.5.2.xdelta NEWS: * `rm -i dir' (without --recursive (-r)) no longer recurses into dir * `tail -c N FILE' now works with files of size >= 4GB * `mkdir -p' can now create very deep (e.g. 40,000-component) directories * rmdir -p dir-with-trailing-slash/ no longer fails * printf now honors the `--' command line delimiter * od's 8-byte formats x8, o8, and u8 now work * tail now accepts fractional seconds for its --sleep-interval=S (-s) option ChangeLog entries: ********************************************************************** ChangeLog 5 Oct 2002 19:56:00 -0000 1.76 ********************************************************************** 2002-10-05 Jim Meyering <[EMAIL PROTECTED]> * Version 4.5.2. * src/remove.c (remove_entry) [ROOT_CAN_UNLINK_DIRS]: With `rm -i DIR', don't recurse into directory, DIR. Prompted by a report from Leonardo Milano. * tests/rm/i-no-r: New file/test, for the above fix. * tests/rm/Makefile.am (TESTS): Add i-no-r. * tests/tail-2/big-4gb: New file/test, for the fix of 2002-09-27. * tests/tail-2/Makefile.am (TESTS): Add big-4gb. 2002-10-03 Jim Meyering <[EMAIL PROTECTED]> * src/rm.c (AUTHORS): Mark translatable string with `N_ (...)'. * src/df.c (AUTHORS): Likewise. * src/du.c (AUTHORS): Likewise. * src/tail.c (AUTHORS): Likewise. * src/touch.c (AUTHORS): Likewise. 2002-10-02 Jim Meyering <[EMAIL PROTECTED]> * Makefile.am (SUBDIRS): Remove `old'. (EXTRA_DIST): List the files in old/. * configure.ac (AC_CONFIG_FILES): Remove old/* names. Suggestion from Akim Demaille. 2002-10-01 Jim Meyering <[EMAIL PROTECTED]> * src/sys2.h (SSIZE_MAX): Define. 2002-09-30 Jim Meyering <[EMAIL PROTECTED]> * src/csplit.c: Don't include stdlib.h here. It's already included via system.h. 2002-09-29 Jim Meyering <[EMAIL PROTECTED]> * src/tr.c (find_bracketed_repeat): Rearrange pointer/integer expression to avoid bogus warning from gcc. * src/cat.c (simple_cat): Use a temporary to avoid bogus warnings. (cat): Declare insize and outsize to be of type size_t, not int. Rearrange pointer/integer expressions to avoid bogus warnings. (main): Declare insize and outsize to be of type size_t, not int. * src/tail.c (parse_options): Give a sensible diagnostic for an invalid byte or line count. Reported by Mikko Tuumanen. * src/touch.c (main): Split a long line. * tests/du/Makefile.am (TESTS): Add slink. * tests/du/slink: New test for system.h change of 2002-08-31. In move mode, always first try to rename. Before, upon failure to rename a directory, this code would never attempt to rename any other file in that directory, but would thenceforth always copy. On some systems (e.g., NetApp's OnTap-6.4), renaming a directory may fail with EXDEV, yet renaming files within that directory to a newly-created destination directory succeeds. * src/copy.c (copy_internal): Remove local, move_mode; use x->move_mode instead. Based on a patch from Tom Haynes. 2002-09-28 Jim Meyering <[EMAIL PROTECTED]> * src/split.c (FAIL_ONLY_ONE_WAY): New macro. Factor out some duplication. (main): Use it. [case 'a']: Use strtoul rather than strtol to avoid compiler warnings. * src/sort.c (begfield, limfield): Rearrange comparisons to avoid compiler warnings. (fillbuf, keycompare): Cast literal `-1' to size_t in comparisons, to avoid compiler warnings. * src/shred.c (dopass): Use a uintmax_t temporary to avoid bogus compiler warnings. Fix things so `mkdir -p' can create very deep directories, e.g., mkdir -p $(perl -e 'print "a/" x 40000') now works. * src/mkdir.c (main): For --parents (-p), call make_path with the entire directory name, so we don't ever require that file operations like stat or chmod be performed on the entire command line argument. * makepath.c (make_path): Restore umask *before* creating the final component. 2002-09-27 Andreas Schwab <[EMAIL PROTECTED]> * src/tail.c (tail_bytes): Change type of bytes_remaining to off_t to avoid overflow. Reported by Hans Lermen. 2002-09-26 Jim Meyering <[EMAIL PROTECTED]> * src/install.c (get_ids): Use strtoul, not strtol. Remove some casts. 2002-09-25 Jim Meyering <[EMAIL PROTECTED]> * src/test.c (eaccess): Change type of local `euid' from int to uid_t and add a cast, to avoid a warning about `signed and unsigned type in conditional expression'. 2002-09-22 Jim Meyering <[EMAIL PROTECTED]> * src/rmdir.c: Include "dirname.h", for declaration of strip_trailing_slashes. * src/stat.c (PRIdMAX, PRIuMAX): Remove definitions. Now they're defined through system.h. * src/cp-hash.c, src/dd.c, src/df.c, src/du.c, src/ls.c, * src/stat.c, src/wc.c: Remove all inclusions of inttypes.h, since it's already included from sys2.h via system.h. * Use automake-1.6f. Regenerate dependent files. * src/Makefile.am (PERL): Remove duplicate definition. fmt's -s, -t, -c options didn't work properly for long lines. Since get_line may end up calling put_paragraph (for long lines), be sure to set global, `other_indent', before it is used there. * src/fmt.c (set_other_indent): New function, factored out of... (get_paragraph): ... here. Call it. (get_line): Call set_other_indent before calling flush_paragraph, which calls fmt_paragraph, which in turn calls put_paragraph, which uses other_indent. * tests/fmt/Makefile.am (TESTS): Add long-line. * tests/fmt/long-line: New file/test, for the above fix. 2002-09-21 Jim Meyering <[EMAIL PROTECTED]> * src/od.c: No longer include deprecated <values.h>. It was required solely for now-removed reference to BITSPERBYTE. * src/install.c: Likewise. Suggestion from Bruno Haible. 2002-09-06 Andreas Schwab <[EMAIL PROTECTED]> `rmdir -p dir-specified-with-trailing-slash/' would fail. * src/rmdir.c (remove_parents): Strip trailing slashes. 2002-09-20 Jim Meyering <[EMAIL PROTECTED]> * tests/rmdir/t-slash: New file/test, for the above fix. * tests/rmdir/Makefile.am (TESTS): Add t-slash. * Makefile.maint (announcement): Arrange to gpg-sign the message. Add a URL for each detached signature file. 2002-09-07 Bruno Haible <[EMAIL PROTECTED]> * configure.ac: Add need-ngettext to AM_GNU_GETTEXT invocation. 2002-09-18 Jim Meyering <[EMAIL PROTECTED]> `od -t x8' used the wrong (`l'-prefixed) printf format. Likewise for the o8 and u8 formats. * src/od.c (ISPEC_TO_FORMAT): Define macro. (decode_one_format): Use PRIdMAX, PRIoMAX, etc. for LONG_LONG. Reported by Arun Sharma. 2002-09-17 Jim Meyering <[EMAIL PROTECTED]> * src/sys2.h (PRIdMAX, PRIoMAX, PRIuMAX, PRIxMAX): Define if necessary. From gettext's intl/loadmsgcat.c. * tests/od/x8: New file/test, for the above fix. * tests/od/Makefile.am (TESTS): Add x8. 2002-09-15 Jim Meyering <[EMAIL PROTECTED]> * Use autoconf-2.54. Regenerate dependent files. * src/csplit.c (get_format_width): Add cast to avoid warning about `signed and unsigned type in conditional expression'. 2002-09-14 Jim Meyering <[EMAIL PROTECTED]> * src/who.c (print_user): Change type of local to size_t to avoid warnings about `comparison between signed and unsigned'. * src/ptx.c (generate_all_output): Likewise. * src/dd.c (main, skip): Add casts to avoid warnings about `comparison between signed and unsigned'. * src/id.c (print_full_info, print_group_list): Add casts to avoid warnings about `signed and unsigned type in conditional expression'. * src/md5sum.c: Change type of global, digest_hex_bytes, to size_t to avoid warnings about `comparison between signed and unsigned'. (split_3): Change parameter names to be readable and add comment. Clean up the test for whether a line may be ignored. 2002-09-13 Jim Meyering <[EMAIL PROTECTED]> * src/printf.c (main): Handle leading command line argument of `--'. Reported by Raul: DervishD <[EMAIL PROTECTED]> * tests/misc/printf: New file: test for the above. * tests/misc/Makefile.am (TESTS): Add printf. * src/date.c (usage): Explain that %S's range of [0..60] is required -- rather than 0..59 -- to accommodate the occasional positive leap second. Reported by Richard Neill. 2002-09-12 Jim Meyering <[EMAIL PROTECTED]> * src/Makefile.am (nanosec_libs): Define. (sleep_LDADD, tail_LDADD): Use it here. Factor nanosleep-related code into ../lib/xnanosleep.c. * src/sleep.c: Include xnanosleep.h. Factor out fenv.h-related code. (timespec_subtract): Remove function. (main): Remove code that deals with computing start and stop times as well as the loop around nanosleep. Now that's in xnanosleep.c. Allow S (in --sleep-interval=S) to be a floating point value. * src/tail.c: Include xnanosleep.h and xstrtod.h. Move declaration of global variable, sleep_interval, to ... (main): ...here. (usage): Update description of --sleep-interval option. (tail_forever): New parameter, sleep_interval. Update caller. Use xnanosleep, rather than sleep. (parse_options): New parameter, sleep_interval. Update caller. Use xstrtod, now that we accept floating point values. Prompted by a patch from Augey Mikus. 2002-09-06 Jim Meyering <[EMAIL PROTECTED]> * src/remove.c (prompt): Change comment to give a better note to translators. From Michael Piefel. 2002-09-02 Jim Meyering <[EMAIL PROTECTED]> * README: A good problem report/patch includes diffs against the most recent test release. * src/pathchk.c (NEED_PATHCONF_WRAPPER): Define. (pathconf_wrapper): Define only if NEED_PATHCONF_WRAPPER is set. * src/kill.c (print_table_row): Use an unsigned type for widths to avoid warning about comparison between signed and unsigned. (list_signals): Likewise. * src/od.c (skip): Add a cast to avoid warning about comparison between signed and unsigned. * src/install.c (get_ids): Likewise. Also rearrange range-checking comparisons to make them more readable. ********************************************************************** doc/ChangeLog 13 Sep 2002 09:31:32 -0000 1.60 ********************************************************************** 2002-09-13 Jim Meyering <[EMAIL PROTECTED]> * coreutils.texi (tail invocation): In --sleep-interval=NUMBER, NUMBER may now be a floating point number. (stat invocation): Remove references to now-removed %S and %C. (Time directives) [%S]: Explain why the range is [0..60]. ********************************************************************** lib/ChangeLog 28 Sep 2002 07:55:16 -0000 1.379 ********************************************************************** 2002-09-28 Jim Meyering <[EMAIL PROTECTED]> * makepath.c (make_path): Restore umask *before* creating the final component. 2002-09-25 Paul Eggert <[EMAIL PROTECTED]> * fsusage.c [! HAVE_INTTYPES_H && HAVE_STDINT_H] Include <stdint.h>. (UINTMAX_MAX) [!defined UINTMAX_MAX]: New macro. (PROPAGATE_ALL_ONES): Work even if X is unsigned and narrower than int. Work more efficiently if X is the same width as uintmax_t. Do not compare X to -1, to avoid bogus compiler warning. (get_fs_usage): (uintmax_t) -1 -> UINTMAX_MAX to avoid a cast. Don't assume that f_frsize and f_bsize are the same type. 2002-09-25 Jim Meyering <[EMAIL PROTECTED]> * fsusage.c: Remove unneeded parentheses around operands of `defined'. * safe-read.c (safe_read): Make comment more precise: upon error, it returns -1. 2002-09-22 Jim Meyering <[EMAIL PROTECTED]> * makepath.c (make_path): Minor reformatting. 2002-09-14 Paul Eggert <[EMAIL PROTECTED]> * lib/xnanosleep (xnanosleep): Return -1 on failure, not 1, for consistency with nanosleep. Check errno after nanosleep returns -1. 2002-09-11 Jim Meyering <[EMAIL PROTECTED]> * xnanosleep.c, xnanosleep.h: New files, factored out of sleep.c. * Makefile.am (libfetish_a_SOURCES): Add them. 2002-09-04 Jim Meyering <[EMAIL PROTECTED]> * addext.c (addext): Add a cast to avoid gcc's warning about `comparison between signed and unsigned'. * sig2str.c (str2signum, sig2str): Declare loop index variables to be of type size_t so that they match type of upper bound, thus avoiding warning about `comparison between signed and unsigned'. ********************************************************************** m4/ChangeLog 28 Sep 2002 22:03:31 -0000 1.432 ********************************************************************** 2002-09-29 Jim Meyering <[EMAIL PROTECTED]> * gettext.m4 (AM_INTL_SUBDIR): Don't require gt_HEADER_INTTYPES_H. It's not necessary with autoconf-2.54. 2002-09-28 Jim Meyering <[EMAIL PROTECTED]> * getgroups.m4 (jm_FUNC_GETGROUPS): Rewrite to use AC_FUNC_GETGROUPS and (if needed) to call AC_LIBOBJ and to set GETGROUPS_LIB. * jm-macros.m4 (jm_MACROS): Don't set GETGROUPS_LIB here; now it's done via getgroups.m4's wrapper function. * strerror_r.m4: Remove file -- now it's part of autoconf-2.54. Reported by Akim Demaille. 2002-09-25 Jim Meyering <[EMAIL PROTECTED]> * gettext.m4: Upgrade to gettext-0.11.5. 2002-09-07 Bruno Haible <[EMAIL PROTECTED]> * host-os.m4 (UTILS_HOST_OS): Add a case for freebsd*-gnu*. 2002-09-17 Jim Meyering <[EMAIL PROTECTED]> * jm-macros.m4 (jm_MACROS): Require gt_INTTYPES_PRI. * inttypes-pri.m4 (gt_INTTYPES_PRI): New file, mostly from gettext. 2002-09-16 Jim Meyering <[EMAIL PROTECTED]> * prereq.m4: Forbid symbols matching ^jm_[A-Z]. (jm_PREREQ_QUOTEARG): Add jm_FUNC_MEMCMP. From Akim Demaille. * error.m4 (jm_PREREQ_ERROR): Check for libintl.h. Reported by Akim Demaille. 2002-09-13 Jim Meyering <[EMAIL PROTECTED]> * jm-macros.m4 (jm_MACROS): Require autoconf-2.54. 2002-09-09 Jim Meyering <[EMAIL PROTECTED]> * getloadavg.m4: Remove file -- now it's part of autoconf-2.53c. * jm-macros.m4: Use AC_CONFIG_LIBOBJ_DIR(lib) to tell the new AC_FUNC_GETLOADAVG where to find getloadavg.c. 2002-09-03 Jim Meyering <[EMAIL PROTECTED]> * gnu-source.m4: Remove file -- now it's part of autoconf-2.53c. * mbstate_t.m4: Likewise. * fnmatch.m4: Likewise. ********************************************************************** po/ChangeLog 29 Sep 2002 17:12:36 -0000 1.5 ********************************************************************** 2002-09-25 gettextize <[EMAIL PROTECTED]> * Makefile.in.in: Upgrade to gettext-0.11.5. 2002-09-16 Jim Meyering <[EMAIL PROTECTED]> * LINGUAS: Add be (Belarusian). 2002-09-02 Jim Meyering <[EMAIL PROTECTED]> * LINGUAS: Add lg (Luganda).
msg01919/pgp00000.pgp
Description: PGP signature