Hi Akim,
> bitset: rename BITSET_VARRAY as BITSET_VECTOR
Looks good to me.
> I have a problem with bitset/expandable.[hc], which
> defines ebitset_*: it corresponds to BITSET_TABLE.
>
> BITSET_TABLE: Expandable table of pointers to arrays of bits
> (variable size, less storage for large sparse sets).
> Faster than BITSET_LIST for random access.
>
> So, for consistency with the others, I'd to rename either the
> file, or the enum: would you prefer BITSET_EXPANDABLE, ebitset
> and bitset/expandable.h, or BITSET_TABLE, tbitset and
> bitset/table.h?
I would prefer the term "table" here, because
- BITSET_VECTOR is also expandable,
- The data structure is essentially the same as the "page tables"
in the Linux kernel or the "3-level tables" in glibc [1],
except that here it's only a 2-level table. So, you see, the term
"table" is already in use for this kind of data structure.
Bruno
[1] https://sourceware.org/git/?p=glibc.git;a=blob;f=locale/programs/3level.h