Pavel Pisa commented: 
https://gitlab.rtems.org/rtems/rtos/rtems/-/merge_requests/1271#note_155420


Generally it worth to resolve conflicting pins in TMS570LC4357 header. But I 
expect that they are result of mapping all pins described on TMS570LC43 HDK 
where some groups of pin have alternatives. So may it be the conflicting pins 
should be listed on some alternatives fragments.

There seems to be problem, that even definitions of some pins and functions 
combinations are missing. I think (not sure) that we have that right on 
TMS570LS3137... It would worth to add at least definitions of pins/balls used 
for MII on 43 Launchpad see 
https://gitlab.rtems.org/rtems/pkg/rtems-lwip/-/merge_requests/48 and commit 
[temslwip/tms570: Bringup lwIP network stack on TI TMS570LC4357 BSP 
(LaunchXL2-570LC43)](https://gitlab.rtems.org/rtems/pkg/rtems-lwip/-/merge_requests/48/diffs?commit_id=a92a54494dde3d5c1f1fb5aa36c03231a37dad28).
 If I remember well we have prepared some really basic list of pins for 4357 
somehow after main 3137 work by some scripting, but we have not own 4357 at 
that time nor finished pins and BSP, it has been done by others. Important part 
to allows pimux with separate inputs mapping specific to 4357 has been 
introduced
```
#define TMS570_PIN_WITH_IN_ALT(pin_num_and_fnc, pin_in_alt_num_and_fnc) \
  ((pin_num_and_fnc) | ((pin_in_alt_num_and_fnc) << TMS570_PIN_IN_ALT_SHIFT))
```  
So for pins which have this another register to choose input from peripheral it 
is necessary to define what should be written to regular MMR (0 to 37) and what 
into this another direction MMR (80 to 80).

It would be ideal to coordinate changes with @ar-in0 to get correct names into 
RTEMS system, and add an option for build to switch to Launchpad from default 
HDK. Then the LwIP change can be more readable and work for both Lauchapd and 
HDKs.

I try to help as my time allows.

-- 
View it on GitLab: 
https://gitlab.rtems.org/rtems/rtos/rtems/-/merge_requests/1271#note_155420
You're receiving this email because of your account on gitlab.rtems.org. 
Unsubscribe from this thread: 
https://gitlab.rtems.org/-/sent_notifications/4-3wu0jo1paaatlf9nwf6qjm17h-1d/unsubscribe
 | Manage all notifications: https://gitlab.rtems.org/-/profile/notifications | 
Help: https://gitlab.rtems.org/help


_______________________________________________
bugs mailing list
[email protected]
http://lists.rtems.org/mailman/listinfo/bugs

Reply via email to