On 9/21/14 3:51 PM, Bradford Wetmore wrote:
Hi Sean/Mandy/Erik/Magnus/Alan/David/others, Please review: JDK-8058845 : Update JCE environment for build improvements http://cr.openjdk.java.net/~wetmore/8058845/
The change looks fine in general. Some minor comments: javax/crypto/Cipher.java line 264: this is not part of your change but caught my attention. I wonder if you want to include some descriptive message in NPE to help diagnosing the problem especially in jdk9 where future changes will be made to support modules. javax/crypto/JceSecurity.java line 79: this could be (PrivilegedExceptionAction<Void>) as the return value is ignored It may be better to rename URLVerifier to ProviderVerifier as it verifies the security provider of the given codebase. URLVerifier might give an interpretation of verifying the given URL. Similarly, the verifyProviderJar method can be renamed to verifyProvider. javax/crypto/URLVerifier.java line 117: should it be pae.getCause()? Mandy