On Mon, 7 Feb 2022 10:55:52 GMT, Andrew Haley <[email protected]> wrote:
>> Alan Hayward has updated the pull request incrementally with one additional
>> commit since the last revision:
>>
>> Documentation updates
>
> src/hotspot/cpu/aarch64/macroAssembler_aarch64.cpp line 5293:
>
>> 5291: // Create an additional frame for a function.
>> 5292: void MacroAssembler::enter_subframe() {
>> 5293: // Addresses can only be signed once, so strip it first. PAC safe
>> because the value is not
>
> This needs a more descriptive name. `enter_and_sign()` ? No, that's not right
> either. How do we come up with a name that's more descriptive?
Because enter always enters a subframe. That's what it's for.
-------------
PR: https://git.openjdk.java.net/jdk/pull/6334