On Mon, 28 Mar 2022 12:20:44 GMT, Thomas Stuefe <stu...@openjdk.org> wrote:

>> Christian Hagedorn has updated the pull request with a new target base due 
>> to a merge or a rebase. The pull request now contains 54 commits:
>> 
>>  - Updating some comments
>>  - Cleanup loading dwarf file and add summary
>>  - Review comments of first pass by Thomas except dwarf file loading
>>  - Merge branch 'master' into JDK-8242181
>>  - Make dwarf tag NOT_PRODUCT
>>  - Change log_* to log_develop_* and log_warning to log_develop_info
>>  - Update test/hotspot/jtreg/runtime/ErrorHandling/TestDwarf.java
>>    
>>    Co-authored-by: Erik Joelsson <37597443+erik...@users.noreply.github.com>
>>  - Update test/hotspot/jtreg/runtime/ErrorHandling/TestDwarf.java
>>    
>>    Co-authored-by: Erik Joelsson <37597443+erik...@users.noreply.github.com>
>>  - Better formatting of trace output
>>  - some code move and more cleanups
>>  - ... and 44 more: 
>> https://git.openjdk.java.net/jdk/compare/efd3967b...5bea4841
>
> src/hotspot/share/utilities/elfFile.hpp line 217:
> 
>> 215:    public:
>> 216:     DwarfFilePath(const char* filename, char* buf, size_t buf_len) : 
>> _filename(filename), _path(buf), _path_len(buf_len) {
>> 217:       size_t offset = (strlen(filename) + 4) >> 2u;
> 
> Why not use align()? Would be more readable.

See also comments in load_dwarf_file(). I'd really be more happy with more 
verifications.

-------------

PR: https://git.openjdk.java.net/jdk/pull/7126

Reply via email to