On Mon, 29 Jun 2026 21:17:47 GMT, Dean Long <[email protected]> wrote:

>> David Simms has updated the pull request with a new target base due to a 
>> merge or a rebase. The pull request now contains 2859 commits:
>> 
>>  - Merge branch '8317277' into jep401_sub_review_8317278
>>  - Merge remote-tracking branch 'valhalla/lworld' into 8317277
>>  - Merge
>>    
>>    Merge jdk-28+4
>>  - 8386963: [lworld] Improve the exception message from Object 
>> synchronization methods on value objects
>>    
>>    Reviewed-by: dholmes, alanb
>>  - 8387300: [lworld] Minor review comments in javac
>>    
>>    Reviewed-by: vromero
>>  - 8387192: [lworld] Review comment drop for core libs
>>    
>>    Reviewed-by: jvernee, vromero
>>  - 8386999: [lworld] C2: assert(is_dead_loop_safe()) failed: shouldn't be 
>> cleared yet
>>    
>>    Reviewed-by: qamai, vlivanov
>>  - 8386787: [lworld] 
>> compiler/valhalla/inlinetypes/TestValueConstruction.java#StressIncrementalInliningDontInlineMyAbstractInit
>>  timed out
>>    
>>    Reviewed-by: phubner, chagedorn
>>  - 8386995: [lworld] Duplicate value classes are a preview feature warning
>>    
>>    Reviewed-by: alanb, vromero
>>  - 8383389: [lworld] Augment AOTMapLogger::print_oop_details to support flat 
>> arrays with oops
>>    
>>    Reviewed-by: iklam, fparain
>>  - ... and 2849 more: https://git.openjdk.org/jdk/compare/193de1b1...cffcfb57
>
> src/hotspot/share/c1/c1_GraphBuilder.cpp line 1906:
> 
>> 1904:         if (field_type->is_loaded() && field_type->is_inlinetype() && 
>> field_type->as_inline_klass()->is_empty() &&
>> 1905:             (!method()->is_class_initializer() || field->is_flat())) {
>> 1906:           // Storing to a field of an empty, null-free inline type 
>> that is already initialized. Ignore.
> 
> This code pattern and comment occur twice in C1 and once in C2, but the 
> comment is confusing.  It is the field type that is empty, not the field's 
> holder/container.

I will add a helper method and fix the comment.

-------------

PR Review Comment: https://git.openjdk.org/jdk/pull/31122#discussion_r3519054678

Reply via email to