This series adds two namespaces-related applets reimplementing most arguments supported by their upstream util-linux counterparts.
The fourth patch is an optional code shrink. v2: - v1 was badly rebased and patch 3/4 didn't compile - fixed it - added some parenthesis for better readability in patch 3/4 v1: http://lists.busybox.net/pipermail/busybox/2016-March/083957.html Bartosz Golaszewski (4): libbb: add BIT() macro unshare: new applet nsenter: new applet namespace utils: code shrink include/libbb.h | 2 + util-linux/namespace.c | 34 ++++ util-linux/namespace.h | 27 ++++ util-linux/nsenter.c | 343 +++++++++++++++++++++++++++++++++++++++ util-linux/unshare.c | 429 +++++++++++++++++++++++++++++++++++++++++++++++++ 5 files changed, 835 insertions(+) create mode 100644 util-linux/namespace.c create mode 100644 util-linux/namespace.h create mode 100644 util-linux/nsenter.c create mode 100644 util-linux/unshare.c -- 2.1.4 _______________________________________________ busybox mailing list busybox@busybox.net http://lists.busybox.net/mailman/listinfo/busybox