This series adds two namespaces-related applets reimplementing most
arguments supported by their upstream util-linux counterparts.

The fifth patch is an optional code shrink.

v5:
- fixed the define guard in namespace.h to make it consistent with the
  rest of the codebase
- added a separate patch implementing a macro for calculating the
  string buffer size needed to store an integer type and used it in
  the new applets

v4:
- split the namespace structure into the read-only and modifiable
  parts
- made the read-only definition const and moved it out of the main
  function in both applets
- moved the position indicators to an enum and replaced all the
  ARRAY_SIZE() macros with NS_COUNT constant defined there
- fixed some whitespace errors

v3:
- moved the namespace positions into an enum for better readability

v2:
- v1 was badly rebased and patch 3/4 didn't compile - fixed it
- added some parenthesis for better readability in patch 3/4

v1: http://lists.busybox.net/pipermail/busybox/2016-March/083957.html

Bartosz Golaszewski (5):
  libbb: add BIT() macro
  libbb: INT_BUF_MAX(): new macro
  unshare: new applet
  nsenter: new applet
  namespace utils: code shrink

 include/libbb.h        |   3 +
 util-linux/namespace.c |  34 ++++
 util-linux/namespace.h |  27 +++
 util-linux/nsenter.c   | 351 +++++++++++++++++++++++++++++++++++++++
 util-linux/unshare.c   | 443 +++++++++++++++++++++++++++++++++++++++++++++++++
 5 files changed, 858 insertions(+)
 create mode 100644 util-linux/namespace.c
 create mode 100644 util-linux/namespace.h
 create mode 100644 util-linux/nsenter.c
 create mode 100644 util-linux/unshare.c

-- 
2.1.4

_______________________________________________
busybox mailing list
busybox@busybox.net
http://lists.busybox.net/mailman/listinfo/busybox

Reply via email to