Hello,

2017-02-09 15:48 GMT+01:00 Kang-Che Sung <explore...@gmail.com>:
> Signed-off-by: Kang-Che Sung <explore...@gmail.com>
> ---
>  modutils/modprobe-small.c | 3 ++-
>  1 file changed, 2 insertions(+), 1 deletion(-)
>
> diff --git a/modutils/modprobe-small.c b/modutils/modprobe-small.c
> index 52765bc99..43625490b 100644
> --- a/modutils/modprobe-small.c
> +++ b/modutils/modprobe-small.c
> @@ -79,6 +79,7 @@ int lsmod_main(int argc UNUSED_PARAM, char **argv 
> UNUSED_PARAM)
>  #define is_rmmod    (ENABLE_RMMOD    && (ONLY_APPLET || applet_name[0] == 
> 'r'))
>
>  enum {
> +       DEPMOD_OPT_n = (1 << 0), /* dry-run, print to stdout */

Why not call it OPT_n? Is it used somewere else?

>         OPT_q = (1 << 0), /* be quiet */
>         OPT_r = (1 << 1), /* module removal instead of loading */
>  };
> @@ -477,7 +478,7 @@ static int start_dep_bb_writeout(void)
>         int fd;
>
>         /* depmod -n: write result to stdout */
> -       if (applet_name[0] == 'd' && (option_mask32 & 1))
> +       if (is_depmod && (option_mask32 & DEPMOD_OPT_n))
>                 return STDOUT_FILENO;
>
>         fd = open(DEPFILE_BB".new", O_WRONLY | O_CREAT | O_TRUNC | O_EXCL, 
> 0644);
> --
> 2.11.0

Cheers,
Xabier Oneca_,,_
_______________________________________________
busybox mailing list
busybox@busybox.net
http://lists.busybox.net/mailman/listinfo/busybox

Reply via email to