Overall the code was very good but there are some areas which we can improve
on.

In summary, the code should be better organized so that the edge cases do
not affect the understandability of the code.

We saw several instances where the same method was called with different
param values (e.g. prefetch), and the execution flow depended on the value
of this passed param. The proper OO way of doing this  is to introduce two
methods. Please take this into consideration & fix all such areas.

Thanks
Azeez



On Thu, Sep 23, 2010 at 3:44 PM, Amani Soysa <am...@wso2.com> wrote:

> Code Review Notes
>
>    - Consider generating a single operation for batch request operations
>    other than getting two operations when needed.
>    - isBatchRequest -DBUtils.setBatchProcessing(true) ---> should not set
>    flags like this. (it should be like start begin transaction, commit and
>    abort) should refactor
>    - doFinalize method name should change (better terminology)
>    - Better documentation on prefetchdataInfo
>    - Document  prefectDataInfor -> excute method parameters
>    - Refactor overall batch request / boxcarring code.
>    - isHasResult method should be renamed (auto generated code)
>    - Validate call querry group sections.
>
>
> Regards,
> Amani
>
> _______________________________________________
> Carbon-dev mailing list
> Carbon-dev@wso2.org
> https://mail.wso2.org/cgi-bin/mailman/listinfo/carbon-dev
>
>


-- 
*Afkham Azeez*
Senior Software Architect & Senior Manager; WSO2, Inc.; http://wso2.com,
*
*
*Member; Apache Software Foundation;
**http://www.apache.org/*<http://www.apache.org/>
*
email: **az...@wso2.com* <az...@wso2.com>* cell: +94 77 3320919
blog: **http://blog.afkham.org* <http://blog.afkham.org>*
twitter: **http://twitter.com/afkham_azeez*<http://twitter.com/afkham_azeez>
*
linked-in: **http://lk.linkedin.com/in/afkhamazeez*
*
*
*Lean . Enterprise . Middleware*
_______________________________________________
Carbon-dev mailing list
Carbon-dev@wso2.org
https://mail.wso2.org/cgi-bin/mailman/listinfo/carbon-dev

Reply via email to