Brian, In my opinion, when you are making very small strings, & is not going to be different than "#" in terms of performance, so you have to go with which ever is easier for the situation. Also take into account which makes the code easier to read / maintain.
Which is easier to read: <cfset FORM[ "hot_girl_#i#" ] = "molly" /> .... Or ... <cfset FORM[ "hot_girl_" & i ] = "molly" /> It's up to you. To me, the use of ## makes for a more readable string and does not distract from the overall intention of the line. But again, my option. However, if you are going to be making large strings, ie. LOTS of concatination, be sure to use the Java string buffer with the Append() method. That probably doesn't apply to what you are talking about, so I won't go into it... Just keep it in the back of your mind. ....................... Ben Nadel www.bennadel.com -----Original Message----- From: Brian Dumbledore [mailto:[EMAIL PROTECTED] Sent: Monday, July 24, 2006 10:32 AM To: CF-Talk Subject: making strings.. good practice?? I know the subject line is a bit foggy, but I was going through some code (not mine) a while back and found the coder doing... <cfset a="#b# blah blah #c#"> I am not old enough with CF and I found this kind of usage peculiar as against "&" ing the variables and string literals all the time. Though the above way looks easier and cleaner, I somehow feel it is a bad practice. What do you all have to say regarding this??? Thanks for your time.. ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~| Introducing the Fusion Authority Quarterly Update. 80 pages of hard-hitting, up-to-date ColdFusion information by your peers, delivered to your door four times a year. http://www.fusionauthority.com/quarterly Archive: http://www.houseoffusion.com/groups/CF-Talk/message.cfm/messageid:247511 Subscription: http://www.houseoffusion.com/lists.cfm/link=s:4 Unsubscribe: http://www.houseoffusion.com/cf_lists/unsubscribe.cfm?user=89.70.4