<cfif (form["editor_" & ee] is not "" and form["editor_" & ee] is not
"other") or (form["editor_" & ee] is "other" and form["e_fname_" & ee]
is not "" and form["e_lname_" & ee] is not "")>
        <!--- action: do something --->
</cfif>

That should do what you want. It also eliminates the use of evaluate().

If you want to keep it as two separate <cfif>s for clarity, you could do

<cfif (form["editor_" & ee] is not "">
        <cfif form["editor_" & ee] is not "other") or (form["e_fname_" &
ee] is not "" and form["e_lname_" & ee] is not "")>


-----Original Message-----
Alright, my brain is locked-up today, so I'm just going to ask.
I need to make a set of cfif statements to so that if the dropdown value
is '' then it skips the action.  If the dropdown is 'other', then it
needs to check to see if fname and lname both have values before it does
the action.  If the dropdown is anything else, then it does the action
but doesn't need to do the fname, lname check.

Do I just need to have the action in there twice?  If so, I can make a
file out of it and include it.


here's my current failure:
<cfloop from="1" to="#Form.editorcount#" index="ee">
       <cfif evaluate("Form.editor_#ee#") NEQ ''>
              <cfif evaluate("Form.e_fname_#ee#") NEQ '' OR evaluate
("Form.e_lname_#ee#") NEQ ''>
                                                
                   action: do something

             </cfif>
       </cfif>
</cfloop>

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~|
Deploy Web Applications Quickly across the enterprise with ColdFusion MX7 & 
Flex 2
Free Trial 
http://www.adobe.com/products/coldfusion/flex2/?sdid=RVJU

Archive: 
http://www.houseoffusion.com/groups/CF-Talk/message.cfm/messageid:276214
Subscription: http://www.houseoffusion.com/groups/CF-Talk/subscribe.cfm
Unsubscribe: 
http://www.houseoffusion.com/cf_lists/unsubscribe.cfm?user=11502.10531.4

Reply via email to