I'd be leery of something that says, "always".

Sometimes, it's OK to consider the readability/maintainability factor.

On Wed, Jul 15, 2009 at 2:08 PM, Eric Cobb <cft...@ecartech.com> wrote:

>
> According to this "Performance tuning for ColdFusion applications" post,
> you should always use compare() or compareNoCase() instead of the IS NOT
> operator, and you should use listFindNoCase() or listFind() instead of
> the IS and OR operators.
>
>
> http://www.adobe.com/devnet/coldfusion/articles/coldfusion_performance_04.html
>
>
> Thanks,
>
> Eric Cobb
> Certified Macromedia ColdFusion MX 7 Developer
> http://www.cfgears.com
>
>
> Jason Fisher wrote:
> > I have long been in the habit of using EQ and NEQ (and now moving to ==
> and !=) for numbers in all cases, since there is no such thing as 'sort of
> equivalent', like there is with strings ('foo IS FOO' etc).  For strings I
> use IS, unless case is important, and then I use CompareNoCase().
> >
> >
>
> 

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~|
Want to reach the ColdFusion community with something they want? Let them know 
on the House of Fusion mailing lists
Archive: 
http://www.houseoffusion.com/groups/cf-talk/message.cfm/messageid:324556
Subscription: http://www.houseoffusion.com/groups/cf-talk/subscribe.cfm
Unsubscribe: http://www.houseoffusion.com/cf_lists/unsubscribe.cfm?user=89.70.4

Reply via email to