Paul,

I use the underscore and mixed case for tags.  The most important thing is
to find a style that makes sense to you (and your team) and conform to it
throughout your projects.  I hate doing application mods where the coding is
inconsistent. Of course with the case-insensitive nature of CF, it's largely
a matter of readability.  Also, I would point out that using the underscore
may cause confusion in the new world of flash remoting - where underscores
provide functionality in some cases. Finally, if you use the underscore for
variable names in cf 4-5, watch out for automatically evaluated variable
extensions in the form scope (_date, _number etc.).  This can cause a
ticklish error that is difficult to troubleshoot.

Mark

-----Original Message-----
From: Paul Giesenhagen [mailto:[EMAIL PROTECTED]]
Sent: Friday, July 05, 2002 9:14 AM
To: CF-Talk
Subject: OT: Naming Convention choice


Curious as to which one people prefer.

<cfquery datasource="QueryName" ...>

OR

<cfquery datasource="query_name" ...>

Also, out of curiosity these too:

<CFQUERY DATASOURCE...> (all caps)

Or

<cfquery datasource ...>

Thanks
Paul Giesenhagen
QuillDesign


______________________________________________________________________
Get the mailserver that powers this list at http://www.coolfusion.com
FAQ: http://www.thenetprofits.co.uk/coldfusion/faq
Archives: http://www.mail-archive.com/cf-talk@houseoffusion.com/
Unsubscribe: http://www.houseoffusion.com/index.cfm?sidebar=lists

Reply via email to