In http://reviews.llvm.org/D10839#197340, @rengolin wrote:

> Hi Alexandros,
>
> Thanks for the patch. I'm really happy that we can now change everything else 
> and not need to change the TargetParser any more. This means we're 
> stabilising the interface, and soon will be time to move it inside the new 
> Tuple class.
>
> About your patch, it's overall good, but I have a few minor comments inline.
>
> cheers,
> --renato


Thanks for the feedback. I have already made some changes and I will upload a 
new patch soon. Regarding the odd variable name? (it was not quite clear what I 
should change)


REPOSITORY
  rL LLVM

================
Comment at: lib/Basic/Targets.cpp:4489
@@ +4488,3 @@
+                       (ArchVersion == 5 && CPUAttr.count('E')));
+    bool is32Bit = (!IsThumb || supportsThumb2(CPUAttr));
+    if (is5EOrAbove && is32Bit && (CPUProfile != "M" || CPUAttr  == "7EM"))
----------------
rengolin wrote:
> This variable name is odd...
Are you referring to "is32Bit"? Any suggestions?

http://reviews.llvm.org/D10839

EMAIL PREFERENCES
  http://reviews.llvm.org/settings/panel/emailpreferences/



_______________________________________________
cfe-commits mailing list
cfe-commits@cs.uiuc.edu
http://lists.cs.uiuc.edu/mailman/listinfo/cfe-commits

Reply via email to